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Getting started with CuteFTP 

Professional 
If you're new to the Internet or to CuteFTP Professional, here's the information you need to 
get started. 
 

• CuteFTP Professional's main screen 
• Making your first connection 
• Transferring files and folders 
• What's new 

 

 
Support   
Questions? Navigate to http://www.globalscape.com/support for information on customer 
service, technical support, software registration, product manuals, and downloads, as well as 
access to GlobalSCAPE's Knowledge Base and FAQs. 
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CuteFTP 7 Professional New Features 
New features for CuteFTP Professional include: 

• Transfer files faster using automatic streaming compression to servers supporting the 
new MODE Z command. 

• Transfer files faster over poor connections such as satellite links and legacy CDMA 
wireless connections by controlling CuteFTP’s Send and Receive Buffers. 

• View your local and remote images using Thumbnail View just like in Windows 
Explorer.  

• Navigate local and remote directories with a single click when matching directory 
structures are present using Lockstep Folder Navigation. 

• Perform simultaneous bandwidth intensive tasks on your computer by setting the 
maximum allowed bandwidth for CuteFTP using Bandwidth Throttling. 

• Easily negotiate secure connections though NAT devices and firewalls when 
connecting to servers that  support IPv6’s EPSV and EPRT port negotiation 
commands. 

• Edit remote files with ease by choosing between Full and Partial Screen Remote Edit 
modes. 

• Set advanced options such as the specific IP Address and Port Range to use when 
negotiating the connection port though NAT or Firewall devices. 

• Schedule concurrent events. Set up as many scheduled events as you like for 
transfers, synchronizations, monitoring, site backups, etc. 

• Faster Startup allows you to start working as soon as you launch the program. 
• Show transfer date/time in queue helps determine start and stop time of transfers. 
• Even up Panes make it easier to make eyeball comparisons of local and remote 

directories. 
• On Connect Prompts help communicate status during the connection process. 
• CTRL key same session transfer enables you to force transfers to occur over the 

same session. 
• Fonts for all panes let you customize the font size and colors used for all views 

(local, remote, log, queue). 
• Automatic Server Port Mapping provides automatic behavior to assist connection to 

problem servers. 
• Miscellaneous enhancements made to improve usability and efficiency. 
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Getting Started 

About CuteFTP Professional 
You can easily understand and use CuteFTP Professional whether you're a novice or 
accomplished FTP User. You will find all the features contained in CuteFTP Home and 
many new additions. CuteFTP Professional embodies the accumulated knowledge gained 
from the evolution of CuteFTP Professional, now imparted in a more advanced, more 
secure application. 
In CuteFTP Professional, you have a variety of features which enhance file transfer. The 
accessible interface allows you to easily update and maintain sophisticated Web sites. You 
can safeguard transfers of mission critical files with CuteFTP Professional's security features. 
You can speed the transfer of large architectural, graphic, or engineering files with multi-part 
accelerated downloads. Site caching allows you to minimize bandwidth while you browse. 
You can even schedule and script FTP transactions with minimal overhead using the 
autonomous Transfer Engine.  
CuteFTP Professional includes the Transfer Engine (TE), and an integrated HTML editor. 
You can use the Transfer Engine from within CuteFTP, or with any COM enabled scripting 
or programming language. The HTML editor can create, open, and edit local or remote 
HTML documents, right in CuteFTP. 
 

Registering CuteFTP 
CuteFTP must be registered, or activated, within 30 days or it will no longer function. To 
register and fully activate your software please input the Registration Serial Number you 
received when you are prompted to do so. For the registered user name, you may use either 
your first and last name or your company name. This information appears under Help > 
About from the menu bar.  
To ensure your software is registered accurately, we recommend you provide all of the 
optional details that are requested. This helps us confirm your eligibility for technical support 
or any upgrades that may become available in the future.  

Troubleshooting product registration 
If registration fails, try the following: 
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INVALID SERIAL NUMBER 

Make sure the serial number is valid. It is not case sensitive; however, it is alphanumeric and 
must be entered exactly as it displays on your invoice or label. If you received a digital 
invoice, try copying the serial number to the Windows clipboard and then paste it into the 
serial number box in the registration wizard. 

SERIAL NUMBER ENTERED FOR THE WRONG PRODUCT TYPE 

Registration serial numbers are specific to a particular product. For example, you cannot 
register CuteFTP Professional with a CuteFTP Home serial number and vice-versa. Also, a 
serial number for version 7 can't register version 6 and vice-versa. Double-check your 
invoice to see what product and version you purchased. Compare that to the product name 
and version shown in your Help About box or on the Splash screen. If they don't match, 
then please download the correct product from our website. If you accidentally purchased 
the wrong product please contact us. 

REGISTRATION UNABLE TO COMPLETE DUE TO A NETWORK PROBLEM 

Because activation takes place over the Internet, CuteFTP must be able to connect to our 
registration server to complete the activation process. If it cannot connect or complete the 
process, it will prompt you with various alternatives. You can go through a manual 
registration process, where you e-mail us certain information and we subsequently reply with 
an unlock code, or choose to register via a Web form, which also provides you with an 
unlock code. The final alternative is to continue as an "unverified" registration, which means 
that we will honor the serial number you provided as valid for now, and attempt to complete 
the activation process later once a connection to the registration server is secured (checked 
at application startup).  

Note: 
To register successfully, you must be connected to the Internet and have 
administrator privileges on your computer. If a firewall or proxy server is 
in use, the network administrator should ensure port 80 is open during 
the registration process. 

UNABLE TO CONNECT DUE TO PROXY SETTINGS 

In the Registration Failed dialog, click on the HTTP Proxy button and modify your proxy 
settings so that CuteFTP can perform HTTP (Web) transactions. If you don't know how to 
edit these fields, check with your system administrator. 

LOST SERIAL NUMBER 

If you cannot locate your serial number, you can obtain a copy from GlobalSCAPE Support 
if you still have the original e-mail address used to purchase the software. If you no longer 
have access to that e-mail account or don't recall what e-mail address you used, contact 
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customer service department and provide your name, address, order ID or any other 
pertinent data that you believe might help us locate your original purchase record. 

Making your first connection 

TO MAKE A CONNECTION TO AN FTP SITE 

1. Select File > Connect > Connection Wizard. 
2. Type a name for the site in the Label field. It can be any name you choose. 
3. Enter the address for the site in the Host field. You can enter a domain address like 

ftp.globalscape.com or an IP address such as 192.168.20.52. If you don't know the 
address, please contact your Web hosting company.  

4. In the Username field, enter the user name given to you by your hosting provider. 
5. In the Password field, enter the password given to you by your hosting provider. 
6. Click Connect. CuteFTP will connect to the remote computer and the site 

information will be saved in the Site Manager for future use. 

Transferring files and folders 

TO UPLOAD FILES (TRANSFER FROM A LOCAL TO REMOTE COMPUTER) 

1. Connect to a remote site. 
2. In the Local (left) pane, locate the file or folder you want to upload. 
3. Select and drag the item from the Local (left) pane to the Remote (right) pane. 

TO DOWNLOAD FILES (TRANSFER FROM A REMOTE TO A LOCAL COMPUTER) 

1. Connect to a remote site. 
2. In the Remote (right) pane, locate the file or folder you want to download. 
3. Select and drag the item from the Remote (right) pane to the Local (left) pane. 

Frequently asked questions 
• How do I set up a connection to my FTP Server?  
• What is my FTP Host Address?  
• What is my user name and password?  
• How do I upload my files with CuteFTP?  
• How do I transfer files from one site to another (CuteFTP Professional only)?  
• How do I navigate the directory tree in CuteFTP?  
• How do I change the permissions of my files (CHMOD)?  
• How do I delete files off my server?  
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• Why can't I connect to my FTP site?  
• Does CuteFTP support SSL (FTPS) and SSH2 (SFTP)?  
• How do I connect if I’m behind a firewall?  
• Why won’t my files transfer?  
• How do I remove files from CuteFTP that have finished transferring?  
• What is the Transfer Engine (TE)?  
• How does CuteFTP Professional & Home differ?  
• How can I get a copy of CuteFTP?  
• How long does it take to download?  
• Do you offer any online or offline support?  
• How can I best describe my problem if I contact technical support?  

 

Note: 
Reference the troubleshooting section for answers to problems 
frequently encountered. 

HOW DO I SET UP A CONNECTION TO MY FTP SERVER? 

First time users should use the Connection Wizard, located under File > Connection > 
Connection Wizard. It will bring up a window that will ask you for a Label for the site and 
the rest of the login information provided to you by your Web Host Provider.  

WHAT IS MY FTP HOST ADDRESS?  

This information is assigned by your Web Hosting Provider. If you Don't know what the 
FTP address is or are not sure, you can contact your Web Hosting Provider or Internet 
Service Provider and they can give that information to you.  

WHAT IS MY USER NAME AND PASSWORD?  

Your Web Hosting Provider or Internet Service Provider assigns this information. If you 
need to find out what this information is, you can contact them and they will be able to give 
that information back to you.  

HOW DO I UPLOAD MY FILES WITH CUTEFTP?  

First you must connect to your site. Once connected, you can upload your files by browsing 
to the directory where your files are located on the left hand window of the screen. Click on 
the files you wish to upload and drag them across to the corresponding right hand window 
(the server side). You will see the upload progress of your files in the queue window at the 
bottom of your CuteFTP window. 
More on transferring files and folders. 
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HOW DO I TRANSFER FILES FROM ONE SITE TO ANOTHER?  

In CuteFTP Professional, connect to two different servers. Click on the files you wish to 
transfer located in the first server window. Drag and drop these files to the second server 
window and they will be transferred from the first server to the second server. 
More on site-to-site transfers. 

HOW DO I NAVIGATE THE DIRECTORY TREE IN CUTEFTP?  

The Local Drives pane, located on the left-hand side of the screen, shows files and folders 
on your computer. The left pane in CuteFTP Professional shows you both the Local Drive 
pane and the Site Manager as separate tabs. You can navigate your local drives in the same 
fashion as Windows Explorer.  

HOW DO I CHANGE THE PERMISSIONS OF MY FILES (CHMOD)?  

Connect to your server using CuteFTP. Click (highlight) the file you wish to change 
permissions. Right-click on the file and choose Properties. The different options for the 
permissions are located at the bottom of this dialog box. Only servers that support the 
CHMOD command will let you change permissions. For the servers that do not support 
CHMOD, you cannot change permissions.  

HOW DO I DELETE FILES OFF MY SERVER? 

To delete files from your server, simply click on the file you wish to delete and press the 
Delete key on your keyboard. You can also right-click on the file and click Delete, or you 
can click on the file and then click on the red X on the toolbar.  

WHY CAN'T I CONNECT TO MY FTP SITE? 

If you have tried to log into your FTP site and have been unsuccessful, a window will appear 
telling you that it could not log in. Click on the button that says Details and it will list the 
exact error message sent to you by the server. Contact your Internet Service Provider or your 
Web Host Provider with this error message and they will be able to assist you in getting 
connected.  
See Troubleshooting for more help. 

DOES CUTEFTP SUPPORT SSL (FTPS) AND SSH2 (SFTP)?  

 SFTP, which is a component of SSH2, is supported by CuteFTP Professional only. SSL is 
supported by Professional and Home editions. Check with your server administrator to 
verify that the server you are connecting to supports SSL or SFTP (SSH2).  
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HOW DO I CONNECT IF I’M BEHIND A FIREWALL? 

If you are behind a firewall and you cannot connect, you will need to set up CuteFTP to 
connect through that firewall. Go to Tools > Global Options and expand the menu option 
entitled Connection. Click on the either SOCKS4 & 5 or Proxy Server option and fill out 
the information. If you are unsure of whether or not you are behind a Proxy Firewall or a 
Socks Firewall or are not sure of the specific settings for that firewall, consult your system 
administrator for the correct settings.  
See Troubleshooting for more help. 

WHY WON’T MY FILES TRANSFER? 

If you’ve tried to transfer files and they are not transferring, you will receive a window telling 
you that the files could not be transferred. Click Details for more information on the exact 
error message sent to you by the server. Contact your Internet Service Provider or your Web 
Hosting Provider with this error message.  
See Troubleshooting for more help. 

HOW DO I REMOVE FILES FROM CUTEFTP THAT HAVE FINISHED TRANSFERRING?  

To remove items from the queue that have already transferred or will not transfer, go to 
Tools > Queue > Remove all and the items will be removed from the queue.  

What is the Transfer Engine (TE)?  
Built on a modular design platform, CuteFTP Professional’s Transfer Engine (TE) is 
completely independent of the main application interface. Currently, transfers can continue 
even after the main interface is exited (if enabled in settings). It offers a COM interface that 
allows application developers to develop custom FTP solutions.  

How does CuteFTP Professional & Home differ?  
CuteFTP Professional is targeted towards corporate users or prosumers who need extra 
security, automation, and management tools. It contains everything the Home version has 
and is equipped with additional tools such as the Transfer Engine (TE), as well as SFTP, 
HTTPS, site-to-site transfer capability and more. For a comparison of CuteFTP Home and 
Professional, visit the comparison page. 

How can I get a copy of CuteFTP?  
CuteFTP is available by download from our website at www.globalscape.com 

How long does it take to download?  
Download time depends on your modem speed. On a regular 56K modem, CuteFTP will 
take about 7 minutes. The time to download decreases as your connection speed increases.  

Do you offer any online or offline support?  
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Telephone support for CuteFTP is available to registered customers within 30-days of 
purchase or who have purchased a support agreement.  All other users may submit their 
questions to our support form or refer to our online knowledge base for assistance. 

How can I best describe my problem if I contact technical support?  
If you are having a transfer or connection problem, you may want to enable extended listing 
in the session log window, reproduce the problem and then copy and paste the resulting log 
in to our online support request form. 

Installing & removing the software 

TO INSTALL 

From a download 
1. Download and save CuteFTP from www.globalscape.com. 
2. Double-click the executable to run the install. 
3. Follow the on-screen instructions.  

From a CD 
1. Place the installation CD in your CD-ROM drive. Installation should begin 

automatically. 
2. Follow the on-screen instructions.  
3. If your CD-ROM drive does not support automatic installation 
4. Place the installation CD in your CD-ROM drive. 
5. Double-click My Computer located on the Desktop.  
6. Double-click the CD-ROM drive icon.  
7. Double-click the Setup.exe icon. 
8. Follow the on-screen instructions. 

To remove CuteFTP from your computer 
1. Choose Start > Settings > Control Panel > Add/Remove Programs. 
2. Choose CuteFTP from the list. 
3. Select the Add/Remove button. 
4. Follow the on-screen instructions to uninstall CuteFTP. 
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Using the Interface 

CuteFTP Professional's main screen 

PROFESSIONAL VIEW 

In Professional (default) View, the main window is divided into four panes: a Local Pane, 
Remote Pane, Individual Session Logs pane, and Queue Pane.  The Local and Remote panes 
represent files available on local and remote drives, much like Windows Explorer. 
 

 
FTP Professsional Main Window 
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HOME VIEW 

You can also choose to use Home View, which is also a four-pane view with the log 
displayed above the local and remote panes and the queue underneath. This is the classic 
view found in earlier versions of CuteFTP.   

TO USE THE CLASSIC VIEW 

• Select View > Switch to Classic Interface from the menu. 
 

 
FTP Professional Main Window, Classic View 
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TO HIDE THE SITE MANAGER/LOCAL DRIVES PANE 

The S ready set. 
 The L s 
Windo

1. From the menu, choose View > Show Panes > Local Drives & Site Manager. 

TO HIDE THE INDIVIDUAL SESSION L  

The Individual Session Logs pane displays the FTP connection information for one 
rem e 

1. On the menu bar, go to View > Show dual Session Logs. 

r
• k reappears to show the p

 

on 

 On the menu bar, go to w Panes > Queue & Log Pane. 

e che ears to show the pane. 

ite Manager displays remote sites with all the connection information al
ocal Drives pane displays files and folders on your computer in the same manner a
ws Explorer. 

2. Click until the check mark disappears. 
Or 

• Click until the check mark reappears to show the pane. 

OGS PANE

ot connection. 
 Panes > Indivi

2. Click until the check mark disappears. 
O  

Click until the check mar ane. 

TO HIDE THE QUEUE/LOG PANE

The Queue pane displays file and folder transfers.  The Log pane displays FTP connecti
formation for all remote sites. in

1.
2.

View > Sho

 Click until the check mar
Or 

k disappears. 

• Click until th ck mark reapp
 

Note: 
The Remote pane displays files and folders on FTP sites to which you 
are connected. It w ot connected to any remote ill be blank if you are n
sites. You cannot h  ide the Remote pane.

Changing to the Home (classic) CuteFTP interface 
 can change the CuteFTP Professional Edition window to look like CuteFTP Home 
ion. 

CHANGE TO THE CL  

• Select View > Sw om the menu. 

You
Edit

TO ASSIC CUTEFTP INTERFACE

itch to Classic Interface fr
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TO CHANGE TO THE PR

Select View > Sw

short
lows you ugh the keyboard. For 

ress ALT+F to activate the File menu. Additional shortcuts are listed below.  

OFESSIONAL CUTEFTP INTERFACE 

• itch to Pro Interface from the menu. 

Keyboard cuts 
The ALT key al
example, p

to access CuteFTP menu functions thro

 
Key Function  
BACKSPACE Move to parent folder 
NUMBER PAD + Group select 
NUMBER PAD -  Group deselect 
NUMBER PAD * Invert selection 
TAB Moves focus between tabs (documents) in the active pane group
DELETE Delete selected object 
ESC Cancel transfer 
F1 Help 
F2 Rename 
F3 Find next 
F4 Switch between Site Manager and Local Drives tabs  
F5 Refresh active pane 
F6 Switch to Classic/Pro mode 
F8 Display folder information 
F9 Cancel transfer 
F10 Switch between Log Pane and Queue Pane 
F11 Folder comparison options 
F12 Hide or display individual log window 
ALT+ENTER Folder, file, or site properties 
ALT+UP ARROW Move to parent folder 
ALT+DOWN 
ARROW 

Select dropdown arrow for active pane 

ALT+RIGHT 
ARROW 

Show bookmark dropdown for remote pane 

ALT+LEFT ARROW Show bookmark dropdown for local pane 
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Key Function  
ALT+F7 Display Global Options Dialog 
ALT+0 Toggle show Site Manager/Local Pane view 
ALT+1 Toggle show Queue/Log Pane 
ALT+2 Hide or display individual log window (same as F12) 
ALT+3 Toggle show status bar 
ALT+Q Exit 
CTRL + A Select All 
CTRL + B Bold Font (when in HTML editor), Browse offline (When a site 

is selected in Site Manager pane) 
CTRL + C Copy 
CTRL + D Change remote folder 
CTRL + E Execute file 
CTRL + F Find 
CTRL + H Launch internal HTML editor 
CTRL + I Italic Font (when in HTML editor mode) 
CTRL + J Launch Connection wizard 
CTRL + L Filter 
CTRL + M Make new folder 
CTRL + N New FTP Connection 
CTRL + O Open (new document) 
CTRL + P Print (when in HTML editor mode) 
CTRL + Q Add current path as new bookmark 
CTRL + R Reconnect 
CTRL + S Save open document (HTML editor mode) 
CTRL + U Connect to URL or underline when HTML editor is active. 
CTRL + V Paste 
CTRL + W View file 
CTRL + X Cut 
CTRL + Y Redo (When in HTML editor mode) 
CTRL + Z Undo (When in HTML editor mode) 
CTRL + F4 Close active pane 
CTRL + F8 Quick Connect 
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Key Function  
CTRL+F9  Folder Monitor Tool 
CTRL+F10   Folder Backup Tool 
CTRL+F11  Folder Synchronize Tool 
CTRL + ~ (TILDE) Move focus between left, right and bottom panes 
CTRL + PAGE 
DOWN 

Download 

CTRL + PAGE UP Upload 
CTRL + TAB Move focus right to left among open connections and 

documents 
CTRL+ENTER Edit selected document (also creates a line-break when in the 

integrated editor's Find/Replace utility) 
CTRL+SHIFT+A Add anchor (when in HTML editor mode) 
CTRL+SHIFT+B Change item queue order (place at bottom) 
CTRL+SHIFT+C Add comment (when in HTML editor mode) 
CTRL+SHIFT+D Change item queue order (move down one) 
CTRL+SHIFT+I Font dialog (when in HTML editor mode), Input RAW FTP 

command when in CuteFTP mode 
CTRL+SHIFT+L Clear entire log 
CTRL+SHIFT+T Change item queue order (move to top) 
CTRL+SHIFT+U Change item queue order (move up one) 
SHIFT+F4 Disconnect 
 

Displaying the Site Manager 

TO DISPLAY THE SITE MANAGER 

1. Select Tools > Site Manager > Display Site Manager from the menu. A check 
mark appears next to the menu selection, indicating the Site Manager is visible. To 
hide the Site Manager again, select it from the menu. 
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Note: 
You can use F4 on your keyboard to toggle the Site Manager on and off. 

Warning: 
Hiding the Site Manager in CuteFTP Professional hides the Local Drives 
Pane as well. 

Displaying local files and folders 
Local files and folders are displayed in the Local Drives pane on the left-hand side of the 
CuteFTP window. 

TO DISPLAY FILES AND FOLDERS ON THE LOCAL COMPUTER 

1. From the menu, select View > Show Panes > Local Drives & SM Pane (there 
should be a check mark next to it.). 

2. Select the Local Drives tab at the bottom of the left pane to toggle between Local 
Drives and the Site Manager pane. 

Warning:  
Hiding the Local Drives Pane hides the Site Manager as well. 

Displaying transfer items 
Items ready for transfer, in transit, or just transferred display in the transfer Queue. The 
Queue Pane is just above the status bar along the bottom of the CuteFTP window.  

TO DISPLAY QUEUED FILES AND FOLDERS 

1. Make certain there is a check mark on the View > Show Panes menu next to 
Queue & Log Pane. 

2. Click the Queue tab at the bottom left of the lowest pane to toggle between the 
Queue and Log pane. 

Warning: 
Hiding the Queue Pane hides the Log pane too. 

Displaying the connection log 
Messages between the local computer and the server are stored in the Log.  Display the Log 
by selecting its tab in the Queue & Log Pane in the bottom window. 

TO DISPLAY THE CONNECTION LOG 

1. From the menu, select View > Show Panes > Queue & Log Pane (there should 
be a check mark next to it.). 
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2. Select the Log tab at the bottom left of the lowest pane. 

Warning: 
Hiding the Queue Pane hides the Log pane too. 

3. At the left end of the Log pane, select the plus sign next to the FTP address. 
4. Select a session. The log for that session appears to the right. 

Note: 
The active session log displays as a small log underneath each remote 
pane, with additional transfer session logs shown in the lower Log pane. 

Displaying folder contents 

TO VIEW A LISTING OF LOCAL FOLDER CONTENTS  

1. Select the Local Drives tab. 
2. Double-click a folder to view its contents. 

TO VIEW LISTINGS IN A PARENT FOLDER 

1. Select in the pane where you want to view the parent folder. 

2. Select the Move up folder button.  

TO UPDATE (REFRESH) A FOLDER LISTING 

1. Display the folder. 
2. Select in the pane where the folder is displayed. 
3. On the menu bar click View > Refresh. 

Displaying an individual log for each connection  
You can see messages between the local computer and the server appear in the Log.  You 
can also see a log for each individual session in the Individual Log Pane, just above the 
Queue & Log Pane, and just below the Remote Pane. 

TO DISPLAY A SEPARATE LOG FOR A CONNECTION 

• Select View > View Show Panes > Individual Session Logs (there should be a 
check mark next to it.). 
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Displaying the Status Bar 
You see the Status Bar at the bottom of the CuteFTP window. When you hover the mouse 
cursor over a tool or menu item, the left side of the Status Bar displays a brief description of 
the item. The right side of the Status Bar displays information about the current folder in the 
Remote pane. 

TO SHOW/HIDE THE STATUS BAR 

• From the menu, select View > Toolbars > Status Bar. A check mark indicates if 
the status bar is visible. 

Displaying toolbars 
CuteFTP includes four toolbars you can hide or display.   

TO HIDE/SHOW THE QUICK CONNECT BAR 

• From the menu select View > Toolbars > Quick Connect Bar.  A check mark 
indicates if the status bar is visible. 

You can display or hide these toolbars with the same method: 
• Standard Buttons 

• Quick Connect Bar 

• Custom Commands Bar 

• HTML Editor Bar 

• Status Bar 

Lockstep folder navigation 
Lockstep folder navigation allows you to navigate simultaneously through local and remote 
folders that have the same structure. 

TO TURN ON LOCKSTEP NAVIGATION 

• In the Local Drives tab view of the local pane, Select the Lockstep Folder 
Navigation icon. 
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Note: 
Lockstep navigation does not follow if you jump up or down several 
directory levels at once. 

Setting delete prompts 
You can set CuteFTP to display a pop-up box asking if you are sure you want to delete an 
item from the following areas: 

• Local drives 
• Remote sites 
• The queue 

TO SET CUTEFTP TO ASK BEFORE DELETING FILES FROM LOCAL DRIVES 

1. From the menu, select Tools > Global Options. The Global Options window 
appears. 

2. In the left pane, expand Display. 
3. Select Prompts. 
4. In the right pane, select the Confirm when deleting from local drive check box. 
5. Select OK. 

TO SET CUTEFTP TO ASK BEFORE DELETING FILES FROM REMOTE SITES  

1. From the menu, select  Tools > Global Options. The Global Options window 
appears. 

2. In the left pane, expand Display. 
3. Select Prompts. 
4. In the right pane, select the Confirm when deleting an item on remote view 

check box. 
5. Select OK. 

TO SET CUTEFTP TO ASK BEFORE DELETING ITEMS FROM THE QUEUE 

1. On the menu bar click Tools > Global Options. The Global Options window 
appears. 

2. In the left pane, expand Display. 
3. Select Prompts. 
4. In the right pane, select the Confirm when deleting an item from the queue 

check box. 
• Clear the same box to stop CuteFTP from asking before a deletion. 

6. Select OK. 
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TO SET CUTEFTP TO ASK BEFORE CLOSING A REMOTE PANE 

1. On the menu bar click Tools > Global Options. The Global Options window 
appears. 

2. In the left pane, expand Display. 
3. Select Prompts. 
4. In the right pane, select the Confirm when closing a remote pane check box. 
5. Select OK. 

Showing connection errors in pop-up windows 
During a session, errors are displayed in the connection log to avoid cluttering the monitor 
and memory during unattended sessions.  You can set CuteFTP to show the errors in a pop-
up window when they occur. 

To show connection errors in pop-up windows 
1. From the menu select Tools > Global Options. 
2. In the left pane, expand Display. 
3. Select Prompts. 
4. In the right pane, select the Show prompt upon error check box. 
5. Select OK. 

Customizing toolbars 
You can determine the buttons and their order in your toolbars.    

TO ADD A BUTTON 

1. From the menu, select Tools > Global Options > Display, highlight a toolbar and 
select Customize. 

2. The Customize Toolbar dialog box opens. There are two columns in the dialog 
box, Available Toolbar buttons and Current Toolbar buttons.  

3. Select a button from the Available Toolbar buttons column. 
4. Select Add. 
5. Select Reset to cancel any changes. 

TO REMOVE A BUTTON 

1. From the menu, select Tools > Global Options > Display, highlight a toolbar and 
select Customize. 

2. The Customize Toolbar dialog box opens. There are two columns in the dialog 
box, they are Available Toolbar buttons and Current Toolbar buttons.  
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3. Select a button from the Current Toolbar buttons column. 
4. Select Remove, or double-click the button. 
5. Select Reset to cancel any changes. 

TO MOVE A BUTTON  

1. From the menu, select Tools > Global Options > Display, highlight a toolbar and 
select Customize. 

2. The Customize Toolbar dialog box opens. There are two columns in the dialog 
box, they are Available Toolbar buttons and Current Toolbar buttons.  

3. Select a button from the Current Toolbar buttons column. 
4. Select Move Up to move a button one icon to the left on the toolbar.  

• Select Move Down to move the button one icon to the right on the toolbar. 
5. Select Reset to cancel any changes. 

 

Note: 
Reset does not cancel changes made when the Customize Toolbar dialog 
box was opened and closed previously. 

Thumbnail views 
If you are working with graphics, uploading or downloading photos, thumbnail view makes 
it convenient to preview the images right in CuteFTP so you can select the ones you want 
before you transfer them. 

TO TURN ON THUMBNAIL VIEW 

1. Select the pane (local or remote) that you want to change to thumbnail view.  
2. From the menu, select View > View, and choose Thumbnails. 
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Note: 
Thumbnail view supports previews of gif, jpeg and bitmaps, but not .png 
files. 

 Note: 
You can adjust how CuteFTP handles thumbnail images in thumbnail 
cache settings in Global Options. For more information, see Thumbnail 
settings in Log File Settings. 

Local and remote pane views 

TO CHANGE THE PANE VIEW 

1. Select the pane you want to change the view for.  
2. From the menu, select View > View, and choose from: 

• Large Icons 
• Small Icons 
• List 
• Details 
• Thumbnails 

Thumbnail view is useful if you are working with graphics, and need to see what a file looks 
like before you upload/download it. 

File and folder properties 
To look at the properties of a file or folder, right-click on the item and select properties. 

LOCAL PANE INFORMATION 

• Type: Tells you the kind of item. 
• Location: The path the file resides at. 
• Size: The size of the item.  Note that CuteFTP also calculates the size of folders. 

REMOTE PANE INFORMATION 

• Type: Tells you the kind of item, folder, file. 
• Server: The address of the server the file resides on. 
• Location: The path the file resides at. 
• Size: The size of the item.  Note that CuteFTP also calculates the size of folders. 
• Modified: When the item was last modified. 
• User: Specifies the user of the item 
• Group: Specifies the group the item belongs to. 
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• Read/Write Permissions: You can set the CHMOD permissions by changing the 
number (such as 777), or just check off the permissions in the Owner, Group, and 
Public area of the dialog. 
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Connecting to Sites 

Connecting to a site 
You can connect to any site listed in the CuteFTP Site Manager. You must be connected to 
the internet before you can connect to any sites. CuteFTP Professional can connect to FTP, 
FTPS (SSL), TLS(SSL v3), SSCN (SSL Site-to-Site transfer), SSH2(SFTP2), HTTP, and 
HTTPS (SSL) sites. For more on SSCN, see Site-to-site transfers. 

TO CONNECT TO AN EXISTING SITE WITHIN THE SITE MANAGER  

1. Select the Site Manager tab at the bottom of the Local Pane in CuteFTP. 
2. Expand a folder from the list shown in the Site Manager.  
3. Select a site from the list. 
4. From the menu, choose File > Connect > Connect. 

TO ADD AN FTP SITE TO THE SITE MANAGER 

1. From the menu, choose File > New > FTP Site. The Site Properties window 
appears. 

2. Type a name for the site in the Label field. It can be any name you choose. 
3. Enter the address for the site in the Host field. You can enter a domain address like 

ftp.globalscape.com or an IP address such as 192.168.20.52.  If you don't know the 
address your hosting provider can give it to you. 

4. In the Username field, enter the user name given to you by your hosting provider. 
5. In the Password field, enter the password given to you by your hosting provider. 
6. Select Connect or OK. The site information is saved in the Site Manager for future 

use. 

  

Note: 
You can also type or copy and paste an FTP URL directly into CuteFTP 
by choosing File > Connect > Connect to URL from the Menu Bar. 

SUPPORTED URL FORMATS 

• ftp://user:pass@host.host.com:port  
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• ftp://user:pass@host.host.com  
• ftp://user@host.host.com  
• ftp://host.host.com:port  
• ftp://host.host.com  
• ftp://ftp.sitename.com/pub l: user  p: pass  
• ftp://ftp.sitename.com/pub:44 l: user  p: pass  
• ftp://ftp.sitename.com/pub port:44 l: user  p: pass  
• ftp://ftp.sitename.com/pub l/p:  user/pass  
• ftp://ftp.sitename.com/pub:44 l/p:  user/pass  
• ftp://ftp.sitename.com/pub p:44 l/p:  user/pass  
• ftp://ftp.sitename.com/pub port:44 l/p:  user/pass  
• ftp://ftp.sitename.com/pub l: user p: pass  
• ftp://ftp.sitename.com/pub:44 l:  user p: pass  
• ftp://ftp.sitename.com/pub p:44 l: user p: pass  
• ftp://ftp.sitename.com/pub port:44 l: user p: pass  
• ftp://[any of the above formats]/pathnametofile/[optional filename]  
• also http, https, sftp, and ftps URLs 

TIP: 

Using Paste URL, CuteFTP either connects to the folder or downloads the file specified in 
the path. Here are some sample path endings and how the main program interprets them.  

• "ftp://host/dir.ext/"  This URL is considered a folder. CuteFTP can connect to it.   
• "host/.ext/"  This is considered a folder. CuteFTP can connect to it.   
• "host/dir/"  This is considered a folder. CuteFTP can connect to it.   
• "host/dir"  This is considered a folder. CuteFTP can connect to it.   
• "host/dir.ext"  This is considered a file. CuteFTP can download it.   
• "host/.ext"  This is considered a file. CuteFTP can download it.   

TO CONNECT TO A URL WITH THE TRANSFER ENGINE 

The Connect to URL feature is also supported by the Transfer Engine, and is called 
Download URL. Whether the URL specifies a path to a folder or file, the TE will try to 
download it.  

1. Right-click the Transfer Engine icon  in the system tray. 
2. Choose Download URL. 
3. Type or paste the URL in the Download URL box. 
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Using the Connection Wizard to Connect 
Use the Connection Wizard to step through the process of connecting to a site.  After 
using the Connection Wizard, your site is automatically saved to the Site Manager. 

TO ADD A SITE THROUGH THE CONNECTION WIZARD 

1. From the menu, select File > Connect > Connection Wizard. 
2. Enter a name for your site. You can choose any name. 
3. Select Next. 
4. Enter the IP or Web address for the site. The address may look like 64.243.64.21 or 

ftp.example.com. You can get this address from your hosting provider. 
5. Select Next. 
6. In the Username field, enter the username given to you by your hosting provider. 
7. In the Password field, enter the password given to you by your hosting provider. 
8. Select Anonymous logon if the site does not require a password. 
9. Select Hide password to disguise the password display as asterisks. 
10. Select Next. 
11. In the Default Local Folder field, browse or type the path to the local folder you 

want to see when connecting to this site. 
12. Select Next. 
13. Select Finish.  CuteFTP connects to the site, and the site is saved in the Site 

Manager. 

Using Quick Connect 
Use the Quick Connect toolbar to make speedy connections to FTP sites.  

TO CONNECT USING THE QUICK CONNECT TOOLBAR 

1. Open CuteFTP. The Quick Connect Bar should display by default under the menu 
bar and the main toolbar. 

2. If the Quick Connect Bar is not displayed, select View > Toolbars > Quick 
Connect Bar. 

3. Type in the FTP host address in Host. 
4. Type in your user name in the Username box. 
5. Type in your password in the Password box. 
6. Make sure the correct port is listed in the Port box (21 is the default FTP port). 

7. Select Connect  at the end of the Port box. 
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THE QUICK CONNECT TOOLBAR 

The Quick Connect bar can be moved or undocked by clicking and dragging on the vertical 
bar at the left-hand edge of the bar.  

Quick Connect fields  
Host: The name or TCP/IP address of the FTP server. The Host field is also a drop-down 
list; by clicking on the arrow to the right of the field you can access a list of the last several 
sites accessed during the current session via Quick Connect.  
User Name: Enter your user name or leave blank for anonymous FTP.  
Password: Enter the associated password if not connecting anonymously.  
Port: If you are not connecting to the default FTP port (21), enter the appropriate port here.  

Quick connect buttons 

 Connect: Activates the connection to the site specified in the fields. You can also pres
the  key while the cursor is in one of the toolbar fields to connect.  

s 
Enter

 Settings: Allows you to set connection options for the site.   

 Add to Site Manager: This button automatically creates a Site Manager entry for the 
site in the Quick Connect bar, so you can easily access it in the future.  

 
permissions, you can browse contents, download, upload and delete files on HTTP sites.  

TO CONNECT TO A HTTP SITE  

1. menu, select File > New > HTTP Site. The Site Properties dialog box 

3. ost address field. Prefixing the HTTP site 

4. 
that under the Type tab, the 

5. 
RL 

mainder of the tabs and fields are identical to those seen 

6. Select Connect to establish the connection.  

Connecting to a HTTP site 
You can connect to HTTP servers with CuteFTP Professional. If you have the appropriate

From the 
appears.  

2. Enter an identifying name for the site in the Label field.  
Enter the HTTP site’s address in the H
address with http:// is not necessary.  
If the site uses basic HTTP username/password authentication, fill in your user 
name and password in the appropriate fields. Notice 
site has been automatically set up as an HTTP site.  
If the Web site operates on a port other than 80, enter the appropriate port number 
in the Port field. Most sites connect to port 80. If the last portion of the site’s U
ends in a number, that number is the port to use. For example, 
http://www.example.com:99 indicates that the Web server www.example.com 
operates on port 99. The re
when adding an FTP site.  
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CuteFTP takes advantage of the keep-alive header (as defined in RFC 2068 & 2616) which 
keeps the session open during multiple transactions, saving the user considerable time and 
bandwidth.  

Note:  
The Web server must support basic authentication as described in RFC 
1945 <http://www.faqs.org/rfcs/rfc1945.html>. Because of the way 
authentication works, the server may challenge the client: with a WWW-
Authenticate request. The client responds with: Authorization: Basic 
<base64 encoding of userid-password>. Most Web Servers support basic 
authentication but require intervention on the site operator's behalf to set 
it up because it is server specific. Various existing sites employ other 
authentication schemes, such as NTLM or those found in ASP or 
JavaScripts, and are not supported by CuteFTP.  

Connecting to secure sites 
P (SSH2), 

HTTPS (SSL), and standard FTP with One Time Password authentication. 

TO CONNECT TO AN FTPS (SSL/TLS) SITE 

S (SSL) Site.  

name and password.  

5.  

lected. Certain servers support only one of 
n mechanisms.  

6. Select Connect or OK. 

TO CONNECT TO AN SSH2 (SFTP2) SITE 

P (SSH2) Site. 

me and password. 
4. Select Connect or OK. 

TO CONNECT TO AN HTTPS SITE 

TPS (SSL) Site.  

You can make secure connections and transfers with FTPS (SSL/TLS), SFT

1. From the menu, select File > New > FTP

2. The Site Properties dialog box appears.  
3. Type in the host, user 
4. Select the Type tab.  

In the Protocol list, choose FTP with TLS/SSL (Implicit encryption), or FTP
with TLS/SSL (Explicit encryption), or FTP with TLS/SSL (AUTH TLS - 
Explicit). The appropriate port will be se
the above SSL connectio

1. From the menu, select File > New > SFT

2. The Site Properties dialog box appears.  
3. Type in the host, user na

1. From the menu, select File > New > HT

2. The Site Properties dialog box appears.  
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3. Type in the host, user name and password. 
4. Select Connect or OK. 

Staying connected to sites 

ommands at random intervals to the FTP server, 
which maintains an active connection.  

TO TURN ON SMART KEEP ALIVE 

1.  menu choose Tools > Global Options. The Global Options dialog box 

nnection. 

pane, select the Enable Smart Keep Alive (SKA) check box.  
5. Select OK. 

TO TURN OFF SMART KEEP ALIVE 

1.  menu choose Tools > Global Options. The Global Options window 

nnection. 

pane, clear the Enable Smart Keep Alive (SKA) check box.  
5. Select OK. 

CUSTOMIZABLE SETTINGS IN SMART KEEP ALIVE (SKA) 

re starting   

e sent 
• Automatically reconnect  

TO SET THE TIME SKA WAITS BEFORE STARTING   

1.  menu, choose Tools > Global Options. The Global Options window 

nnection. 

You can maintain connections even when you aren't transferring files by using the Smart 
Keep Alive (SKA) feature. SKA sends c

From the
appears. 

2. In the left pane, expand Co

3. Select Smart Keep Alive. 
4. In the right 

From the
appears. 

2. In the left pane, expand Co

3. Select Smart Keep Alive. 
4. In the right 

• The time SKA waits befo
• How long SKA will run 
• When SKA commands are sent 
• Which SKA commands ar

From the
appears. 

2. In the left pane, expand Co

3. Select Smart Keep Alive. 
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4. In the right pane, enter a value between 0 and 1000 in Start SKA n seconds after 
the last command. CuteFTP will begin using SKA after the specified idle time. 

5. Select OK. 

TO SET NG SKA WILL RUN   

ools > Global Options. The Global Options window 

2. on. 
t Keep Alive. 

4. In the right pane, enter a value between 1 and 1000 in Maintain SKA for n 

5. Select OK. 

TO SET COMMANDS ARE SENT 

ols > Global Options. The Global Options window 

2. 
t Keep Alive. 

4. In the right pane, enter values between 0 and 1000 in Send command at random 
efault is between 15 and 60 seconds) 

5. Select OK. 

TO T

SKA sends commands from the ist in random order. 

ols > Global Options. The Global Options window 

 Connection

3. Select Smart Keep Alive. 
 to the 

 list and click Remove.  
5. Select OK. 

TO T

If th  automatically reconnects to the FTP site.  

(Default is 30 seconds) 

 HOW LO

1. On the menu bar, choose T
appears. 
In the left pane, expand Connecti

3. Select Smar

minutes. (Default is 30 minutes) 

 WHEN SKA 

1. From the menu, choose To
appears. 
In the left pane, expand Connection. 

3. Select Smar

intervals between n and n seconds. (D

 SE  WHICH SKA COMMANDS ARE SENT 

Commands l

1. From the menu, choose To
appears. 

2. In the left pane, expand . 

4. In the right pane, click Add and type in another command to add a command
list. 

OR  
• To remove a command, highlight a command in the

 SE  CUTEFTP TO AUTOMATICALLY RECONNECT   

e server terminates the connection, CuteFTP
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1. From the menu, choose Tools > Global Options. The Global Options windo
appears. 

w 

3. eep Alive. 
pane, select If disconnected, auto-reconnect within n seconds. 

(Default is 10 seconds) 
teFTP waits before 

reconnecting.  

e site.  
pen windows in the Remote Pane 

(on the right side by default). You can tile, cascade, or minimize these windows. When the 
pan essions by clicking the tabs at their lower left border.  

TO 

1. Select the Site Manager tab. 

 sites. You can connect to the same or 

TO FORCE CUTEFTP TO OPEN NEW CONNECTIONS FOR MULTIPLE TRANSFERS 

1. From the menu, choose Tools > Global Options > Transfer. 
heck box. 

TO L

2. Select Connection. 
umber of connections. 

TO L

2. Select Connection. 
ctions per site. 

2. In the left pane, expand Connection. 
Select Smart K

4. In the right 

5. Enter a value between 1 and 1000 seconds to set how long Cu

6. Select OK. 

Making multiple concurrent connections 
You can transfer files on one site while browsing another site or browse a folder on a site 
while transferring files from the sam
Multiple Concurrent Sessions are depicted as multiple o

es are maximized, select alternate s

OPEN MULTIPLE CONCURRENT CONNECTIONS 

2. From the menu choose File > Connect > Connect. 
3. Repeat steps 1 and 2 to connect to more

different sites. 

2. Clear the Transfer files over the browse session c

 AL OW MULTIPLE CONNECTIONS FROM CUTEFTP 

1. From the menu, choose Tools > Global Options. 

3. Enter a value between 1 and 200 in Global Max n

 AL OW MULTIPLE CONNECTIONS TO THE SAME SITE 

1. From the menu, select Tools > Global Options. 

3. Enter a value between 1 and 200 in Max number of conne
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TO H RESOURCES  

• Turn off individual transfer item logging in settings or turn off all logging options in 
 > General > Logs.  

• Don't transfer files in Multi-Part mode  

• Transfer Engine perform the transfer.  

PERFO

• s 95/98/ME computer you can only choose up to 40 concurrent 

• hoose up to 200 concurrent 
  

• Connections include transfers, browser sessions, and every single thread in a Multi-

• FTP sites that don't support multiple connections or sites that frequently drop the 

nd slow hardware may limit or prohibit multiple connections. 

g bookmarks 
You tes that open a specific local 
or r o

TO CRE

1. Select and then open the folder you want to bookmark.  
e remote or local window. 

is manner are assigned the remote folder as their default name.  

TO AC

1. Double-click a bookmark in the Site Manager (displayed as a sub-item under the 

2. w opens displaying the bookmark’s remote folder if specified; 

ying the local folder specified in the bookmark.  
Or 

 EN ANCE PERFORMANCE WITH LIMITED 

• Limit the number of concurrent per site transfers allowed  

Tools > Global Options

• Don't perform on-the-fly File Integrity Checking  
Close the main program interface and let the 

RMANCE LIMITATIONS 

On a Window
connections. 
On a Windows NT/2k/XP computer you can c
connections, but more than 40 connections may compromise system performance.

Part transfer. 

FTP connection will limit concurrent sessions.  
• Machine resources a

Creating and usin
 can have special entries called Bookmarks associated with si
em te folder (or both). 

ATE A BOOKMARK  

2. Right-click in either th
3. Choose Bookmark Current Folder from the pop-up menu. The new bookmark 

appears in the Site Manager as a sub-listing of the remote site’s entry. Bookmarks 
created in th

CESS A BOOKMARK 

site icon).  
A new remote windo
otherwise the root folder displays. The Site Manager switches to Local Drives, 
displa
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1. Select the purple bookmark icon next to the folder path field just above the local or 
remote folder pane. 

 appears, displaying the available bookmarks for the current 

TO 

okmark. 
e File > Properties. 

3. In Remote path, type a new path if you want to change the bookmark's remote 

5. 

TO REMOVE A BOOKMARK 

1. Select the bookmark in the Site Manager. 
 File > Delete (when using CuteFTP Professional) or click 

 Home.)  

TO RENAME OKMA

3. Type a new name. 
4. Press the Enter key. 

Using the ACCT command 
You require 
it.  

TO Y  

men File > Properties.  

2. A new context window
site. 

3. Select the desired bookmark. 

MODIFY A BOOKMARK 

1. Select the bo
2. From the menu, choos

folder. 
4. In Local path, type a new path if you want to change the bookmark's local folder. 

Select OK. 

2. On the menu bar, click
the Delete button (when using CuteFTP

3. Select Yes.  

 A BO RK 

1. Select the bookmark.  
2. From the menu select File > Rename.  

 can establish a connection and then supply the ACCT command for servers that 

 USE ACCT WITH OR WITHOUT AN FTP PROX

1. Select a site . From the in the Site Manager u, choose 
2. Select the Options tab, and choose Use site-specific option under the Site-

specific configuration options drop down menu.  
3. Select Proxy. The Proxy dialog box appears. 
4. In the list, select your proxy type. Proxy type 

5. Select the Use authentication check box.  
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6. rd (for ACCT) in the Password field.  
7. OST and PORT field are identical to your site's host and port as 

ral and Type tabs.  
ppears. 

s. Select Enter after each one: 

Type the passwo
Make sure the H
specified in the Gene

8. Select Advanced. The Advanced Proxy Settings dialog a
9. Select CUSTOM.  
10. Add the following variable

USER %user%  
PASS %pass%  
ACCT %fire_pass%  

TO

se File > Properties.  
r the Site-

s drop down box.  

tion check box.  
eld.  

11. r Exit.  

Manager content 

O REQUIRE A PASSWORD TO OPEN THE SITE MANAGER 

1. From the menu, choose Tools > Site Manager > Security > Encrypt Site 

TO CHANGE THE SITE MANAGER PASSWORD  

1. From the menu, choose Tools > Site Manager > Security > Change Password. 

11. Select OK to close the Advanced Proxy Settings dialog. 
12. Select OK again to close the Proxy dialog. 
13. Select Connect or Exit.  

 USE ACCT WITH AN FTP PROXY 

1. Select a site in the Site Manager. From the menu, choo
2. Select the Options tab, and choose Use site-specific option unde

specific configuration option

3. Select Proxy. The Proxy window appears. 
4. In the Proxy type list, select FTP proxy. 
5. Select the Use authentica

6. Type the password (for ACCT) in the Password fi
7. Select Advanced. The Advanced Proxy Settings dialog appears. 
8. Select USER/PASS/ACCT.  
9. Select OK to close the Advanced Proxy Settings dialog. 
10. Select OK again to close the Proxy dialog. 

Select Connect o

Protecting Site 

T

Manager Data. 
2. Type the same password in both the Enter new password and Confirm new 

password fields. 
3. Select OK. CuteFTP will prompt for a password every time it starts. 
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2. Type the same password in both the Enter new password and Confirm new 
password fields. 

TO REMOVE THE SITE MANAGER PASSWORD  

• From the menu, choose Tools > Site Manager > Security > Remove Password. 

C N

• 

• sword, you will not be able to use the protected Site Manager. 
 You will have the option to back up the locked Site Manager and re-enter your site 
information in a new Site Manager. 

• You can re-import the password-protected Site Manager file, but you still need the 
password to do so. 

3. Select OK. CuteFTP will prompt for a password every time it starts. 

CuteFTP will no longer prompt for a password when it starts. 

O FIGURATION NOTES 

When protected, the Site Manager information is protected with 64-bit Blowfish 
encryption. 

• Create a password at least 5 characters long for maximum security. 
If you forget the pas
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Connecting to Secure Socket Layer (SSL and TLS) 
sites 

TO CONNECT TO AN FTP SITE OVER SSL  

1. From the menu, select File > New > FTPS (SSL) Site.  
2. The Site Properties dialog box appears.  
3. Type in the Host address, Username and Password.  
4. Select the Type tab. 
5. In the Protocol list, choose the type of SSL connection mechanism supported by 

your server or use the default type selected. 
6. Select Connect.  

TO CONNECT TO AN EXISTING SITE OVER SSL  

1. Select on the site in the Site Manager.  
2. Select Connect. 

TO SPEED UP TRANSFERS WITH AN SSL SITE 

Using a clear data channel speeds up transfers with SSL sites.  A clear data channel encrypts 
the connection process, but files are transferred without encryption. 

1. Select on the site in the Site Manager.  
2. From the menu, select File > Properties. The Site Properties dialog box appears. 
3. Select the Type tab. 
4. Select the Clear Data Channel check box. 
5. Select OK or Connect. 
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Note: 
Not all servers support or allow the PROT C (Clear Data Channel) 
command argument sequence. 

TO ENCRYPT THE DATA TRANSFER AND NOT THE COMMAND CONNECTION 

Using a Clear Command Channel you can keep your data transfers encrypted, and still avoid 
firewall issues. 

1. Select on the site in the Site Manager.  
2. From the menu, select File > Properties. The Site Properties dialog box appears. 
3. Select the Type tab. 
4. Select the Clear Command Channel check box. 
5. Select OK or Connect. 

Note: 
Not all servers support or allow the CCC (Clear Command Channel) 
command argument. 

TO CONFIGURE OTHER SSL SETTINGS 

1. From the menu, select Tools > Global Options. 
2. Expand Security. 
3. Select SSL Security. 

Creating your own SSL certificates 
With CuteFTP you can create and sign digital certificates. SSL servers use certificates to 
determine whether or not they will allow you to connect. 

TO CREATE AN SSL CERTIFICATE 

1. From the menu, select Tools > Global Options. 
2. Select Security > SSL Security. 
3. Select Create Certificate.  
4. Enter the Certificate Set Name - This is the name of the certificate generated by 

the Certificate Wizard.  
5. Enter the Output Location - Select the folder to save the certificate in.  
6. Choose a bit-length for the certificate private key. CuteFTP supports keys up to 

4,096 bits. 
7. Choose an Expiration date - This defines how long the certificate remains valid.  
8. Enter and confirm the Pass Phrase - The Pass Phrase can be any combination of 

characters or spaces. It is used to encrypt the private key. Do not lose the pass 
phrase. The certificate is useless without it.  
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9. Select Next. 
10. Enter the City/Town of your organization.  
11. Enter the State/Province of your organization.  
12. Enter the name of your Organization.  
13. Enter the Common Name. Typically, this is your name or the domain name 

associated with your site.   
14. Enter your E-mail address.  
15. Enter the Unit or name of your department, such as "Information Systems."  
16. Enter the two-letter Country code for your organization's nation.  
17. Select Next.  
18. Select the Set up CuteFTP to use the generated certificate check box - the 

wizard automatically associates the certificate to CuteFTP. It can be unassociated by 
clearing the Use SSL Certificate check box in Tools > Global Options > Security 
> SSL. If the check box is cleared, the wizard only saves the certificate files in the 
folder originally specified. 

19. Select Finish. 
20. CuteFTP displays the paths to all the files generated for your certificate. If you want 

a third party to sign your certificate, you must send the Certificate Signing Request 
(.csr) file to the third party.   

CONFIGURATION NOTES 

• Not all SSL sites require certificates. 
• When you create a certificate CuteFTP generates the following files: 

• A Private key file (.key) - The private key should never be distributed to 
anyone. It is used to decrypt sessions encrypted by a public key. 

• A Certificate request file (.csr) - This file can be signed by GlobalSCAPE 
Secure FTP Server's Certificate Signing Utility or sent to an intermediate 
Certificate Authority such as Verisign or Thawte for signing. 

• A Certificate file (.crt) - This is a signed certificate, whether self-signed or 
signed by an intermediate certificate authority.  

• If the server accepts self-signed certificates, you can connect with the .crt file and 
.key file you created and associated to CuteFTP, provided the server has added your 
certificate to its trusted list. 

• You can export certificates (.crt files) from CuteFTP’s Trusted certificate store, 
located under Global Options > Security, SSL Security.  
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Having an SSL certificate signed 

TO HAVE A CERTIFICATE SIGNED  

1. Create a certificate. CuteFTP generates the necessary files, including a Certificate 
Signing Request (.csr) file. 

2. Send the .csr file to the server or a Certificate Authority (CA) such as Verisign 
(www.verisign.com) or Thawte (www.thawte.com).  

3. The server or CA uses your .csr file to create a signed certificate (.crt) file, which it 
should then send to you. 

4. Replace your existing .crt file with the signed one. 

CONFIGURATION NOTES 

When you create a certificate CuteFTP generates the following files: 
• A Private key file (.key) - The private key should never be distributed to 

anyone. It is used to decrypt sessions encrypted by a public key. 
• A Certificate request file (.csr) - This file can be signed by GlobalSCAPE 

Secure FTP Server's Certificate Signing Utility or sent to an intermediate 
Certificate Authority such as Verisign or Thawte for signing. 

• A Certificate file (.crt) - This is a signed certificate, whether self-signed or 
signed by an intermediate certificate authority.  

 

Choosing a certificate for SSL sessions 
Choose the certificate CuteFTP will send to SSL servers.    

TO CHOOSE A CERTIFICATE 

1. From the menu select Tools > Global Options. 
2. If you don't see SSL security click on the plus sign to expand Security. 
3. Select SSL security.  
4. Select Use SSL Certificate when authenticating.  
5. Select the appropriate files using the Browse buttons next to Certificate and Private 

Key.  
6. Enter the passphrase in the Passphrase and Confirm passphrase boxes.  
7. Select Apply and OK.  
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Accepting server SSL certificates 
Accepting a certificate from a server allows you to connect with the server.  Once you accept 
a certificate it is added to your Trusted Certificates list, and you will not be asked to accept 
or reject the certificate again.  If you reject a certificate, and try to connect again, you will be 
asked again to accept the certificate. 

TO ACCEPT A SERVER'S SSL CERTIFICATE 

1. Connect to a server with SSL. 
2. If the server has a certificate, it displays. 
3. Select Accept. The certificate isadded to your Trusted Certificates List. 

Note: 
If you click Reject, you will not be able to connect to the server. 

TO SEE YOUR TRUSTED CERTIFICATES 

1. From the menu bar, choose Tools > Global Options > Security > SSL security. 
2. Select Trusted Certificate. 
3. Highlight a certificate in the list. 
4. Select Properties to see more detailed information about the certificate. 

Importing or removing SSL certificates from the 
trusted list 
When a certificate is in your trusted list, you will be able to connect to any server presenting 
that certificate. 

TO IMPORT A CERTIFICATE TO THE CUTEFTP TRUSTED LIST 

1. From the menu, choose Tools > Global Options > Security > SSL security. 
2. Select Trusted Certificate.  
3. Select Import.  
4. In the Files of Type field, select Certificates (*.pem, *pfx, *.crt) or All files (*.*). 
5. Navigate to the folder containing the certificate file.  
6. Highlight the certificate file.   
7. Select Open. The certificate is now listed in your Trusted Certificates list. 
8. Select Close.  

TO REMOVE AN SSL CERTIFICATE FROM THE TRUSTED LIST 

1. From the menu, choose Tools > Global Options > Security > SSL security. 
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2. Select Trusted Certificates. 
3. Highlight the certificate you want to remove. 
4. Select Remove. 
5. Select Close to close the Certificate Manager dialog. 
6. Select OK to close the Global Options dialog. 

Using a clear data channel with SSL 
Using CDC (Clear Data Channel) speeds up transfers with SSL sites. A clear data channel 
encrypts the connection process, but files are transferred without encryption. You can add 
more speed to your transfers by using a clear command channel as well. 

1. Select a site in the Site Manager.  
2. From the menu choose File > Properties. The Site Properties dialog box appears. 
3. Select the Type tab. 
4. In the Protocol list, select  FTP with SSL (Implicit encryption), or FTP with 

SSL (Explicit encryption) or FTP with SSL/TLS (AUTH TLS). 
5. Select the Clear Data channel check box. 
6. Select OK or Connect. 

Note: 
The Clear Data channel option is only available with SSL connections. 

Using a clear command channel with SSL 
Using CCC (Clear Command Channel), your connection process and login are encrypted, 
but when you begin transferring data, all FTP commands are sent in clear text. The data 
transfers remain encrypted, unless you choose to use a clear data channel.  SSL connections 
require CCC when connecting in PORT mode from behind a NAT firewall. 

1. Select a site in the Site Manager.  
2. From the menu, choose File > Properties. The Site Properties dialog box appears. 
3. Click the Type tab. 
4. In the Protocol list, select  FTP with SSL (Implicit encryption), or FTP with 

SSL (Explicit encryption) or FTP with SSL/TLS (AUTH TLS). 
5. Select the Clear Command channel check box. 
6. Select OK or Connect. 
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Note: 
The Clear Command channel option is only available with SSL 
connections. 

Learning about SSL 
When you use CuteFTP to connect securely to a server that supports SSL or TLS, the two 
machines pass a sequence of commands to create a secure connection. The FTP protocol 
definition provides at least two distinct mechanisms by which this sequence is initiated: 
Explicit (active) and Implicit (passive) security.  

EXPLICIT SECURITY  

Explicit security requires that the FTP client issue a specific command to the FTP server 
after establishing a connection to establish the SSL link. The default FTP server port is used. 
This formal method is documented in RFC 2228.  

IMPLICIT SECURITY  

Implicit security is a mechanism by which security is automatically turned on as soon as the 
FTP client makes a connection to an FTP server. In this case, the FTP server defines a 
specific port for the client (990) to be used for secure connections.  

Note: 
Implicit SSL is discussed in various SSL drafts but not formally adopted 
in an RFC. For strict compliance to standards, use the explicit method. 
Implicit SSL adds benefits in the form of a dedicated port strictly used 
for secure connections, requiring less overhead in establishing the 
session. There are various FTP servers that support this mode, including 
GlobalSCAPE’s Secure FTP Server. For more on SSL Connection 
Mechanisms, see Troubleshooting SSL Connections. 

SSL SESSIONS  

The diagram below shows a SSL session using explicit security. In this picture, the two 
machines communicate over an Internet connection. Time is represented vertically—the first 
communication at the top of the timeline is from the Client to the Server, and subsequent 
communications proceed chronologically down the timeline. The breaks in the timeline 
represent the passage of time.  
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EXPLICIT SSL CONNECTION  

 
 
CuteFTP adheres to Internet standards for secure transfer of files over the FTP protocol. 
Specifically, CuteFTP implements the FTP extensions documented in RFC 2228. Any FTP 
Server that also implements these extensions will work with CuteFTP in order to ensure the 
encryption of your sensitive data.  
 
GlobalSCAPE Secure FTP Servers and Enhanced File Transfer Servers are also capable of 
Implicit SSL sessions over a dedicated port. See the Secure FTP Server User's Guide and 
Enhanced File Transfer Server User's Guide for more information on configuring a secure session 
to a GlobalSCAPE Secure Server. 

Secure site-to-site transfers using SSCN 
CuteFTP supports secure (SSL) site to site transfers using a proprietary command developed 
by Raiden FTP Server and supported by GlobalSCAPE Secure FTP Server and a few others. 

TO TRANSFER FILES FROM ONE SERVER TO ANOTHER SECURELY 

1. Connect to each site (source and destination).  
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2. From the menu, choose Window > Tile. 
3. Drag the file from one Remote Pane to another. The Queue pane displays a double 

arrow (<->) to indicate a site-to-site transfer.  

Note: 
Both sites must support and enable SSCN (Set Secured Client 
Negotiation). As of March 2004, the following servers are the only ones 
to support this command: GlobalSCAPE Secure FTP Server, SurgeFTP 
Server, Raiden FTPD, Blackmoon FTP Server, Titan FTP Server, and 
Orenosv HTTP/FTP Server. 

Troubleshooting SSL Connections 
If you are having difficulty connecting to your FTP server over SSL, refer to the following 
checklist for help. 

SSL CONNECTION CHECKLIST 

1. Verify that the server you are connecting to supports SSL connections. 
2. Verify the port being used. Some servers require that SSL connections use a 

dedicated port, such as 990. 
3. Verify the SSL connection type selected under Site Properties > Type > Protocol 

Type is the correct SSL mechanism supported by your server. See SSL 
Compatibility Issues further below. 

4. Verify that your Certificate was added to the server’s Trusted List if the server 
requires client certificates upon connect. You may have to notify the server 
administrator as not all servers will auto-accept client certificates upon their first 
connection attempt. 

5. You must accept the server’s certificate when prompted during a connection 
attempt, otherwise the client will not connect as desired. 

6. Verify that your certificate hasn't expired. Check your Trusted List. 
7. Copy the connection log to a text file or e-mail to assist in troubleshooting when 

contacting your FTP or Web service provider or the GlobalSCAPE support team. 

SSL CONNECTION MECHANISMS 

Not all FTP servers that support SSL connections do so correctly or in strict compliance to 
proposed or approved standards.  
Various FTP over SSL implementations have been proposed over the last few years. Most 
do not conform with RFC–2228 or are at odds with the latest IETF (Internet Engineering 
Task Force) drafts. Typical Implementations include: 

Implicit TLS/SSL 
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SSL connection over a dedicated port (990) registered with the IANA. This approach, while 
quite common, is not favored by the IETF. CuteFTP supports this implementation for 
broader compatibility. 

Explicit "AUTH SSL" 
SSL connection over a standard port (21) using “AUTH SSL” or “AUTH TLS-P” to 
negotiate the protection mechanism. AUTH TLS-P implicitly sets the protection mechanism 
and is therefore in direct disagreement with RFC 2228. CuteFTP does support AUTH SSL, 
and subsequently sets the protection mechanism explicitly using the PROT command and its 
approved arguments. 

Explicit “AUTH TLS” 
SSL v3.1 connection over a standard port (21) and explicitly setting the protection 
mechanism. This is the version that best adheres to RFC 2228 and is favored by the IETF in 
its latest FTP over SSL draft (draft-murray-auth-ftp-tls-13.txt). This version is supported by 
CuteFTP and is selected by default when establish a new SSL connection. 
Apart from those mentioned above, CuteFTP will not connect to servers requiring “AUTH 
TLS-P” or other deprecated SSL connection mechanisms. 

Connecting to HTTPS sites 
HTTPS sites use SSL to secure HTTP connections. 

TO CONNECT TO AN HTTPS SITE  

1. From the menu, choose File > New > HTTPS (SSL) Site.  
2. Enter a name for the site in the Label field.  
3. Enter a site’s address in the Host address field. You do not need to prefix the site 

address with https://.  
4. Enter your user name in the Username field. The HTTPS server administrator 

provides the username and password. 
5. Enter your password in the Password field. 
6. Select Connect. 
7. When you connect for the first time, the Accept Certificate dialog box displays. 
8. Select Accept if you trust the certificate. Rejecting a certificate will abort the 

connection. 
 

CONFIGURATION NOTES 

• HTTPS sites rely on the use of certificates to verify that you are in fact 
communicating with the desired HTTPS server and to establish the secure 
connection.  

48 



Secure Connections 

• Accepting a certificate stores the certificate on your computer so you do not have to 
verify it again the next time you connect to the site.  

• If a site’s certificate appears unusual, has not been signed by a third party (such as 
VeriSign, or Thawte) or does not match the operator’s name, it is suggested you 
reject the request.  

• Once the connection is established, a small lock icon displays on CuteFTP's status 
bar. Double-clicking the icon in the status bar displays the server's certificate.  

• The lock icon represents the type of connection established, but does not guarantee 
a secured connection. Even though you are connected to an https site, you may be 
linked to an unsecured directory, at which time the session is no longer be https, but 
http instead. Check the log if you are unsure of the security of your connection. 

Connecting to Secure Shell (SSH2) sites 

TO CONNECT TO AN SSH2 SITE 

1. From the menu, choose File > New > SFTP (SSH2) Site. 
2. Enter a name for the site in the Label field. 
3. Enter the site address in the Host field. You do not need to enter "ftp://" or 

"sftp://" at the start of the address. 
4. Enter your user name in the User Name field. The server administrator provides 

your username and password. 
5. Enter your password in the Password field. 
6. Select Connect. 

TO CHOOSE SSH2 CIPHERS AND AUTHENTICATION METHODS 

1. From the menu, choose Tools > Global Options. 
2. Expand Security. 
3. Select on SSH2 security and make any changes. 
4. Select OK. 

Authenticating in SSH2 
You can use Password, Public Key, or both authentication methods for SSH2 connections. 
Password authentication is the default. 

TO USE PASSWORD AUTHENTICATION 

1. From the menu, choose Tools > Global Options. 
2. Expand Security. 
3. Select SSH2 security. 
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4. Make sure the Use password authentication check box is selected. You are using 
password authentication whenever the check box is selected, even if the box and 
check are dimmed. 

5. Select OK. 

Note: 
Password authentication uses the FTP site login password for 
authentication, not the passphrase used to decrypt the identity file’s 
private key shown in the field beneath the Use password 
authentication check box. 

TO USE PUBLIC KEY AUTHENTICATION 

1. From the menu, choose Tools > Global Options. 
2. Expand Security. 
3. Select SSH2. 
4. Select the Use public key authentication check box. You are using public key 

authentication whenever the check box is selected, even if the box and check are 
dimmed. 

5. Select OK. 
 

Note: 
To use public key authentication, you will need to send your public key 
to the server administrator before making an SSH2 connection. If the 
server is running OpenSSH, you will need to convert the public key as 
described below: 

 
6. Create an identity file in the client. 
7. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.) 
8. The server administrator must convert the public key to OpenSSH, check it with 

wordcount, and add it to authorized_keys.  
 

Command sequence: 
ssh-keygen -i -f Identity.pub > sshpub 
wc sshpub 
cat sshpub > ~\.ssh\authorized_keys 
 

Note: 
Wordcount should return a "1" as the first number. OpenSSH asks for 
the identity files password the first time you log in. If CuteFTP fails to 
connect, contact our support team and provide the kernel version, 
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OpenSSH build, and the CuteFTP build number (located under Help > 
About). 

Creating SSH2 key pairs 

TO CREATE YOUR OWN PRIVATE AND PUBLIC KEY FOR SSH2 CONNECTIONS 

1. From the menu, choose Tools > Global Options > Security > SSH2 Security 
 and click on the Create identity file button. 

2. Choose an RSA or DSA Key Type. 
3. Select Next. 
4. Enter the same passphrase in the Passphrase and Confirm Passphrase boxes. The 

passphrase can be any combination of characters and spaces.   
5. Select Next. 
6. In the Private key filename box, type or click the browse button to select a path 

where you want to store your private key.  
7. Type a name for the key at the end of the path.    
8. In the Public key filename box,  enter the path where you want to store your 

public key. Make sure the filename extension is .pub and the file name matches. 
9. Choose a Key length between 1024 and 4096 bits. Shorter keys are faster but less 

secure; longer keys are more secure but slow connections. 
10. Select Finish. CuteFTP generates the keys. Longer keys take more time to generate. 
11. CuteFTP displays the path and name of the keys. If you want CuteFTP to use the 

keys just generated, select Yes.  
12. Select OK. 

 

Note: 
For added security, clear the Passphrase and Confirm passphrase 
fields in the SSH2 Security page.  CuteFTP then prompts for the 
identity file’s secret key passphrase when required for connection to a 
SFTP site. 

Note: 
CuteFTP only supports two algorithms for SSH2 keys ssh-dss (DSA) and 
ssh-rsa (RSA). A DSA key is required for SSH2, an RSA key is 
recommended.  

Learning About SSH2 
When you connect with SSH2 there are two components or layers involved: the Transport 
and Authentication layers.  
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TRANSPORT LAYER 

When you first attempt to connect to an SSH2 site, CuteFTP Professional and the server 
determine whether the transmission should be encrypted or clear, compressed or 
uncompressed, what Method Authentication Code (MAC) to use, and what kind of 
encryption (cipher) to use.  
Once the encryption method is chosen the following happens:  

1. The server sends a public key to CuteFTP. 
2. CuteFTP generates a session key, and encrypts it with the server’s public key. 
3. CuteFTP then sends the encrypted session key back to server.  
4. The server then decrypts the session key with its private key and from that time all 

transmitted data is encrypted with the session key.  

AUTHENTICATION LAYER 

After the Transport Layer is established, the server attempts to authenticate the client.  
Common methods for establishing user authentication include:  

• Public Key Authentication Method: publickey  
o To use this method, you will need your private key and your public key, 

which is passed to the server. The server encrypts a random number with 
your public key and sends it to you. 

2. If you have not already entered your passphrase in SSH2 security settings, 
CuteFTP asks you for your passphrase to activate the private key. 

3. The private key decrypts the number and sends it back to the server. 
4. The server recognizes the number as correct and allows the connection. 

• Password Authentication Method: password  
o Using this method, the client sends its password to server. The client does 

not need to explicitly encrypt the password, because it is automatically 
encrypted by the SSH2 Transport Layer. This is the default in CuteFTP. 
With this type of authentication, the connection will fail if the Transport 
Layer cannot encrypt the data.  

After the encryption method is established and authentication is complete, the two systems 
are ready to exchange secure data. CuteFTP Professional sends a secured FTP connection 
along the encrypted data tunnel, the remote system and responds and you can begin 
transferring files securely.  

TRANSPORT LAYER SETTINGS 

To select Message Authentication Codes (MAC) 
Message Authentication Codes are algorithms used to confirm data has not been altered 
between the client and server. 

1. From the menu, choose Tools > Global Options.  
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2. Expand Security. 
3. Select SSH2 Security.  
4. Select at least one Message Authentication Code from the MAC list. There are 

four to choose from: 
• MD5 
• SHA1 
• SHA1-96 
• MD5-96 

5. Select OK. CuteFTP tries each selected MAC with the server starting with the 
top method in the MAC list. 

TO SELECT ENCRYPTION METHODS (CIPHERS) 

1. From the menu, choose Tools > Global Options.  
2. Expand Security. 
3. Select SSH2 Security.  
4. Select at least one encryption method from the Cipher list. There are five 

available encryption types:  
• ARCFOUR  
• Cast128  
• Triple DES (3DES)  
• Twofish 
• Blowfish     

5. Select OK. CuteFTP Professional tries each selected encryption method with the 
server starting with the top method in the Cipher list. 

AVAILABLE ENCRYPTION ALGORITHMS  

ARCFOUR: Arcfour is intended to be compatible with the RC4 cipher trademarked 
by RSA Data Security, makers of the famous PGP program. It uses a 128-bit key and 
provides good security.  
CAST128: This cipher is the CAST-128 cipher in CBC mode, with 128 bit keys.  
Triple DES (3DES): This algorithm uses a 24-bit “triple key” to encrypt data 3 times. 
The 24-bit key is split into 3 8-bit segments and each is used for encryption. Triple 
DES is fast, but not as strong as the other algorithms.  
Blowfish: The Blowfish algorithm is a public-domain method using a 128-bit key. 
Blowfish was intended to be a replacement for 3DES. It provides good security.  
Twofish: Twofish is an improved version of Blowfish using a 256-bit key. It provides 
the strongest security available in CuteFTP Professional and should protect your data 
in most transfers.  
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AUTHENTICATION LAYER SETTINGS 

To use public key authentication 
If you want to use public key authentication, you will need to send your public key to the 
server administrator before you will be able to make an SSH2 connection.   

1. From the menu, choose Tools > Global Options. 
2. Expand Security. 
3. Select SSH2 Security. 
4. Select the Use public key authentication check box. You are using public key 

authentication whenever the check box is selected, even if the box and check are 
dimmed. 

5. Select OK. 

TO USE PASSWORD AUTHENTICATION 

1. From the menu choose Tools > Global Options. 
2. Expand Security. 
3. Select SSH2 Security. 
4. Select the Use password authentication check box. You are using password 

authentication whenever the check box is selected, even if the box and check are 
dimmed. 

5. Select OK. 

Note: 
You have to use at least one authentication method for an SSH2 
connection. You can use both methods for the same SSH2 connection. 

Using SSH2 key pairs 
You can authenticate SSH2 connections with a certificate (public key) just like SSL. 

TO USE PUBLIC KEY AUTHENTICATION IN SSH2 

1. Create an SSH2 key pair. 
2. Send the Public key to the SSH2 server administrator. 
3. On the menu bar click Tools > Global Options. 
4. In the left pane, expand Security. 
5. Select SSH2 Security. 
6. In the right pane, select the Use public key authentication check box. 
7. Type the path or browse to your public and private keys in the Public key path and 

Private key path boxes. 
8. In the Use Passphrase box, enter your passphrase for the key. 
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9. In the Confirm passphrase box, enter your passphrase again. 
10. Select OK. 

CONFIGURATION NOTES 

Your private key and passphrase are never transmitted over a connection. When the server 
attempts to authenticate: 

1. The server encrypts a random number with your public key and sends it to you. 
2. If you have not entered your passphrase in SSH2 security settings, CuteFTP asks 

you for your passphrase to activate the private key. 
3. The private key decrypts the number and sends it back to the server. 
4. The server recognizes the number as correct and allows the connection. 

Public key authentication 
To use public key authentication, you must send your public key to the server administrator 
before making an SSH2 connection. If the server is running OpenSSH, you must  convert 
the public key as described below: 
 

1. Create an identity file in the client. 
2. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.) 
3. The server administrator must convert the public key to OpenSSH, check it with 

wordcount, and add it to authorized_keys.  
 

Command sequence: 
ssh-keygen -i -f Identity.pub > sshpub 
wc sshpub 
cat sshpub > ~\.ssh\authorized_keys 
 

Note: 
Wordcount should return a "1" as the first number. OpenSSH asks for 
the identity files password the first time you log in. If CuteFTP fails to 
connect, contact our support team and provide the kernel version, 
OpenSSH build, and the CuteFTP Professional build number (located 
under Help > About). 

Troubleshooting SFTP Connections 
If you are having difficulty connecting to your SFTP server: 

1. Verify that the server you are connecting to supports SFTP connections. 

Note: 
CuteFTP Professional supports SFTP, a secure service provided by the 
SSH2 host in which the server both encrypts the data and handles the file 
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transfer. This should not be confused with FTP over SSH2, in which 
SSH2 uses port forwarding capabilities to forward standard FTP 
transactions through an encrypted tunnel but the actual file is transferred 
by a separate, non-secure FTP server. If you are unsure if the host is 
supporting SFTP, check the connection port. SFTP usually occurs over 
port 22. 

2. Try toggling the compression options in the SSH2 Security page 
3. Verify the authentication mechanism supported and required by the server. It may 

require password, public key (identity file), or both (see Important note below).  
4. If public key authentication is required, be sure to provide a copy of the public key 

you created to the server’s administrator, as it must be in the server’s trusted list in 
order for you to connect.  

5. If the server administrator created a public key for you, be sure to replace your 
existing one with it and select the provided key from within the SSH2 Security page. 

6. Copy the connection log to a text file or e-mail to assist in troubleshooting when 
contacting your FTP or Web service provider or the GlobalSCAPE support team. 

CONFIGURATION NOTES 

To use public key authentication, you will must send your public key to the server 
administrator before making an SSH2 connection. If the server is running OpenSSH, 
convert the public key: 

1. Create an identity file in the client. 
2. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.) 
3. The server administrator must convert the public key to OpenSSH, check it with 

wordcount, and add it to authorized_keys.  
 

Command sequence: 
ssh-keygen -i -f Identity.pub > sshpub 
wc sshpub 
cat sshpub > ~\.ssh\authorized_keys 
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Note: 
Wordcount should return a "1" as the first number. OpenSSH asks for 
the identity files password the first time you log in. If CuteFTP 
Professional fails to connect, contact our support team and provide the 
kernel version, OpenSSH build, and the CuteFTP Professional build 
number (located under Help > About). 

Encrypt passwords using OTP 
When you connect to a site you can encrypt your password to protect it from interception 
using the One Time Password (OTP) scheme.  OTP is supported by GlobalSCAPE Secure 
FTP Server, various *nix servers, and a few Windows' based servers as well. 

TO ENABLE OTP FOR A STANDARD FTP SITE 

1. Select the Site Manager tab. 
2. Highlight a site. 
3. From the menu, select File > Properties. 
4. Select the Type tab 
5. In Protocol type, make sure FTP (standard File Transfer Protocol) is selected. 
6. Select an encryption method in the Password Protection group. Choose from: 

• Not Encrypted 

• MD4  
• MD5  
• Auto detect OTP 

7. Select Connect or OK. 

TO ENABLE OTP FOR AN FTP OVER SSL SITE 

1. Select the Site Manager tab. 
2. Highlight a site. 
3. From the menu, select File > Properties. 
4. Select the Type tab 
5. In Protocol type, make sure FTP (standard File Transfer Protocol) is selected. 
6. Select an encryption method in the Password Protection group. Choose from: 

• Not Encrypted 

• MD4  
• MD5  
• Auto detect OTP 

7. In Protocol type, select the desired SSL connection mechanism. 
8. Select Connect or OK. 
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Note: 
Using OTP with SSL adds a redundant layer of protection as SSL 
authentication already protects the password using a robust encryption 
mechanism. 

 

Note: 
OTP is defined in RFC 1938 (replaced by 2289) and was evolved from 
S/KEY™, a One-Time Password System originally developed by 
Bellcore.  

 

ENCRYPTION OPTIONS 

Not Encrypted - the password is sent unprotected to the server. 
MD4 (S/Key) - A system that encrypts your password a different way every time it is sent. 
MD5 (S/Key) - The same system as MD4, with more complex encryption scheme. 
Auto detect OTP - CuteFTP tries to detect the encryption method the server uses. 

Protecting Site Manager content 

TO REQUIRE A PASSWORD TO OPEN THE SITE MANAGER 

1. From the menu, choose Tools > Site Manager > Security > Encrypt Site 
Manager Data. 

2. Type the same password in both the Enter new password and Confirm new 
password fields. 

3. Select OK. CuteFTP will prompt for a password every time it starts. 

TO CHANGE THE SITE MANAGER PASSWORD  

1. From the menu, choose Tools > Site Manager > Security > Change Password. 
2. Type the same password in both the Enter new password and Confirm new 

password fields. 
3. Select OK. CuteFTP will prompt for a password every time it starts. 

TO REMOVE THE SITE MANAGER PASSWORD  

• From the menu, choose Tools > Site Manager > Security > Remove Password. 
CuteFTP will no longer prompt for a password when it starts. 
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CONFIGURATION NOTES 

• When protected, the Site Manager information is protected with 64-bit Blowfish 
encryption. 

• Create a password at least 5 characters long for maximum security. 
• If you forget the password, you will not be able to use the protected Site Manager. 

 You will have the option to back up the locked Site Manager and re-enter your site 
information in a new Site Manager. 

• You can re-import the password-protected Site Manager file, but you still need the 
password to do so. 
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Storing and Modifying Sites 

Adding a site to the Site Manager 
You can save connection settings for sites that you use often by adding them to the Site 
Manager. 

TO ADD A SITE TO THE SITE MANAGER 

1. From the menu, select File > New and select the type of site you want to add. 
2. Select the protocol you want the site to have. The Site Properties dialog box 

appears. 
3. Enter a name for the site in the Label field.  
4. Enter the address for the site in the Host address field.  It can be a domain name 

such as ftp.example.com, or an IP address. If you don't know the address, your 
hosting provider can give it to you. 

5. In the Username field, enter the username given to you by your hosting provider. 
6. In the Password field, enter the password given to you by your hosting provider. 
7. Select Connect or OK. The site information is saved in the Site Manager. 

Note: 
Your host address can be in IP form (like 255.255.255.255) or in domain 
name form (like ftp.mysite.com)  

Importing and exporting sites in the Site Manager  
You can add sites to your Site Manager from simple text listings or from site listings in the 
following FTP clients: 
 

• BlueZone 1.01-2.11 
• CoffeeCup 4.0-4.5 
• Crystal FTP 2000 
• CuteFTP 1.3 - 7.0 
• CuteFTP Pro 1.0 - 7.0 
• FTP Commander 4.0 
• FTP Explorer 1.00 
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• FTP Voyager 6.0-8.0 
• LapLink 2.0 
• LeapFTP 2.7.0 
• TransSoft 4.4 
• WS_FTP 5.0 - 7.0 

TO ADD SITE LISTINGS TO YOUR SITE MANAGER 

1. From the menu, choose Tools > Site Manager > Import FTP Sites.  
2. Select your old FTP client from the Import from list.  
3. Type the path or browse to your old client site list.  
4. Select Merge site entries into the existing Site Manager.  
5. Choose Start Conversion.  

TO REPLACE YOUR SITE MANAGER LISTINGS WITH AN IMPORTED LIST  

1. From the menu, choose Tools > Site Manager > Import FTP Sites.  
2. Select your old FTP client from the Import from list.  
3. Type the path or browse to your old client site list. 
4. Type a path or browse to a folder where you will save the new Site Manager list.  

Warning: 
Do not save the new database in the CuteFTP program folder or the 
CuteFTP Application Data folder until step 10. 

5. Select Create a new Site Manager with these entries.  
6. From the menu Start Conversion. 
7. Exit CuteFTP and open Windows Explorer.  
8. Navigate to your user profile folder.  

Example: WDocuments and Settings\jsmith\Application 
Data\Globalscape\CuteFTP Professional.  

9. Give your current Site Manager file (sm.dat) another name, like sm.bak or sm.old.  
10. Move the database you created in step five to the CuteFTP directory and rename it 

sm.dat.  
11. Restart CuteFTP and begin using your new Site Manager database. 
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Warning:  
Do not manually overwrite CuteFTP’s sm.dat file while CuteFTP is 
running. CuteFTP automatically saves the sm.dat file upon exit. This 
means that if you replace the sm.dat file while running, CuteFTP will 
replace it again when you exit, resulting in the loss of your replacement 
file.  

TO EXPORT YOUR SITE MANAGER LISTINGS 

You can also export your Site Manager listings as a text file in two different formats. You 
may export the listings as URLs only, or as a more detailed listing of hostnames, directories 
and descriptions. 

1. From the menu, choose Tools > Site Manager > Export Sites as URL to 
generate a list of sites as Web addresses. Choose Tools > Site Manager > Export 
Sites as Text to generate a list of sites in plain text. 

2.  Enter a name and choose a location for your exported listings in the Save As dialog 
box that appears. 

3. Select Save. 

Modifying a site in the Site Manager 
You can change a number of connection settings for individual sites in the Site Manager. 
The changes made only affects the individual site. 

TO CHANGE SITE PROPERTIES OR SETTINGS 

1. Select the site you want to change in the Site Manager. 
2. From the menu, choose File > Properties. 
3. Select the General, Type, Actions, or Options tab. 
4. Make any desired changes. 
5. Select Connect or OK to save the changes. 
OR 

• Select Cancel to reject the changes. 

General site properties 
The following settings are made from the General tab of the Site Properties dialog: 

LABEL 

Type the name for the site as it will appear in your Site Manager. This can be any name you 
like. 

63 



CuteFTP Professional User's Guide 

HOST ADDRESS 

Enter the address for the site.  It can be a domain name such as ftp.example.com, or an IP 
address. If you don't know the address your hosting provider or system administrator should 
be able to provide it for you. 

USERNAME 

Enter the username given to you by your hosting provider. 

PASSWORD 

Enter the password given to you by your hosting provider. 

COMMENTS 

Enter any notes about the site that you want to save with the site. 

LOGIN METHOD 

• Select Normal if the server requires your user name and password for a connection. 
• Select Anonymous if the server doesn't require a user name and password for a 

connection. 
• Select Double if you need to supply your user name and password twice for a 

connection.  

BUTTONS 

New 
Saves all of your changes for the current site, and opens a new blank site. 

Rename 
Change the name of the site highlighted in the left pane. 

Delete 
Deletes the selected site. The site and all related information are removed from the Site 
Manager. 

Browse Offline 
Opens a cached version of the site's folders in the Remote pane. 

Help 
Opens help for Site Properties. 

Connect 
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Saves site changes and connects to the site. 

Exit 
Saves changes and closes the Site Properties dialog box. 

Site Properties Type 
The following settings are made from the Type tab of the Site Properties dialog: 

PROTOCOL TYPE 

Choose the transfer protocol for the site. You can choose FTP and various SSL options. In 
CuteFTP Professional you can also choose HTTP, HTTP with SSL, or SSH2 (SFTP).  
If you choose any of the SSL options, you will also be able to choose a Clear Data Channel 
or a Clear Command Channel.  

PORT 

CuteFTP chooses the appropriate default port for the protocol you choose. You can change 
this number if the default is not correct for your site. 

SERVER TYPE 

You can leave this at Auto-detect, and CuteFTP will try to determine what kind of server is 
at the site.  If you have connection problems, or you know what kind of server is at the site, 
you can choose from the list which includes Unix, Unix compatible, Windows NT, and 
many others. 

DATA CONNECTION TYPE 

Set to Use global settings, CuteFTP uses the connection type set in Global Options > 
Transfer. You can also specify from PORT, PASV, EPRT, or EPSV connection mode. For 
more information, see Data_mode in Transfer Settings. 

TRANSFER TYPE 

Choose to use the transfer type you set in Global Options or one of the following: 
• Auto-detect  Based on the file type CuteFTP will decide whether to transfer in 

ASCII or binary. 
• ASCII  Used primarily for transfers of text based files like HTML, text and other 

documents. 
• Binary Used primarily for data type transfers like pictures and other graphics, or files 

that do not have line feeds (carriage returns).  
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SERVER TIME ZONE 

Choose No Offset if the server is in your same time zone. If the server is in a different time 
zone, choose it here. These time zones do not account for Daylight Saving Time. To 
account for Daylight Saving Time, choose a time zone one hour ahead of the server's time 
zone.  For example, if you are connecting to a server in Central Daylight time, set the time 
zone to Eastern Standard time. 

PASSWORD PROTECTION 

Offers four options for password encryption if simple FTP is selected as the protocol type. 

Site Properties Actions 
The following settings are made from the Actions tab of the Site Properties dialog: 

When client connects, switch to this remote folder 

Type the full path to any folder on the remote site, and CuteFTP will automatically open the 
folder in the Remote Pane when you connect to the site. 
 

When client connects, switch to this local folder 

Type or browse to the full path for any folder on your machine, and CuteFTP will 
automatically open the folder in the Local Pane when you connect to the site. 
 

For navigation use the following caching options 

Caching means CuteFTP stores the site list information on your computer, so when you 
navigate to different files and folders, you don't have to reconnect. 

• Use cache during session 

Store the site's information only until you close the connection. 
• Always use cache 

Store the site's information and keep it even after you disconnect. 
• Do not use cache 

Never store the site's information. 
 

When uploading, apply this rule to files and folder names 

Use this to change file names to upper case, lower case, or to keep the case the same. 
• Preserve case 

Keep all uploaded file names in their original case. 
• Force lower case 

Change all uploaded file names to small letters. 
• Force upper case 
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Change all uploaded file names to all capitals. 
 

Filter 

Click this button to define which files will be hidden or displayed on the site. 
For more information go to Choosing which files and folders to display. 

Site Properties Options 
The following settings are made from the Options tab of the Site Properties dialog: 

Site specific configuration options 

• Choose Use global settings for all options and the site will use the parameters set in 
Global Options  

• Choose Use site specific option and the site will use the parameters set on this tab.  
 

Apply auto-rename scheme to transfer 

• Select this check box and files you transfer will be renamed according to the settings 
you chose in the Global Options Rename Rules window. 

• Clear this check box and no files will be renamed when you make transfers with this 
site. 

 

Use NLST instead of LIST (retrieves an abbreviated listing) 

• Select this check box to get only a list of file names and no other file information from 
the site. 

• Clear this check box and the site will send you complete file listings, including file size, 
file modified date, and folder names. 

 

Use the logical parent (not physical parent) on CDUP 

• Select this check box to and when you click the button to go back to the previous 
directory, you will go back to the previous directory, even if you clicked a link or 
shortcut to from the previous directory. 

• Clear this check box and when you click the button to go back to the previous 
directory, you will go back to the actual parent directory for this folder, which might 
not have been the directory you were in when you jumped to the current directory. 

 

Site Specific Firewall settings 

• Click Proxy if you need to connect through a proxy server to get to this site. A Proxy 
window will appear where you can enter the proxy type, server address, username and 
password. 
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• Click Socks if you need to connect through a Socks server to get to this site. A Socks 
window will appear where you can enter the SOCKS type, server address, username 
and password. 

 

Retry attempts 

Enter the number of times you want CuteFTP to try connecting to this site, if there is a 
problem making a connection. 

Delay between retries 

Enter how many seconds you want CuteFTP to wait before retrying a connection after a 
connection attempt fails. 

Max connections per this site 

Enter how many connections CuteFTP can open to the site for transferring many files 
simultaneously. 

Correcting times for sites in different time zones 

TO COMPENSATE FOR SERVERS IN DIFFERENT TIME ZONES 

1. Select a site in the Site Manager. 
2. From the menu, choose File > Properties. 
3. Select the Type tab. 
4. Select the server's time zone from the Server time zone list. 
5. Choose Connect or OK. 

 

Note: 
CuteFTP uses time zone offset information for display, transfer, and 
overwrite logic purposes.  

Designating a site's server type 
You can improve compatibility with individual sites by designating the type of server used 
for that site. 

TO DESIGNATE SERVER TYPE 

1. Select a site from the Site Manager. 
2. From the menu choose File > Properties. 
3. Select the Type tab. 
4. In the Server Type list, select a server type. 
5. Select Connect or OK. 
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Removing a site from the Site Manager 
1. Select the site you want to delete in the Site Manager. 
2. Select Delete. A message appears asking if you are sure you want to delete the site. 
3. Select Yes.  

Finding a site in the Site Manager 

TO FIND A SITE IN THE SITE MANAGER 

1. Select the Site Manager. 
2. Right-click and select Find Text in Site Manager. 
3. Type in some letters from the site name. 
4. Select OK. 
5. If a site other than the one you wanted was highlighted, right-click and select Find 

Next, until the desired site is highlighted. 
 

Note: 
The Find Text in Site Manager tool is not case sensitive, searches from 
the top to the bottom of your site listings, and does not recognize 
wildcards. 

Creating and using bookmarks 
You can have special entries called Bookmarks associated with sites that open a specific local 
or remote folder (or both). 

TO CREATE A BOOKMARK  

1. Select and then open the folder you want to bookmark.  
2. Right-click in either the remote or local window. 
3. Choose Bookmark Current Folder from the pop-up menu. The new bookmark 

appears in the Site Manager as a sub-listing of the remote site’s entry. Bookmarks 
created in this manner are assigned the remote folder as their default name.  

TO ACCESS A BOOKMARK 

1. Double-click a bookmark in the Site Manager (displayed as a sub-item under the 
site icon).  

2. A new remote window opens displaying the bookmark’s remote folder if specified; 
otherwise the root folder displays. The Site Manager switches to Local Drives, 
displaying the local folder specified in the bookmark.  
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Or 
1. Select the purple bookmark icon next to the folder path field just above the local or 

remote folder pane. 
2. A new context window appears, displaying the available bookmarks for the current 

site. 
3. Select the desired bookmark. 

TO MODIFY A BOOKMARK 

1. Select the bookmark. 
2. From the menu, choose File > Properties. 
3. In Remote path, type a new path if you want to change the bookmark's remote 

folder. 
4. In Local path, type a new path if you want to change the bookmark's local folder. 
5. Select OK. 

TO REMOVE A BOOKMARK 

1. Select the bookmark in the Site Manager. 
2. On the menu bar, click File > Delete (when using CuteFTP Professional) or click 

the Delete button (when using CuteFTP Home.)  
3. Select Yes.  

TO RENAME A BOOKMARK 

1. Select the bookmark.  
2. From the menu select File > Rename.  
3. Type a new name. 
4. Press the Enter key. 
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Transferring files and folders 

TO UPLOAD FILES (TRANSFER FROM A LOCAL TO REMOTE COMPUTER) 

1. Connect to a remote site. 
2. In the Local (left) pane, locate the file or folder you want to upload. 
3. Select and drag the item from the Local (left) pane to the Remote (right) pane. 

TO DOWNLOAD FILES (TRANSFER FROM A REMOTE TO A LOCAL COMPUTER) 

1. Connect to a remote site. 
2. In the Remote (right) pane, locate the file or folder you want to download. 
3. Select and drag the item from the Remote (right) pane to the Local (left) pane. 

Queuing Files and Folders for Transfer 

TO DISPLAY OR HIDE THE QUEUE 

1. From the menu, choose View > Show Panes. 
2. Select the Queue Pane to show or hide it. 

TO ADD ITEMS TO THE QUEUE 

1. Connect to a site. 
2. Locate the file(s) or folder(s) you want to upload or download in your local or 

remote pane. 
3. Drag the selected item(s) to the transfer queue window. 
4. Repeat as necessary. You can also connect to other sites and add files and folders to 

the queue.  
5. Once you have finished adding items to the transfer queue, you can change queue 

item attributes if desired, such as destination path, transfer type, scheduling and 
more by selecting the item, and pressing Alt+Enter on your keyboard. 
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6. You can change the transfer priority of  items by selecting them, then them up or 
down in the queue. A blue line displays to indicate where the items will move. 

7. Once you are ready to begin processing the queue, choose Tools > Queue > 
Transfer All from the menu. 

 
Note: 
Events you schedule for synchronizations also appear in the queue. To modify 

Transfer queue icon legend 
The queue icons display next to each item in the Queue pane. 
 

The item is in the queue but a transfer has not been attempted or scheduled. 
 

The item is in the queue and a transfer has been scheduled, but has not occurred yet. 
 

This item's transfer is starting. 
 

There is an existing file of the same name in the destination folder and you will have to 
decide whether to Overwrite the existing file, Skip the transfer, Resume an interrupted 
transfer, Rename the file you are transferring, or Numerate the file you are transferring. 
 

The item transfer is in progress, this usually appears for large transfers. 
 

The item transferred successfully. 
 

The item transfer has been interrupted, but CuteFTP is still trying to complete the 
ansfer. 

 
tr

The item transfer has been skipped, usually because you chose to skip it manually or in a 
mS art Overwrite rule that you chose previously. 

 

You have stopped the item transfer while it was in progress. You can still Resume this 
transfer. 
 

The server has refused to complete the item transfer for some reason.  Your transfer log 
will show an ERROR:> message with a little more detail. 
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Transferring files in order 
You can see the order in which queued items transfer at the left end of the Queue pane. 
The numbers in the column indicate the order of transfer. By default, files transfer in the 
same order that they are added to the queue. 

TO TRANSFER ITEMS IN THE ORDER ADDED 

1. Sort the local or remote panes by clicking on the corresponding column header 
(Name, Date, Size, etc.) 

2. Select the items to transfer. 
3. Drag the selected items into the queue. Note that the items are ordered in the same 

way they were sorted prior to adding them to the queue. 
4. Right-click in the Queue pane. 
5. Choose Transfer All. CuteFTP transfers the files in the order reflected by the 

numbers in the left column of the queue. 

TO SET A SPECIFIC TRANSFER ORDER 

1. Move transfer items to the Queue pane. 
2. Select the pound sign (#) column header to sort the items by their transfer order. 
3. Select an item in the queue. 
4. On the menu bar, choose Tools > Queue > Change Order. 
5. Select Move to Top to transfer the selected item first. 
Or 

• Select Move to Bottom to transfer the selected item last. 
Or 

• Select Move Up One to transfer the selected item before the previous item in the 
queue. 

Or 
• Select Move Down One to transfer the selected item after the following item in the 

queue. 
 

Tip: 
To change an item's place in the transfer order, select the line item and 
drag up or down in the queue. A blue line indicates the item's new 
position in the queue. 
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Moving an item fr

 
om position 4 to position 2 prior to transfer. 

St

TO STO ANSFER 

1. Select the item(s) in the queue to be stopped 
2. 

TO REMOVE

eue Pane.  
ue > Remove Selected.  

 item from the 

opping transfers 

P A TR

On the menu bar, click View > Stop. 

 ITEMS QUEUED FOR TRANSFER 

1. Highlight a file listed in the Qu

2. On the menu bar, go to Tools > Que

3. A message appears asking if you are sure you want to remove the
queue. 

4. Click Yes.  

Tip: 
Remove All deletes every file from the queue. Remove Finished 
deletes all of the items from the queue that have completed their transfer.  

TO RES  STOPPED TRANSFER 

1. Select the stopped item in the queue. 
2. From the menu, choose Tools > Queue > Transfer Selected. 

TO RESET A FAILED TRANSFER 

1. Select the item in the queue. 
2. From the menu, choose Tools > Queue > Reset Selected. 
3. To restart the transfer, choose Tools > Queue > Transfer Selected from the 

menu. 

UME A

Tip: 
The shortcut keys Esc or F9 stop active transfers. Press Esc once to stop 
the last command (be it a transfer or connection request). Press Esc 
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repeatedly to cycle through active transfers and/or connections and stop 
them one by one. You can also select multiple items in the queue and 
select Esc to stop them. Use the Del key to stop and remove selected 
queue items. 

Res

ANSFERS 

CuteFTP automatically attempts to resume interrupted transfers caused by lossy connection, 
uteFTP does not auto-resume interrupted 

transfers when the remote server is unreachable because there is no connection available, the 

1. Select the stopped item in the queue. 
 Queue > Transfer Selected or Transfer All. 

 

uming transfers 

TO AUTOMATICALLY RESUME TR

server kicked users, a slow server, and so on. C

server is down, or for any other reason. In those situations, you must manually resume the 
transfer. 

TO MANUALLY RESUME A TRANSFER 

2. From the menu, choose Tools >

Note: 
In you have not shut down and restarted CuteFTP since the interruption 
took place, CuteFTP assumes that the transfer is within its original 
context and attempts to resume it from the point it left off. If the 
transfer is no longer in the original context, CuteFTP prompts you to 
overwrite the destination file, that is, to start over again. You can set up 
overwrite rules to tailor such situations to your specific needs. 

TO RE

1. Select the stopped item in the queue. 
> Queue > Transfer Selected. 

TO

1. Select the item in the queue. 
ols > Queue > Reset Selected. 

Tools > Queue > Transfer Selected from the 

SUME A STOPPED TRANSFER 

2. From the menu, choose Tools 

 RESET A FAILED TRANSFER 

2. From the menu, choose To

3. To restart the transfer, choose 
menu. 

Tip: 
The shortcut keys Esc or F9 stop active transfers. Press Esc once to stop 
the last command (be it a transfer or connection request). Press Esc 
repeatedly to cycle through active transfers and/or connections and stop 
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them one by one. You can also select multiple items in the queue and 
select Esc to stop them. Use the Del key to stop and remove selected 
queue items. 

Usin
You can use the Windows' Clipboard function to copy and paste a URL directly into 
CuteFTP with the Connect to URL feature. This allows you to connect to a site, or if 

1. From the browser or Windows application of your choice, copy the URL to the 

 From the menu, choose File > Connect > Connect to URL.  

4. 
 
Cut ied, starts downloading the file. 
 

he following formats are supported:  

• ftp://user:pass@host.host.com  

 l: user  p: pass  

/pub port:44 l: user  p: pass  

/pass  

: pass  
/[optional filename] 

Cut T tps URLs. 

g the clipboard to transfer 

specified, download a file.  

clipboard. The URL may be general (ftp://www.globalscape.com) or specific 
(ftp://www.globalscape.com/pub/cuteftp/cute2632.exe).  

2. Return to CuteFTP.
3. Paste the URL into the Connect to URL window.  

Select OK.  

eFTP parses the URL and connects to the site or, if specif

T

• ftp://user:pass@host.host.com:port  

• ftp://user@host.host.com  
• ftp://host.host.com:port  
• ftp://host.host.com  
• ftp://ftp.sitename.com/pub

b:44 l: user  p: pass  • ftp://ftp.sitename.com/pu
• ftp://ftp.sitename.com
• ftp://ftp.sitename.com/pub l/p:  user/pass  
• ftp://ftp.sitename.com/pub:44 l/p:  user/pass  
• ftp://ftp.sitename.com/pub p:44 l/p:  user/pass  
• ftp://ftp.sitename.com/pub port:44 l/p:  user
• ftp://ftp.sitename.com/pub l: user p: pass  
• ftp://ftp.sitename.com/pub:44 l:  user p: pass  
• ftp://ftp.sitename.com/pub p:44 l: user p: pass  
• ftp://ftp.sitename.com/pub port:44 l: user p
• ftp://[any of the above formats]/pathnametofile
eF P Professional also accepts http, https, sftp, and f
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PASTING A URL DIRECTLY INTO THE TRANSFER ENGINE 

The Paste URL feature is also accessible from the Transfer Engine icon  in the Windows 
system tray.  

1. Right-click the TE icon and select Download URL.   
2. Paste the URL into the Download URL dialog box and select OK.  the TE 

attempst to download the URL regardless of whether the URL specifies a path to a 
folder or a file.  

Depending on the URL you paste, CuteFTP tries to connect and navigate to the specified 
folder or attempst to download the item. Following is a sample of path endings and how 
CuteFTP handles it:  
 
Path endings Interpretation Action Attempted 

ftp://host/dir.ext/ A folder Connection 
host/.ext/ A folder Connection 
host/dir/ A folder Connection 
host/dir A folder Connection 
host/dir.ext A file Download 
host/.ext A file Download 
 

Scheduling transfers 

TO SCHEDULE DOWNLOADS  

1. Connect to a remote site. 
2. Select the destination folder in the Local Drives pane. 
3. In the Remote pane, select the file or folder you want to transfer. 
4. From the menu, choose File > Download Advanced > Download Scheduled. 

The Scheduling Properties dialog appears. 
5. Select the Schedule the current item check box. 
6. In the Start on option boxes, choose a date and time. 
7. Select the Enable Recurrence check box and continue with step eight if you want 

the download to repeat automatically.  If you do not want the download to repeat 
automatically, clear the Enable Recurrence check box and skip to step nine. 

8. In the Repeat every option boxes, choose how often you want the download to 
repeat. 

9. Select OK. 
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TO SCHEDULE UPLOADS  

1. Connect to a remote site. 
2. Open the folder where you want to send the file or folder. 
3. In the Local Drives pane, highlight the file or folder you want to transfer. 
4. From the menu, choose File > Upload Advanced > Upload Scheduled. 
5. Select the Schedule the current item check box. 
6. In the Start on option boxes, choose a date and time. 
7. Select the Enable Recurrence check box and continue with step eight if you want 

the upload to repeat automatically.  If you do not want the upload to repeat 
automatically, clear the Enable Recurrence check box and skip to step nine. 

8. In the Repeat every option boxes, choose how often you want the upload to repeat. 
9. Select OK. 

 TO SCHEDULE TRANSFERS FROM THE QUEUE WINDOW  

1. In the Queue pane, select the file to be transferred.  
2. From the menu, choose Tools > Queue > Schedule Selected.  
3. Select the Schedule the current item check box. 
4. In the Start on option boxes, choose a date and time. 
5. Select the Enable Recurrence check box and continue with step six if you want the 

transfer to repeat automatically.  If you do not want the transfer to repeat 
automatically, clear the Enable Recurrence check box and skip to step seven. 

6. In the Repeat every option boxes, choose how often you want the transfer to 
repeat. boxes. 

7. Choose OK. 

CONFIGURATION NOTES 

• You can schedule multiple transfers. 
• CuteFTP continues to run and complete any scheduled or pending transfers even f 

you exit the program before a transfer is scheduled to start, unless the "Don't close 
the transfer engine if tasks are pending" is disabled under Tools > Global Options 
> General page.   

• If you manually close the Transfer Engine or shut down the computer before a 
scheduled transfer can start, CuteFTP prompts if you still want to complete the 
scheduled transfer the next time you open CuteFTP.  

• If you leave CuteFTP or the Transfer Engine open to accomplish a number of tasks, 
it is a good idea to configure CuteFTP to delete successfully finished items from the 
queue. 

78 



Transferring Files and Folders 

Filtering Transfers 
CuteFTP allows you to set filters that automatically include or exclude files from transfer so 
you don't have to manually. You define the filters in the filter dialog box, then apply them to 
individual transfers, or use them on all transfers. You can also use filters during folder 
synchronizations.  

TO TRANSFER FILTERED ITEMS 

1. Select the pane displaying the files or directory you want to apply a filter to.  
2. From the menu, choose View > Filter... The Filter dialog appears. 
3. From the Filter Properties tab, select Enable filtering. 
4. If you want to filter at the folder level, select Apply filtering to folder names. If a 

filter you add matches a folder name, the entire contents of that folder are included 
or excluded along with the folder. 

5. If you want the filters to work during transfers, select Apply to file transfers. 
6. Select the Filter Mask tab and add any files you want to include. 
7. Select the Filter NOT Mask tab and add any items you want to exclude. 
8. Select OK. 
9. Select the files that remain visible and choose File > Upload Advanced > Upload 

filtered from the menu (or Download filtered if you are downloading.). 

CONFIGURATION NOTES 

• You can configure two filter sets: one for the local pane, and one for the remote 
pane. Note that CuteFTP applies the filter parameters to all of the contents, 
directories, and subdirectories displayed in that pane. 

• Filtering works with folder synchronizing.  
• You can filter by file extensions, for example, .htm, .php, .asp., etc. 

Site-to-site transfers (FXP) 

TO PERFORM A SITE-TO-SITE TRANSFER 

1. Connect to each site (source and destination).  
2. Choose Window > Tile from the menu. 
3. Drag the file from one Remote Pane to another. The Queue pane displays a double 

arrow (<->), to indicate a site-to-site transfer.  

TO DISPLAY MORE THAN ONE REMOTE SITE AT A TIME 

1. Connect to two or more sites. 
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2. Choose Window > Cascade, or Window > Tile from the menu. 
3. Select Maximize in the upper right of any remote pane to return to the default, 

tabbed view. 

CONFIGURATION NOTES 

• If you are transferring between sites with SSH2 or SSL connections, transfers 
between them are not secure unless both servers support SSCN. 

• Because site-to-site transfers are considered a security risk, many servers do not 
support them or optionally decline to do so. The following table displays supporting 
servers.  

BLUE servers must be present for successful site-to-site transfer.  
RED servers make site-to-site transfers impossible.  
BLACK servers can perform site-to-site transfers if a BLUE server is on the other 
side.  
A site-to-site transfer with at least one RED server or two BLACK servers will fail.  
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You can configure the ProFTPD 1.2.3 Orc3 server, the wu-ftpd 2.6.0 server and the MS IIS 
5.0 server to allow FXP. 

HIS

Sep
clie
between them by issuing a PASV command on one server and then a matching PORT 
comm er instead of to a client. This 
behav ly known as FXP. 

Multi-part (accelerated) transfers 
You c ulti-part 
transfe

O PERFORM A MULTI-PART DOWNLOAD 

1. 
2. 
3. 
4. nload Advanced >  Multi-part Download. 
5. Choose HIGH to split the file into two parts or MAX to divide the file into more 

T

1
2
3 anced >  Multi-part Upload. 
4

TORY OF FXP 

arate CONTROL and DATA connections allows transmitting data not only between 
nt and server; it allows a client to control two FTP servers at once and transfer data 

and on the other. Thus, one server connects to the oth
ior is not a hack; it is part of the official FTP specs. Today, it is wide

an greatly speed up the transfer of large files with multi-part transfers. A m
r divides large files and sends the parts over multiple FTP sessions.  

T

Connect to a remote site. 
Select the file you want to transfer in the Remote Pane. 
Open the destination folder in the Local Drives pane. 
From the menu, choose File > Dow

parts. 

O PERFORM A MULTI-PART UPLOAD 

. Connect to a remote site. 

. Select the file you want to transfer in the Local Drives pane. 

. From the menu, choose File > Upload Adv

. Choose HIGH to split the file into two parts or MAX to divide the file into more 
parts. 

Note: 
You can only use multi-part uploads with servers that support the 
COMB command, such as GlobalSCAPE Secure FTP Server.  

Note:  
Very large files can take time to combine, so you might have to manually 
refresh (F5) the screen after a large multi-part transfer to see the resulting 
single, combined file on the remote server.  
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Tip: 
You can quickly gauge the effectiveness of the transfer by highlighting 
that item in the queue pane, and clicking on the small plus sign + next to 
the item name. The item will expand to show you all parts of the transfer 
with the average speed of each part.  

CONFIGURATION NOTES 

• r files.  
• r sites that do not support resume downloading.  
 Multi-part transfers are not very effective within your own network. 

 slower than 56kb, because most 

• w multiple simultaneous 
address.  

• the proce sor of a server when generating encrypted 
loads over SSH and SSL can be ineffective and are not 

Accelerating ASCII transfers with Mode Z 
Mo n compresses files on the fly as you transfer, saving bandwidth and 
improving transfer times. This feature is turned on by default, and is used whenever you 
connect to a server that supports Mode Z. 

2. ansfer from the left-hand navigation pane. 
on to ASCII transfers when possible. 

Tran

TO CH

enu, choose File > Transfer Type. 
Auto. 

LE TYPES IN ASCII MODE 

1

2
3. Select ASCII Types. 

Multi-part transfers are not very effective for smalle
Multi-part downloads do not occur fo

•

• Multi-part transfers are not very effective for modems
FTP servers can at least transfer at that speed.  
Multi-part transfers do not work if the FTP site does not allo
connections from the same user or IP 

n sDue to added overhead o
transfers, multi-part down
recommended. 

de Z compressio

To turn on Mode Z compression 
1. From the menu, choose Tools > Global Options. 

Select Tr

3. Select Apply MODE Z compressi

sferring files in binary or ASCII mode 

OOSE THE TRANSFER MODE 

1. From the m
2. Choose ASCII, Binary, or 

TO TRANSFER SPECIFIC FI

. From the menu, choose Tools > Global Options. The Global Options window 
appears. 

. In the left pane, expand Transfer. 
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4  file type you want to transfer in 

5
6
7  

TO T

window 

2. In the left pane, expand Transfer. 
transferred in ASCII mode will 

be displayed. If the file type you want to transfer is not displayed, select OK and 

4.  extension of the file you want to transfer in binary mode. 

CONFIGURATION NOTES 

fer type, and sends files in the mode specified for each file's 
extension. All extensions are sent in binary mode unless they are listed in Global 

• 
r this 

by a e feeds prior to uploads and restores them during 

• You r type for a particular site in your Site Manager under its Site 

• 
T a

 

 Global Options. The Global Options dialog 

. In the right pane, enter the file extension for the
ASCII mode in the ASCII extensions box. If the extension is already in the list, 
proceed with the transfers. 

. Select Add. 

. Select OK. 

. Proceed with transfers.

RANSFER SPECIFIC FILE TYPES IN BINARY MODE 

1. From the menu, choose Tools > Global Options. The Global Options 
appears. 

3. Select ASCII Types. A list of the file types that are 

proceed to step seven. If it is displayed continue with step four. 
Select the

5. Select Remove. 
6. Select OK. 
7. Proceed with transfers. 

• Auto is the default trans

Options > Transfer Settings > ASCII Types. 
SSH2 servers do not support ASCII transfers (see 
http://www.ssh.com/tech/archive/secsh.cfm). CuteFTP Professional adjusts fo

utomatically stripping lin
downloads (prior to the file getting written to disk). 

 can specify the transfe
Properties > Type tab.  
You can change the transfer type for a single CuteFTP session by choosing File > 

r nsfer Type from the menu. Once CuteFTP is restarted, it reverts to the transfer 
 set under Global Options. type

Verifying integrity of transferred files 

TO VERIFY FILES HAVE SUCCESSFULLY TRANSFERRED

1. From the menu, choose Tools >
appears. 

2. In the left pane, expand Transfer. 
3. Select Events. 
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4. In the right pane, select the Verify file integrity when transferring to/from 

CO

d ONLY if all of the following are true statements:  
• The file integrity feature is turned on in CuteFTP.  

 > Global Options > 

• 

• supports resume 
ability).  

Few s e Transfer 
Server

Com

O COMPRESS FILES FOR UPLOADS 

1. 
2. 
3. 
4.  menu, choose File > Upload Advanced > Upload Compressed. 
5. The menu di ee different extensions. Each extension 

ion scheme. 
6. 

TO 

1. Choose the local folder where the archive is located. 
cal Drives pane. 

GlobalSCAPE's FTP Server check box. 
5. Select OK. 

NFIGURATION NOTES 

The File Integrity CRC Checksum is use

• The FEAT command is enabled in CuteFTP (Tools
Navigation Settings). 

• The remote server supports both FEAT and XCRC and has enabled it for the 
specific user account.  
The files are binary files transferring in binary mode.  

 The destination file size is smaller than the source and the server 
OR the destination is equal to the source size (regardless of resume cap

ervers, other than GlobalSCAPE’s Secure FTP Server and Enhanced Fil
, support the required XCRC command. 

pressing and Decompressing 

T

Connect to a site.   
Choose the destination folder in the Remote pane. 
Select the item(s) you want to upload in the Local Drives pane. 
From the

splays file names with thr
identifies a compress
Choose the file name with the extension for the compression scheme you want. 

DECOMPRESS A LOCAL ARCHIVE 

2. Select the archive to be expanded in the Lo
3. From the menu, choose Tools > Compression > Decompress. The contents of 

the archive expand into a directory with the same name as the archive. 

Note: 
You cannot decompress a file on a remote FTP server from within 
CuteFTP's interface. To decompress an archive remotely, use a tool such 
as CuteZIP and GlobalSCAPE SecureFTP Server and create an Event 
Rule or Custom Command (on the Server) that will decompress archives 
uploaded to the server (either automatically, or as a result of a custom 
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command sent by the client). See this custom command example for 
more information.  

 

Note: 
To created encrypted archives for upload, you need a copy of CuteZIP 
and a call script to encrypt, compress and then upload an archive. For 
more information, see Automatically encrypting and compressing 
transfers. 

CONFIGURATION NOTES 

• .zip is the industry standard archival method (wide support, medium compres
.cab is a Micro

sion).  
• soft format (not very wide support, stronger compression than ZIP).  

mpressed).  

Using scripts to transfer files 
You can write scripts to transfer files using CuteFTP Professional's Transfer Engine (TE). 

 directly with the TE using common programming languages 
such as Visual Basic (VB) or other scripting languages supported by the Windows Scripting 

d examples are available in Transfer Engine Help. 
ou can also use CuteFTP's macro recorder to capture entire sessions to a script for future 

play c

• .gzip/tar is a UNIX format (files are stored in a “Tarball” then co

With scripts you can interact

Host (WSH).  
Sample scripts an
Y

ba k. 

Tip: 
To conserve resources, if you leave CuteFTP or the Transfer Engine 
open to accomplish a number of tasks, you should set CuteFTP to delete 
successfully finished items from the queue.   

Recording a macro 
CuteFTP Professional can record and playback entire sessions using the powerful macro 
record/playback tool. Sessions are recorded in Visual Basic Script and take advantage of 
Cut T fer engine (TE) interface. 

To start recording a macro  
Tools > Macros and Scripting > Record > Start 

d perform the tasks you want to record.   
 recording the macro click Tools > Macros and Scripting > 

Record > Stop Recording. 
4. Enter a name for the macro in the Filename box and select Save. 

eF P's COM exposed trans

1. From the menu, choos
Recording.   

e 

2. Connect to your site an
3. When you are finished
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CONFIGURATION NOTES 

The m nal's TE 
COM 
 

g all parameters (OTP, CCC, 
AUTH_TLS, etc.) 

• Upload  

• 

• 

• Command 
 

acro recorder can record most events supported by the CuteFTP Professio
interface: 

• Connect (FTP, FTPS, SFTP, HTTPS) includin

• Disconnect 

• Download 
Site to Site Transfer 

• Synchronize 
• URL Transfer 
• Create Local Folder 
• Create Remote Folder 
• Rename Local Folder 
• Rename Remote Folder 

Remove Local Folder 
• Remove Local Folder 

Raw FTP 

Note: 
The macro recorder uses all defined parameters set in the CuteFTP 
interface for Socks and Proxy information. Therefore, there is no need to 
add "UseProxy" to the resulting script (macro) that is created. 

Playing back a recorded macro 

TO PLAYBACK A MACRO FROM WITHIN CUTEFTP'S INTERFACE 

se. An 

2. Navigate to the folder where your macro is saved. 

 closes and the macro runs. 

TO M OUTSIDE OF CUTEFTP'S INTERFACE 

e macro file you previously created as 

1. From the menu, choose Tools > Macros and Scripting > Run > Brow
Open dialog appears. 

3. Select the macro. 
4. Select Open. he Open dialog

 PLAYBACK A MACRO (SCRIPT) FRO

1. In Windows Explorer, locate th
"something.vbs" and run it. 
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2. CuteFTP's Transfer Engine performs the recorded events without launching the 
interface. 

Note: 
Y pting Host (WSH) installed in order to ou must have the  Windows Scri
playback recorded macros or scripts. 

Ad
Custom Commands allow you to specify a raw FTP command sequence and assign shortcuts 

 

TO   

1. choose Tools > Custom Commands > Edit Custom 

 dialog box, click the New Folder

ding custom commands 

or toolbar links to these sequences. 

 ADD A CUSTOM COMMAND

From the menu, 
Commands.  

 2. In the Custom Commands button.  

and

3. Enter a name for the folder. 

 . 4. Select New Comm

5. Enter a name for the command. 

6. Select Properties button.  
7. In the Custom Command Properties dialog box, enter the command or command 

8. Optionally, select Shortcut Key and then press the keys on your keyboard for the 

9. . Select the 

10. Select Place on the custom commands toolbar to include the new command on 

mmands dialog 
box. 

TO A  

eak between command sequences when entering them into the 
Command box. 

TO

ite. 

sequence you want in the Command box.  

shortcut. This step is optional. 
Optionally, select Change Icon to select a toolbar icon for the command
icon you want, then select OK.  

the Custom Commands toolbar.   
11. Select OK twice to accept the changes and close the Custom Co

DD COMMAND SEQUENCES

1. Follow steps 1-7 above. 
2. Add a line br

Example: USER %u \n PASS %p 

 USE A CUSTOM COMMAND  

1. Connect to a s
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2. From the menu, choose Tools > Custom Commands> (your command).  

TO DI

• View > Toolbars > Custom Commands Bar. 
 

SPLAY THE CUSTOM COMMANDS BAR 

From the menu, choose 

Note: 
The remote site must be the active pane for a command to be sent. Once 
sent, you can view the server’s response in the log window. 

Saving and reusing a list of transfer tasks 

 LIST OF TRANSFER TASKS 

e > Load & Save Queue > Save Queue. 

O REUSE A LIST OF TRANSFER TASKS LOAD A PREVIOUSLY SAVED QUEUE) 

ve Queue > Load Queue. 

TO SAVE A

1. From the menu, choose Tools > Queu

2. Choose a name and location in the Save As dialog box. 
3. Select Save. 

T (

1. From the menu, choose Tools > Queue > Load & Sa

2. Select the a previously saved Queue file in the Open dialog box. 
3. Select Open. 
4. From the menu, choose Tools > Queue > Transfer All. 

Notes: 
When you drag items from the local drive to the Queue, they transfer to 
the site currently displayed in the Remote pane. 
 
Queue files are saved with a .cpx extension. 

 
 

Improving slow transfers 
If y g CuteFTP. Try the 

ED ON 

Mo s they are transferred. Reducing the file size reduces 
the necessary bandwidth and improves transfer times. If this option is turned on CuteFTP 
will take advantage of any server that supports Mode Z. 

ou are having problems with slow transfer speeds, try fine tunin
following:  

MAKE SURE THAT MODE Z IS TURN

de Z compression compresses files a
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TWEAK THE RECEIVE AND SEND BUFFERS 

Setting these buffers allow you to fine tune transfers over high latency or lossy connections 
legacy CDMA wireless connections. It is unlikely you 

will ever need to adjust this setting, but if you have problems with successful transfers and 

 
s should be set to the 

same size. The default is set at 65536 bytes, the normal maximum window size of TCP.  
 the available bandwidth with network monitoring 

tools. There is some guesswork involved, as most tools are not entirely accurate, but they 

have high latency, a higher buffer size might 
help. 

dwidth times the latency of the link. So,  

s and you have a latency of 200ms (.2 seconds), your 

r is set to 
65536 (64kb), try 32768 (32kb). 

TURN OFF TIME STAMP IN LOGS 

When this feature is on, CuteFTP adds a time stamp next to each log event. This option 
doe nce is critical, you can turn this off. For 
mo isplay time stamps in Log file settings

TR

If you are transferring large files, try using a multi-part transfer. You can only use this option 
if the server you are connecting to supports it. 

CHECK THE GLOBAL BANDWIDTH LIMIT 

Che  throughput. This setting in Global 
Op sions on CuteFTP. See Global bandwidth limits in 
Tra

like those over satellite links or with 

suspect the latency or quality of the connection is at fault, try tweaking these buffers. 
The receive buffer holds data until CuteFTP is ready to read it; the send buffer holds data
until it can be sent to the server. Typically, both send and receive buffer

You can measure the latency and estimate

can guide you to finding a sweet spot where transmissions are successful. If you have a lossy 
connection, try lowering the buffer size. If you 

Normally, the optimal buffer size is your ban
bandwidth (in bits) * latency (round trip time in 
seconds) = socket buffer size (in bits) 

Convert bits to bytes (bits/8=bytes) for the buffer size. 
So, if your bandwidth is 1,536,000 bp
socket buffers should be set to 38400: 

1536000*.2=307200 bits 
307200/8=38,400 bytes 

You can also try halving or doubling the buffer size. For example, if the buffe

s consume system resources,
re information, see Record/D

 and if performa
 

-  Y USING MULTI PART TRANSFERS

ck to see if the global bandwidth limit is limiting your
tions throttles the bandwidth of all ses
nsfer Settings. 
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Transferring manually 
 its exact location and you are unable 

TO DOWNLOAD A FILE MANUALLY 

1. Select the destination folder in the Local pane. 
 where the file exists. 

 
o Download dialog appears. 

d path, type the path to the file you want to download.  
6. Select OK.  

TO UP

1. Connect to a site. 
2. Open the destination folder in the Remote pane. 
3. In the Local pane select any file. 
4. From the menu, choose File >  Upload Advanced > Upload Manually. The File 

to Upload dialog appears. 
5. In Upload path, enter the complete path to the file you want to upload.  
6. Select OK. 

Manually enter FTP commands 
You can communicate with an FTP site on the lowest possible level. 

TO MANUALLY ENTER AN FTP COMMAND 

1. Connect to a site. 
2. From the menu, choose Tools > Enter FTP Command. 
3. Enter the command such as LIST or CWD or PWD in the Input FTP command 

box. 
4. Select OK. 

Use this function to transfer a specific file if you know
to navigate to that location or do not have LIST permissions for that folder. 

2. Connect to the site
3. Select any file or folder. 
4. From the menu, choose File > Download Advanced > Download Manually. The

File t

5. In Downloa

LOAD A FILE MANUALLY 

Note: 
You can also input multiple commands to the FTP server by using the 
Custom Commands feature.  

90 



 

9 

Managing Files and Folders 

Opening, editing, renaming and deleting files 
You can work with files on local and remote drives from within CuteFTP. 

TO OPEN A FILE 

1. Select a file in Local Drives or the Remote pane. 
2. From the menu, choose File > Execute.  The selected program opens and displays 

or runs the file. 

Note 
File > Execute only works on executable files.  

TO EDIT A FILE 

1. Select a file in Local Drives or the Remote pane. 
2. From the menu, choose File > Edit or File > View. The file opens in CuteFTP's 

built-in HTML editor. 
3. Make any desired changes. 
4. To save the changes, choose File > Save from the menu. 

Note: 
The integrated editor opens in full-screen mode. When you exit the 
editor, CuteFTP restores the screen to its original state. Cycle through 
the open panes, including any editor tabs, by pressing Ctrl+Tab on your 
keyboard. 

TO RENAME A FILE 

1. Select a file in Local Drives or the Remote pane. 
2. From the menu, choose File > Rename.   
3. Enter the new name for the file and press the Enter key on your keyboard. 
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Warning:  
If you change the extension when you rename the file, you may not be 
able to open the file in the proper program. 

TO DELETE A FILE 

1. Select a file in the Local Drives or the Remote pane. 
2. From the menu, choose File > Delete.  CuteFTP displays a message asking if you 

are sure you want to delete the file. 
3. Select Yes. 

Updating or refreshing folder listings 
To update or refresh a folder listing 

1. Click in the pane where the folder is displayed. 
2. On the menu bar, click View > Refresh. 

 

To update remote folder listings automatically 

1. On the menu bar, choose Tools > Global Options. The Global Options window 
appears. 

2. In the left pane, select Navigation. 
3. Select the Auto-refresh the remote pane after uploading a file or folder check 

box. 
4. Click OK. 

Listing files and folders in order 

TO SORT FILES AND FOLDERS IN ORDER BY NAME 

1. Select the Remote or Local Drives pane. 
2. From the menu, choose View > View > Details. 
3. Select the Name column header in the Remote or Local drives pane. 
4. Each time you select the column header the items list in the opposite order. 

Tip: 
You can sort by any column when in Details view. 

TO SORT FILES AND FOLDERS IN ORDER IN THE QUEUE 

1. Select the Queue pane. 
2. Select a column header in the Queue pane. The transfer items are listed in alphabetic 

order of the selected column's contents. 
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3. Each time you select the column header the items list in the opposite order. 

Note: 
The order items are listed in the queue is not necessarily the order in 
which they transfer. The numbers in the leftmost column of the queue 
indicate the order of transfer. 

Changing how files and folders are displayed 
You can display files and folders in one of four ways: 

LARGE ICONS 

1. Select  the Local or Remote drives pane. 
2. From the menu, choose View > View > Large Icons. 

SMALL ICONS 

1. Click in the Local or Remote drives pane. 
2. From the menu, choose View > View > Small Icons. 

LIST 

1. Right click in the Local or Remote drives pane. 
2. From the menu, choose View > View > List. 

SIZE AND DATE DETAILS 

1. Right-click in the Local or Remote drives pane. 
2. From the menu, choose View > View > Details. 

Finding files and folders 
Search for a specific file or folder in a local folder or a remote folder. 

TO FIND A FILE OR FOLDER 

1. Select the directory level you want to search. 
2. From the menu, choose Edit > Find. 
3. Enter the item name. You can also use wildcards. 
4. Select OK. 
5. If the item you wanted wasn't selected, choose Edit > Find Next until it is. 
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Note: 
Find and Find Next are not case sensitive and only search from the top 
to the bottom of your listings. 

Selecting a group of items 
You can select (highlight) items in the remote, local, or queue pane by name or type using 
Group Select and wildcard masks. 

TO SELECT ALL FILES OF A CERTAIN TYPE 

1. Choose the pane displaying the files you want to select. 
2. From the menu, choose Edit > Group Select. 
3. In the Select group box, enter *. (asterisk, period) and then the extension for the file 

type you want to select. 
4. Clear Mask directories to exclude folders from the selection. 
5. Select Remove Selection to include previously selected files in the new group you 

are selecting, or clear the check box to unselect any previously selected items that are 
not in the new group.   

6. Select OK. 

TO SWITCH A SELECTION FROM THE HIGHLIGHTED TO GROUP, TO ALL NON-
HIGHLIGHTED ITEMS 

• From the menu, choose Edit > Invert Selection. 

TO REMOVE ITEMS FROM A GROUP SELECTION 

1. Select the items to remove from the group. 
2. Choose Edit > Group Deselect from the menu. 
3. In Deselect group, enter the name of the file you want to remove, or use wildcard 

masks to remove a group of items. 
4. Select Mask directories to include folders in the action. 
5. Select OK. 

Moving items from one folder to another on a remote 
server 
Move selected items from one remote folder to another remote folder on the same server. 
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TO MOVE ITEMS FROM ONE REMOTE FOLDER TO ANOTHER 

1. Connect to a site. 
2. Open a folder on the remote site. 
3. Select items in the folder. 
4. From the menu, choose Edit > Move to Folder. 
5. Enter the path where you want to send the selected items in the Move to folder 

box. 
6. Select OK. 

Changing file and folder permissions 
You can set who can open, change, or delete files and folders on remote sites. 

TO CHANGE PERMISSIONS FOR A SINGLE REMOTE FILE OR FOLDER 

1. Connect to a site. 
2. Select the file or folder you want to change permissions for. 
3. From the menu, choose File > Properties. 
4. Select the permissions desired. 
5. Select OK. 

TO CHANGE PERMISSIONS FOR A GROUP OF REMOTE FILES OR FOLDERS 

1. Connect to a site. 
2. Select a group of files or folders. 
3. From the menu, choose File > Properties. 
4. Select the check boxes next to the permissions you want for yourself (Owner), a 

Group of users, and the general Public. 
5. Select OK. 

CONFIGURATION NOTES 

• A gray check signifies the permission is granted for some files in a selected group, but 
not in others. You can still change the permission for the whole group. 

• If you cannot change permissions for a file or folder, the FTP server administrator 
must modify your account or the file permissions before you can modify permissions. 

Choosing which files and folders to display (Filtering) 
When you apply filters, you do not add or remove files, you simply set which files will be 
visible or invisible in CuteFTP. 
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TO CHOOSE WHICH FILES TO DISPLAY 

1. From the menu, select View > Filter. 
2. Select the Enable Filtering check box. 
3. Select the Filter Mask tab. 
4. Enter the names of files you want to display, or use wildcard masks to include a 

group of files. 
5. Select Add. 
6. Select the Filter NOT Mask tab. 
7. Enter the names of files you want to Hide, or use wildcard masks to exclude a group 

of files. 
8. Select OK. 

TO CHOOSE WHICH FOLDERS TO DISPLAY 

1. From the menu, select View > Filter. 
2. Select Enable Filtering. 
3. Select Apply filtering to folder name(s). 
4. Select the Filter Mask tab. 
5. Enter the names of files and folders you want to display, or use wildcard masks to 

include groups of files and folders. 
6. Select Add. 
7. Select the Filter NOT Mask tab. 
8. Enter the names of files and folders you want to Hide, or use wildcard masks  to 

exclude groups of files and folders. 
9. Select OK. 

TO USE FILTERS WITH TRANSFERS 

1. From the menu, select View > Filter. 
2. Select Enable Filtering. 
3. Select Apply to file transfers. 
4. Set your filters in the Filter Mask tab and Filter NOT Mask tab. 
5. Select OK. 

TO MAKE FILTERS CASE SENSITIVE 

1. From the menu, select View > Filter. 
2. Select Enable Filtering. 
3. Select Case sensitive filtering. 
4. Set your filters. 
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5. Select OK. 

TO USE SERVER FILTERS 

1. From the menu, select View > Filter. 
2. Select Enable Filtering. 
3. Select Enable server side filtering. 
4. Enter in a filter from the Unix ls program. 
5. Select OK. 

Displaying hidden files or folders 
By default, some servers will hide files with names starting with a period such as ".htaccess" 
or ".profile".   

TO SEE HIDDEN FILES ON A REMOTE SITE 

1. Select the Site Manager tab. 
2. Select the site with the hidden files. 
3. Choose File > Properties from the menu. 
4. Select the Actions tab. 
5. Select Filter.  
6. Select Enable filtering.  
7. Select Enable server side filtering.  
8. Enter -a in the Remote field.  
9. Select OK. 
10. Connect to your site.  

Comparing folder contents by size and date 
Use the Compare Folder Contents tool to highlight differences between a remote and a 
local folder.  

TO COMPARE FOLDER CONTENTS BY DATE 

1. Display a folder to in the Local Drives pane and connect to the folder you want to 
compare it to in the Remote pane. 

2. From the menu, choose Tools > Folder Tools > Compare Folder Contents. 
3. Select Compare dates. 
4. Select Ignore case to compare all files with the same name, regardless of differing 

upper or lower case letters. 
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5. Select OK. CuteFTP compares all items with the same name and highlight any files 
or folders with time stamps that are different between the server and local folder. 
CuteFTP also highlights items that only exist on one site or the other. 

TO COMPARE FOLDER CONTENTS BY SIZE  

1. Display a folder in the Local Drives pane. 
2. Connect to the folder you want to compare in the Remote pane. 
3. From the menu, choose Tools > Folder Tools > Compare Folder Contents. 
4. Select Compare sizes. 
5. Select Ignore case to compare all files with the same name, regardless of differing 

upper or lower case letters. 
6. Select OK. CuteFTP compares all items with the same name and highlight any files 

or folders with sizes that are different between the server and local folder. CuteFTP 
also highlights items that only exist on one site or the other. 

Note: 
Once differing files are highlighted, click and drag one file to move all of 
the files together. 
If you clear Ignore case, two files with the same name spelled in 
differing case are treated as two different files. For example, test.txt and 
TEST.txt are considered two different files. If Ignore case is selected, 
test.txt and TEST.txt are considered the same. 

 

Synchronizing folders 
Use the synchronization tools to automatically make the contents of a remote and local 
folder exactly the same. You can monitor more than one folder, or synchronize multiple 
sites. Just schedule and queue the synchronizations you need. 

TO SYNCHRONIZE FOLDERS 

1. From the menu, choose Tools > Folder Tools > Synchronize Folders.  
2. In Enter the local path to synchronize, type in the path, or browse to the local 

folder you want to synchronize. 
3. In Enter the remote path to synchronize, type in the path, or browse to the local 

folder you want to synchronize.  
4. In Please select the direction of synchronization, choose to Mirror Local, Mirror 

Remote, or Mirror Both. 
Mirror Local keeps the local folder the same and changes the remote folder to match. 
Mirror Remote keeps the remote folder the same and changes the local folder to 
match. 
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Mirror Both adds files to both folders and puts the latest version of all files in both 
folders. 

5. If you want to include contents of subfolders in the synchronization select the 
Include subfolders check box. 

6. Select the Start now button, 
OR 

select the Schedule button to automatically to start the synchronization later, or to 
repeat the synchronization at regular intervals. 

TO REPEAT SYNCHRONIZATION AUTOMATICALLY  

1. Select Tools > Folder Tools > Synchronize Folders. 
2. Choose the folders and the direction. 

3. Select the Schedule button.  
 check box.  4. When the scheduler appears, select the Schedule the current item

Tools Queue Remove Selected

• 
y to file 

5. Select the Enable recurrence check box.  
6. Choose how often you want the synchronization to repeat.  
7. Select OK. The task is added to your queue. If you close CuteFTP Professional, the 

Transfer Engine (represented by the icon in the System tray) still handles the 
mirroring and scheduling.  

TO STOP A SYNCHRONIZATION TASK 

1. Select the task in the Queue Window. 
2. From the menu, choose  >  > . 

TO USE FILTERS WITH SYNCHRONIZATIONS 

When you set up the synchronization , right-click in the pane you want to filter (local 
or remote), select Filter... and make sure that Enable filtering and Appl
transfers are selected. The filter definitions in place when you set up the 
synchronization are applied. For more on using filters, see Filtering transfers. 

ADVANCED FOLDER SYNCHRONIZATION 

1. Select Tools > Folder Tools > Synchronize Folders. Select Advanced to display 
additional synchronization options. 
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Advanced folder synchronization 
Select Tools > Folder Tools > Synchronize Folders. Select Advanced to display 
additional synchronization options.    

FOR MATCHING FILENAMES ALWAYS  

Use this setting to control the action taken by CuteFTP when synchronizing files with 
identical names.  

• Use global overwrite settings This is the default choice. This uses overwrite settings 
adjusted for all sites in Tools > Global Options > Transfer > Smart Overwrite.  

• Overwrite The transferring file replaces the destination file. When mirroring both 
folders, the most recent version of the file is kept. 

• Numerate Both files are kept, and one is renamed with a number to distinguish 
between the two.  

• Skip ignores matching files, and only transfers those files not yet present on the other 
system.  

REMOTE FILE NAMES THAT DIFFER ONLY IN CASE  

Use this setting to tell CuteFTP what to do with files having identically-spelled but 
differently-cased names. You can choose:  

• Transfer first file only and skip others:  The first file transfers and the rest are 
skipped. 

• Numerate files: Both files are kept, and one is renamed with a number to distinguish 
between the two.  

• Show rename prompt: CuteFTP prompts you to rename one of the identical files.  
Since Windows file systems do not support case-sensitive file names, you may want to use 
this option when working with file systems that do (like Unix).  

IGNORE SYMBOLIC LINKS  

Select this option to prevent CuteFTP from following symbolic links when mirroring 
subfolders. This option should be left on unless symbolic links are absolutely needed. If you 
disable this option and a symbolic link points to a spot further up the folder tree from where 
the mirroring began you can get stuck in an infinite loop.  

WHEN ONE-WAY MIRRORING, DELETE DESTINATION FILE IF IT DOES NOT EXIST IN 
THE SOURCE FOLDER  

Select this option to make the mirrored folder a strict duplicate of the source folder. This 
updates old files and deletes unused files. If you disable this option, any extra files present in 
the mirrored folder are left in place.  
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ALWAYS PROMPT BEFORE DELETING  

Disable this option to turn off the pop-up box that asks if you are sure you want to delete a 
file. If you plan to run synchronizations automatically, clear this check box, or the process 
will stop until the file deletion prompt is manually cleared. 

TRANSFER ALL FILES IN BINARY TO COMPENSATE FOR ASCII FILE DIFFERENCES  

Select this option to compensate for a problem that occurs when trying to synchronize 
ASCII files residing on UNIX file systems. Windows and UNIX differ slightly on how they 
store ASCII files, especially with regards to the End Of Line (EOL) or line breaks in ASCII 
documents. This difference causes an otherwise identical file to be seen as “different” when 
performing a synchronization tasks, due to the difference in size.  
By forcing binary transfers, all files are transferred in binary mode, which would mean that 
an ASCII file residing on a local system would be transferred to the remote server with its 
EOLs intact. Some Web servers can accommodate for this while others may not. This could 
result in an html or other ASCII document not being displayed in the end user’s browser.  
Experiment with the two options if you are unsure of which one to choose. By default, force 
binary is turned off, as extra traffic might be acceptable, but conserving EOLs in a UNIX 
environment may not.  

Backing up remote folders 
You can schedule CuteFTP Professional to regularly create copies of remote files and folders 
on your local computer.  You can also compress the backup automatically. 

TO BACKUP A REMOTE FOLDER 

1. From the menu, choose Tools > Folder Tools > Backup Remote Folder(s). 
2. Enter the local path for the backup folder in Local backup folder. 
3. Enter the path to the remote folder you wish to replicate in Remote path for 

backup. 
4. Select Include subfolders to backup all folders within the target folder. 
5. Choose a compression scheme from the Compression list. 
6. Select Start, or if you want to schedule or repeat backups: 

For repeated or timed backups 
6. Select Schedule. 
7. Select Schedule the current item and choose a starting date and time. 
8. Select Enable recurrence and select how often you want the backup to repeat. 
9. Select OK. 
10. Select Start. 
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TO DISCONTINUE A SCHEDULED BACKUP TASK 

1. Select the task in the Queue. 
2. From the menu, choose Tools > Queue > Remove Selected. 

Monitoring a local folder for changes  
You can automatically upload any new or modified files or folders added to a specific local 
folder. 

TO AUTOMATICALLY UPLOAD CHANGES TO A LOCAL FOLDER 

1. Connect to the site that contains the folder that you want to upload changed or new 
files to. 

2. From the menu, choose Tools > Folder Tools > Monitor Local Folder(s). 
3. In Local folder to monitor, select the browse button and navigate to the folder you 

want to monitor. 
4. Select Include subfolders to monitor all folders within the target folder. 
5. Verify that the full ftp address for the remote folder where you are uploading the 

files to is correct. 
6. Choose the file modified date you want to begin monitoring changes on. 
7. Select Always overwrite to overwrite any file with the same name on the server. 

Warning:  
If you select this check box, Smart Overwrite rules are ignored and there 
will be no warning before files are overwritten. 

7. Select Apply monitor filters and choose Filters to monitor only certain files or file 
types in a folder. 

8. Select Attempt to autodetect... to use system functions to better determine when a 
file is modified. If unchecked, CuteFTP cycles through the folder at the rate defined 
by Monitor folder every n seconds and looks for changes to the modified time-
stamp. 

9. Select Start. 

CONFIGURATION NOTES 

• Items deleted from the local folder will not be deleted from the remote folder. 
• To discontinue a scheduled backup task 

1. Select the task in the Queue. 
2. From the menu, choose Tools > Queue > Remove Selected. 
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Listing files from HTTP sites 

TO LIST FILES ON HTTP SITES 

1. Connect to an HTTP site within CuteFTP Professional. 
2. Files on the site will be listed in the remote pane. 

CONFIGURATION NOTES 

When you connect to HTTP sites in CuteFTP, the sites do not list file sizes, attributes, or 
dates like FTP sites do. This is because HTTP listings are not actual lists of files on the 
server. 
CuteFTP downloads the server’s index.html file and parses it, looking for links. Each link is 
then listed as an available file in the HTTP site’s window. Because this is not an actual file 
listing, there may be files on the HTTP site not accessible to CuteFTP. Also, some of the 
files may just be links that lead to another HTTP site. 
If you connect to an HTTP site that does not support the listing of folder contents, 
CuteFTP attempts to guess the contents of the HTTP server by scanning its Web pages.  
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General settings 

GENERAL SETTINGS 

In this window, you choose when to start and stop the Transfer Engine, other startup 
options, and which folder to show in the Local Drives pane. 

To display the General Settings window 
1. From the menu, choose Tools > Global Options. 
2. Select General. 

Startup and exit events 
• Start the Transfer Engine on Windows startup  

o When selected, the Transfer Engine starts automatically when your computer 
starts up. 

o When not selected, the Transfer Engine does not start until you start CuteFTP, or 
call it from a script. 

• On startup   
o Choose Display Site Manager to display the Site Manager on program start. 
o Choose Do Nothing to keep the Site Manager from displaying on program 

start 
o Choose Connect to the last connected to Site Manager site to connect to the 

site you were connect to the last time you closed the program so long as the site is 
saved in the Site Manager. 

• On exit  
o Choose Don't close the Transfer Engine if tasks are pending to complete 

unfinished or scheduled transfers after CuteFTP is closed. The Transfer Engine 
automatically shuts down after the last scheduled transfer. 

o Choose Don't close the Transfer Engine to leave the Transfer Engine running 
even when CuteFTP is closed and there are no transfers to complete. The 
Transfer Engine stays open until the computer is shut down, or you close the 
Transfer Engine from the System Tray. 

o Choose Close the Transfer Engine to shut it down whenever you close 
CuteFTP. 
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Download folder defaults 
• Use the current folder in the local pane as the default  

o When selected, remote items dragged to the queue are downloaded to the folder 
displayed in the Local Drives pane. 

o When not selected, you can enter a path to a specific folder with Use (text field). 
o Use (text field) 

o Browse or type the path to a download location for remote items you place in the 
queue. All remote items dragged to the queue are downloaded to the specified 
folder. 

LOG DISPLAY AND CAPTURE SETTINGS 

To access the log display and log saving options 
1. From the menu, choose Tools > Global Options. 
2. Expand General Settings. 
3. Select Logs. 

Log text colors 
• STATUS  

o Select the STATUS:> color icon to choose a new color for all log window status 
messages. 

o ERROR  
o Select the ERROR:> color icon to choose a new color for all log window error 

messages. 
o COMMAND  

o Select the COMMAND:> color icon to choose a new color for all log window 
command messages. 

o OTHER  
o Select the OTHER:> color icon to choose a new display color for all other 

messages in log windows. 

Log text fonts  
• Select Font  

o Changes the style of text in the log windows. 

Other log settings 
• Enable session (control connection) logs  

o Select this to save each session log as a separate text file, and to display the log in 
the individual session log window. 

o Clear this to stop recording a log for each session, and to show no logs in the 
individual session log window. 

• Enable individual transfer item (data connection) logs  
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o Select this to save the log for each item transferred as a separate text file. 
o Clear this to stop recording a separate log for each item transferred. 

• Enable consolidated transfer logs (both session and all transfers in log pane)  
o Select this to display all logs in the Log Window in the bottom of CuteFTP 

interface.  This option also saves all activity in one log file. 
o Clear this to leave the Log Window blank and to stop recording all activity in a 

single log file. 
• Record/Display raw directory listing in logs  

o Select this to include file lists and permissions as part of session logs and 
consolidated logs. This returns a RAW list, which is used commonly for 
debugging. 

o Clear this to exclude file lists and permissions from session logs and consolidated 
logs. 

• Show individual logs for each connection window 

o Select this to show a log window in the remote pane for each site to which you 
connect. 

o Clear this to hide any log windows in the remote pane. 

Tip: 
Logs can consume a large amount of system resources (memory and hard 
drive space), depending on the amount and size of files being transferred. 
It is recommended that you disable most logging (especially data 
connection logs) when performing a transfer that consists of many 
thousands of files, especially small files. To further reduce resource use, 
go to the menu and choose Tools > Global Options. Select Transfer > 
Events, and select Remove successful transfers from the queue 
automatically. 

LOG FILE SETTINGS 

To access the log file settings 
1. From the menu, choose Tools > Global Options. 
2. Expand General. 
3. Select Log Files. 

Options 
• Log path 

o Browse or type a path to the folder where you want to save your log files. 
 
• Delete saved logs every...  

o Select this to automatically delete log files at time intervals you choose.  Choose 
to delete files after a specified number of days, hours, or minutes. 

o Clear this to keep all log files, or to delete them in other ways. 
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• Delete error logs after quitting the Transfer Engine  
o Select this to automatically delete error logs when the Transfer Engine shuts 

down. 
o Clear this to keep error logs after the Transfer Engine shuts down. 

• Delete logs of successful transfers immediately after completion  
o Select this to automatically delete the associated logs immediately after a 

successful task is finished. 
o Clear this to keep the associated logs after a successful task is finished. 

• Record/Display time stamps in logs  
o Select this to include the date and time in all log files. 
o Clear this to exclude the date and time from all log files. 

Note: 
This option consumes additional system resources due to insertion of 
time/date stamp at each log event. 

• Delete all logs  
o Select this to remove all log files from your log folder that are currently unused. 

Note: 
Logs for active sessions are not automatically deleted. 

• Delete listing cache 
o Select this to remove all remote file and folder listings CuteFTP has saved on 

your computer for offline browsing. 
 
• Thumbnail settings  

Choose from: 
o Retain images in thumbnail cache - thumbnails stored in the cache are not 

deleted when you exit CuteFTP or the Transfer Engine. 
o Delete images in thumbnail cache - the thumbnail cache is emptied when the 

Transfer Engine is exited. 
o Delete images older than value specified - Thumbnails are stored for the time 

specified by the thumbnail cache expiration drop down menu. 
o Delete thumbnail cache - Empty the cache at any time by selecting this button. 

Connection settings 

CONNECTION OPTIONS 

To display the Connection window 
1. From the menu, choose Tools > Global Options. 
2. Select Connection. 
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Options 
• Global max connections/transfers 

o Choose the number of simultaneous connections you will allow from CuteFTP.  
� On a Windows 95/98/ME computer you can choose up to 40 

connections. 
� On a Windows NT/2k/XP computer you can choose up to 200 

connections, but CuteFTP will warn you that more than 20 connections 
may compromise system performance.  

� Connections include transfers, browse sessions, and every single thread in 
a Multi-Part transfer. 

• Per site max connections/transfers 

o Same as Global max but on a per site basis. 

Note: 
If you choose to allow only one connection per site, you must transfer 
files over the browse session only (you can navigate or transfer, but not 
both at the same time). This may be needed in situations where the server 
does not allow more than one connection from the same user. If the 
server allows more than one connection, then it is recommended that 
you use a value greater than one, for example 5. That way you can 
transfer files and at the same time continue to navigate the site.  

• Connection retry attempts 

o Choose the number of times CuteFTP tries to connect to a site before giving up. 
You can set CuteFTP to try connecting up to 1,000 times. 

• Delay between retries in seconds 

o Choose how long CuteFTP waits before attempting a new connection after a 
failed connection. Choose up to 1,000 seconds (about 17 minutes). 

Note: 
CuteFTP does not automatically retry after fatal errors, such as a host 
unreachable (invalid IP address or host name), or upon receiving a socket 
1006n error, which usually has to do with the client not being able to 
connect to the host for various reasons (firewall blocking, network error, 
host is down, etc.).  

• Connection timeout in seconds: 

o Choose how long CuteFTP waits for an unresponsive server before it stops 
attempting a new connection. Choose up to 1,000 seconds (about 17 minutes). 

• E-mail address for anonymous logins 

o Enter the address you want to send to servers that require an e-mail address for 
anonymous logins.  By default, CuteFTP sends a simulated e-mail address. 

• Display the server's welcome message  
o Select this to display a pop-up window with information from the server when 

initial connections are successful. 
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o Clear this check box to skip the server's successful connection message. 
• Send the FEAT command after login to determine feature support 

o Select this to ask the server for a list of extended features it supports.   
o Clear this check box stop sending the FEAT command, the server won't respond 

with a list of supported features.   

Note: 
FEAT is used to determine whether extended features are supported, 
such as MDTM, MLST, and others. Not all servers support the FEAT 
command.  

• Send QUIT command before disconnecting 

o Select this check box to always send the QUIT command from CuteFTP no 
matter how you choose to disconnect. 

o Clear this check box to disconnect without sending the QUIT command. 
• Enable port mapping using UPnP 

o Select this to use the UPnP NAT interface (available in Windows XP) to provide 
proper port-mapping when connecting securely from behind a NAT/firewall 
using PORT mode (rather than PASV, due to the remote host also being behind 
a NAT/firewall). Without UPnP, you would need to manually set the port range 
in the client and also enable and forward them in the NAT/firewall device. 

Note: 
You can choose Max connections, Delay between retries, and Retry 
attempts for individual sites. Select the site to configure from Site 
Manager, then from the menu, choose File > Properties, and select the 
Options tab. 

• Assign PORT mode IP address and port range 

• Use this to specify an IP address and define a port range when establishing 
connections using PORT mode. 

Typically, this setting should be turned off, but if you are using SSL and are 
having difficulty negotiating a firewall, it may help to specify your public FTP 
address here to enable CuteFTP to successfully negotiate with the firewall or 
NAT. Optionally, you can specify a range of ports for issuing port commands. 

Tip: 
Use local port range when you have a defined limited number of open 
ports on your firewall. 

SMART KEEP ALIVE OPTIONS 

You can set CuteFTP to maintain an active connection to a server even if you aren't 
currently sending commands or making transfers, by using Smart Keep Alive (SKA). SKA 
sends commands at random intervals to the FTP server, maintaining an active connection. 

To access Smart Keep Alive options 
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1. From the menu, choose Tools > Global Options. 
2. Expand Connection. 
3. Select Smart Keep Alive. 

Options 
• Enable Smart Keep Alive (SKA) 

o Select this to automatically send commands to a server to keep a connection 
open, and to make all the SKA options available. 

o Clear this check box to disable SKA and to disable all SKA options. 
• Start SKA n seconds after the last command 

o Set how soon SKA begins after transfers and other activities have stopped. You 
can start SKA immediately or after 1,000 seconds (just under 17 minutes). 

• Maintain SKA for n minutes 

o Choose how long SKA sends commands to keep a connection open. You can set 
this for as little as one minute, and as much as 1,000 minutes (just under 17 
hours). 

• Send command at random intervals between n and n seconds 

o For after SKA has started, choose the shortest and longest time CuteFTP will 
wait before sending a command to keep the connection open. You can choose to 
set times as low as zero seconds up to 1,000 seconds (just under 17 minutes). 
Between 15 and 60 seconds are the defaults.  

• Commands 

o Select Add to include new FTP commands in the list of possible commands sent 
to keep a connection open. CuteFTP uses the listed commands. 

o Choose Remove after selecting a command in the list to exclude that command 
from the list of commands sent to keep a connection open. 

• If disconnected, auto-reconnect within n seconds 

o Select this to have CuteFTP attempt a new connection with a server that has 
closed a connection. Choose a delay time between zero and 100 seconds.  

o Clear this check box if you don't want CuteFTP to automatically attempt a new 
connection. 

INTERNET CONNECTION (DUN/LAN) SETTINGS 

DUN stands for Dial-Up Networking. LAN stands for Local Area Network.  If you connect 
to the Internet with a regular phone modem you are using Dial-Up networking.  If you 
connect to the Internet with a cable modem, DSL modem, or through a computer network, 
you are using a Local Area Network. 

To access Dial-up and Network settings 
1. From the menu, choose Tools > Global Options. 
2. Expand Connection. 
3. Select DUN/LAN. 
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Connection Type 
• Connect to the Internet using a LAN 

o Select this if you connect to the Internet with a Cable modem, DSL modem or 
through a computer network. 

• Connect to the Internet using a modem 

o Select this if you connect to the Internet using a modem over regular telephone 
lines. 

Dial-Up options 
• Use the following Dial-Up Networking connection 

o Select the dial-up connection you want CuteFTP to use.  The list includes every 
dial-up connection on the local computer that is available in MS Windows®. 
Many computers list only one. 

• Show authentication window (requires user input) 

o Select this to display the dial-up connection user name and password whenever 
CuteFTP attempts a connection. 

o Clear this check box to stop the display of the dial-up connection user name and 
password when CuteFTP attempts a connection. 

• Show error prompts (requires user interaction) 

o Select this to display messages when an error occurs with the dial-up connection.  
o Clear this check box to stop the display of error messages from the dial-up 

connection. 
• Disconnect from the Internet upon program exit 

o Select this to automatically disconnect from the Internet when CuteFTP or the 
Transfer Engine shuts down. 

o Clear this check box to keep the Internet connection active after CuteFTP or the 
Transfer Engine shuts down. 

• Number of times to attempt connection 

o Choose how many times CuteFTP tries to establish a dial-up connection to the 
Internet after a connection fails. You can choose from 0 to 1000 attempts. 

• Number of seconds to wait between attempts 

o Choose how long in seconds CuteFTP waits between attempts to establish a dial-
up connection to the Internet. You can choose from 0 to 1000 seconds (1000 
seconds equals almost 17 minutes). 

SOCKS 4 AND 5 CONNECTION SETTINGS 

SOCKS is a network proxy protocol that allows transparent Internet connections across a 
firewall. 

To access SOCKS 4 and 5 settings 
1. From the menu, choose Tools > Global Options. 
2. In the left pane, expand Connection. 
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3. Select SOCKS4 & 5. 
• Use the highlighted SOCKS server when connecting 

o Select this to connect to an FTP site through a SOCKS server. 
o Clear this check box to connect to an FTP site without connecting through a 

SOCKS server. 
• SOCKS 

o Select a host name in the list to make FTP connections through that specific server. 
o Select Add, then enter the server name in the Host name box to include a server in 

the SOCKS list.  
o Select Remove button to delete a highlighted server from the SOCKS list. 

• Host name 

o Select Add, then enter the name of a new SOCKS server. 
OR 
o Select a server from the SOCKS list, and edit the name. 

• Port 

o Enter the port for the server selected in the SOCKS list. The default port for 
SOCKS servers is 1080. 

OR 
o Select a server in the SOCKS list, and edit the port number. 

• Use Authentication 

o Select this  to have CuteFTP automatically send the proper user name and password 
for the SOCKS server when first connecting. 

o Clear this check box if you don't have a SOCKS user name and password, or if you 
choose to enter them manually upon connection. 

• User name 

o Enter or edit the user name for the highlighted SOCKS server. 
• Password 

o Enter or edit the password for the highlighted SOCKS server. 
• SOCKS type 

o Select either SOCKS4 or SOCKS5 to match the highlighted SOCKS server.   

Tip: 
SOCKS4 servers do not require usernames and passwords. If you need a 
username and password to connect to the server, it is a SOCKS5 server. 
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Note: 
Contact your system or network administrator for the proper Host name, 
Port, User name, Password and SOCKS type. 

PROXY CONNECTION SETTINGS 

To access proxy server settings 
1. From the menu, choose Tools > Global Options. 
2. In the left pane, expand Connection. 
3. Select Proxy Server. 

 

Configuration notes 
Use network connection proxy settings from Internet Explorer 

o Select this and CuteFTP uses the proxy settings already set in Internet Explorer to 
connect to FTP sites. 

o Clear this check box to connect to an FTP site without connecting through a proxy 
server, or to connect using proxy settings listed in CuteFTP. 

Note: 
With this option, CuteFTP attempts to detect Internet Explorer's proxy 
settings, including proxy.pac proxy script files. This is only available for 
Windows XP SP1, W2K Pro SP3, W2K Server SP3, W2K Server 2003 
using WinHTTP dll. If that fails, WinInet dll is queried, which is 
supported by XP, 2K PRO, NT4, ME, 98, and 95.  

• Use the highlighted proxy when connecting 

o Select this  to connect to an FTP site through a proxy server. 
o Clear this check box to connect to an FTP site without connecting through a proxy 

server, or to connect using settings from Internet Explorer. 
• Proxies  

o Select a host name in the list to make FTP connections through that specific server. 
o Select Add and enter the server name in the Host name box to include a server in 

the Proxies list.  
o Select Remove to delete the selected server from the Proxies list. 

• Host name 

o Select Add and enter the name of a new proxy server. 
OR 
o Select a server in the Proxies list and edit the name. 

• Port 

o Type the proper port for the server selected in the Proxies list.  The default port for 
proxy servers is 8000. 

• User name 
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o Enter or edit the user name for the selected proxy server. 
• Password 

o Enter or edit the password for the selected proxy server. 
• Proxy type 

o Select either FTP or HTTP to match the protocol the selected proxy server 
supports. 

• Advanced is for selection of advanced authentication methods. Choose: 
o USER user @site if your proxy server requires the USER command followed by 

your user name and the site name to allow connection with a remote site. You can 
change the @ symbol if a different separator is required by your proxy server. 

o SITE site if your proxy server requires the SITE command followed by the address 
of the remote FTP site to allow a connection.  

o USER with logon if your proxy server requires the USER command followed by a 
user name and password to allow connection with a remote site. 

o USER/PASS/ACCT if your proxy server requires all three commands before 
allowing a connection to a remote site. 

o OPEN site if your proxy server requires the OPEN command followed by the site 
name before allowing connection to the site. 

o Custom if your proxy server requires a login sequence different from those above. 

To create a custom authentication method for a proxy server 

1. Enter a command. 
2. Follow the command with a space and the appropriate variable. Choose from:. 

• %host% - sends the host name you typed in the Proxy server options 
window. 

• %user% - sends the user name you typed in the Proxy server options 
window. 

• %pass% - sends the password you typed in the Proxy server options window. 
• %port% - sends the port number you typed in the Proxy server options 

window. 
• %fire_pass% - sends the password you typed in the Proxy server options 

window as authentication for the firewall. 
• %fire_user% - sends the user name you typed in the Proxy server options 

window as authentication for the firewall. 
3. Enter each variable with percent signs before and after. 
4. Press Enter to separate commands.  
5. Enter any other commands and variables, separating commands with a line break. 
6. Select OK. 

115 



CuteFTP Professional User's Guide 

Note: 
Contact your system administrator for the proper Host name, Port, User 
name, Password, and proxy type, as well as any required advanced 
authentication methods.  

Security settings 

SECURITY SETTINGS 

To display the Security window 
1. From the menu, choose Tools > Global Options. 
2. Select Security. 

Configuration Notes 
• Remove Site Manager passwords upon program exit 

o Select this to prevent storing any site passwords in the Site Manager file at all. 
CuteFTP asks for the site password for each connection attempt. 

o Clear this check box to allow CuteFTP to store site passwords in the Site Manager 
file (default behavior). When passwords are saved, you won't have to enter them 
again when connecting to a site. 

Note: 
Not saving passwords at all is useful in shared system environments, 
where CuteFTP is likely being used by multiple users on the same 
physical machine. 

• Site Manager path: 

o Leave this to keep the Site Manager file in its default location. 
o Enter a new path or browse to a new path to move your Site Manager to a different 

location on your computer or network. 
• Encrypt contents of Site Manager 

o Select this to secure the Site Manager. You must supply a password every time you 
start CuteFTP. 

o Clear this check box, and CuteFTP starts without requiring a password. Site Manager 
and all its sites are available. 

Tip: 
When this option is not used (default) CuteFTP does use mild encryption 
with a system generated password to protect your Site Manager's 
contents. It is highly recommended that you select Encrypt the 
contents of the Site Manager, as it protects the contents of the Site 
Manager with strong encryption, using a password you supply.  

• Change Password 
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o This becomes available when you select Encrypt contents of Site Manager. Select 
it to open a dialog to set and confirm a password for protecting the contents of the 
Site Manager. 

• Remove Queue file passwords upon program exit 

o Select this to remove passwords from queued items. Next time you start CuteFTP, 
you will be prompted for a password to complete the transfer. 

o Clear this check box to allow passwords to be sent automatically for queued items. 
• Remove Quick Connect and Connect to URL history upon program exit 

o Select this to erase any URLS and remove all sites from the Quick Connect drop-
down, when CuteFTP is shut down. 

o Clear this check box to keep URLS and to keep a list of sites in the Quick Connect 
drop-down list even when CuteFTP is closed.  

SSH2 SECURITY SETTINGS 

To access the SSH2 security settings 
1. From the menu, choose Tools > Global Options. 
2. In the left pane, expand Security. 
3. Select SSH2 Security. 

Cipher  
• Select the check box for every cipher (encryption algorithm) you want available for 

SSH2 connections. See Learning about SSH2 for an explanation of the algorithms. 
• Clear the check box for any cipher you do not want available for SSH2 connections. 
• Move your preferred cipher to the top of the list by highlighting it and clicking the up 

arrow  outside the list. 
• Move your least preferred Cipher to the bottom of the list by highlighting it and 

clicking the down arrow  outside the list. 

MAC  
• Select the check box for every MAC (Message Authentication Code) you want available 

for SSH2 connections. See Learning about SSH2 for an explanation of MACs. 
• Clear the check box for any MAC you do not want available for SSH2 connections. 

Move your preferred MAC to the top of the list by highlighting it and clicking the up 

arrow 

• 

 outside the list. 
• Move your least referred MAC to the bottom of the list by highlighting it and clicking p

the down arrow  outside the list. 

U e
er will allow it. 

sfer compression. 

s  data compression 
• Select this check box to compress transfers if the serv
• Clear this check box to refuse tran
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U e
• 

•  
d the Use public key authentication check box. 

U e

x to only sign on to SSH2 servers with a password. 
• 

he location of the Public Key file on your local machine. 
o 

o the location of the Private Key file on your local machine. 
• 

 passphrase for decrypting the key listed in Private Key Path. 
o 

o  the same passphrase again for the key listed in Private Key Path. 

s  password authentication 
Select this check box to sign on to SSH2 servers with a password (the entered in your 
Site Manager). 
Clear this check box to only use public/private key authentication. You can only clear
this box if you have already selecte

s  public key authentication 
• Select this to sign on to SSH2 servers with a certificate (identity file). 
• Clear this check bo

Public Key Path 

o Browse or type t
Private Key Path 

 Browse or type 
Use Passphrase 
o Type the appropriate
Confirm Passphrase 

Type

Tip: 
The private key password is stored in the registry using strong 
encryption. For added security, leave the passphrase fields blank. 
CuteFTP prompts you for the private key password when necessary. 

• 

o te key pair. For instructions on key pair 
 SSH2 key pairs.  

• 

f public keys that you have accepted as valid in the 

o 

 
� t Remove to delete a highlighted public key from the trusted list.  

Create identity file 

Select this to create a new Public/Priva
creation see Creating

Trusted identity list 

Select this to see a list oo 
Certificate Manager. 
Certificate manager 

� Select Import to add a public key to the trusted list. 
� Select Export to send a highlighted public key to a location or program.
 Selec

Note: 
SSH2 connections require at least one authentication method but may 
require more than one. Check with your server administrator when in 
doubt. 
To use public key authentication, you must send your public key to the 
server administrator before making an SSH2 connection. 

SSL SECURITY SETTINGS 

To cac ess the SSL security settings 
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1. From the menu, choose Tools > Global Options. 
d Security. 

. 

C n

• 

• his check box to send no certificate to SSL servers for authentication. 

2. In the left pane, expan
3. Select SSL Security

o figuration Notes 

Use SSL certificate when authenticating  

• Select this to send a certificate to SSL servers for authentication. 
Clear t

Note: 
Your server may not require client certificates. If they do require client 
certificates, you may need to send your self-signed or 3rd-party signed 
certificate to the server administrator so the admin can add it to the 
server's Trusted List. 

• 

o  an SSL certificate file on your local machine. The 
 have a .crt extension. 

o 

o rivate key file on your local machine. 
uld have a .key extension. 

• 

e passphrase for the certificate listed in the Certificate field. 
o 

o ter the appropriate passphrase again for the certificate listed. 

Certificate 

Browse to or type the location of
file should

Private key 

Browse to or type the location of an SSL p
The key file sho

Use passphrase  
o Enter the appropriat
Confirm Passphrase 

 En

Tip: 
The private key password is stored in the registry using strong 
encryption. For added security, leave the passphrase fields blank. 
CuteFTP prompts you for the private key password when necessary. 

• 

o  
formation on creating SSL certificates see Creating your 

. 
o 

o ion 
rtificates see Accepting server SSL certificates and Importing SSL 

o 

o nsfer. 
• 

o y accepted by your system, even 
if they have not been added to your Trusted list. 

Create Certificate 

Select this to create a new SSL certificate with a signing request and a key for the
certificate. For more in
own SSL certificates

Trusted Certificates 

Displays a list of certificates that you have accepted as valid. For more informat
on trusted ce
certificates. 

Reuse cached session for data connection (required by some servers) 

o Select this to allow new transfers without encrypting a new data channel.  
 Clear this check box to require encryption of every session for every new tra
Accept certificates in Windows Trusted Root Certificate Authority store 

Select this to automatically trust certificates alread
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o Clear this check box to require all certificates to be added to the CuteFTP Trusted 
list before allowing connections. 

• Warn when switching from secure to non-secure pages (CuteFTP Professional 
Only) 

o Select this to see a pop-up message when, after connecting to a secure HTTP site, 
you click a folder or link that is not secure. 

o Clear this check box to be able to link from secure HTTP sites to HTTP sites that 
are not secure without seeing any pop-up messages. 

Transfer settings 

TRANSFER SETTINGS 

To access transfer settings 
1. From the menu, choose Tools > Global Options. 
2. Select Transfer. 

Transfer method 
• Choose Auto-detect to have CuteFTP decide the transfer method based on the file 

and server type. 
• Choose ASCII to transfer text files, web pages or other text type files. 
• Choose Binary to transfer pictures, programs or executable files. 

Note: 
Binary files cannot be transferred in ASCII mode, but ASCII files can be 
transferred in Binary mode. 

Data mode: 
• Choose Auto and CuteFTP  makes connections in PASV mode. If the PASV 

connection fails, CuteFTP attempts to connect in PORT mode automatically.  
• PASV helps avoid conflicts with security systems.  PASV support is necessary for 

some firewalls and routers, because with PASV, the client opens the connection to 
an IP Address and port that the server supplies. 

• Choose PORT when connections or transfer attempts fail in PASV mode, or when 
you receive data socket errors. When an FTP client connects using PORT, the server 
opens a connection to an IP Address and port that the client supplies. 

• EPRT is an extesnion of PORT that allows the server to give an Ipv6 address to the 
client for negotiation through NAT firewalls. 

• EPSV is an extesnion of PASV that allows the server to give an Ipv6 address to the 
client for negotiation through NAT firewalls. 

• Used as an alternative to PASV or PORT commands for the traversal of NAT 
firewalls for secure (FTPS) connections. Read RFC 2428 for more details. Common 
 Add EPRT and EPSV to the existing Data mode drop-down (combo) located under 
Global Options | Transfer pane. Note that each site in the site manager is currently 
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able to either inherit global settings for Data Mode or define their own. Therefore 
the EPRT and EPSV choices must also be available on a site basis (Site Properties | 
Type page). 

Note: 
If you connect in PORT mode your session becomes vulnerable to "Port 
theft," where a third party can interfere with transfers. 

Mode Z: 
Mode Z compression compresses files on the fly as you transfer, saving bandwidth and 
improving transfer times. This feature is turned on by default, and is used whenever you 
connect to a server that supports Mode Z. 

• Select Apply Mode Z compression to ASCII transfers when possible to use 
Mode Z. 

Transfer files over the browse session 
This feature controls the sessions that files are transferred on. 

If Allow transfers to occur over the existing (browse) session is: 
• Checked, files transfer over new and existing sessions. CuteFTP uses the 

browse session and if available, additional connections. For example, If you 
define a per site max limit of five connections and then transfer five files, 
CuteFTP checks the browse connection first to see if it is busy, and if not busy, 
transfers the 1st file over the browse connection. The subsequent four files are 
transferred over four additional sessions. CuteFTP automatically adjusts for 
allowed connections (both from the client and server perspective) and whether 
or not it can use the browse session.  

• Checked + CTRL key, files transfer over the exisiting session only. To use 
this, select the files you want to transfer, then press and hold the Ctrl key while 
you drag and drop the files into the destination folder. This forces CuteFTP to 
transfer all the files on the existing session. Transferring files using only the 
currently logged in session can reduce overhead in certain situations. For 
example, a transfer of a large number of small HTML files can often be done 
much faster if limited to the current connection rather than performing a full 
TCP/IP connection and FTP login (and possibly FEAT/CWD/LIST) 
sequence first 

• Cleared (unchecked), files transfer over new sessions only. Use this option if 
your server allows multiple connections, is quick to respond, and you want to 
navigate the site while downloading. All transfers are forced over new 
connections, freeing up the browse session so you can continue to navigate. 
The only time may pose a problem is when the server either refuses to allow 
multiple connections or is slow to log into. 

When selecting MAX in a multi-part transfer, use n threads 
• Select the number of parts to split a file into when a max multi-part transfer is 

requested. 

Global bandwidth limit 

121 



CuteFTP Professional User's Guide 

Throttles the bandwidth of all sessions on CuteFTP. To set a bandwidth throttle, adjust 
Global bandwidth limit: to the number of kilobytes per second you want to limit CuteFTP 
to.  If set to 0 (the default), there is no throttling. 

Reconnect and resume in n seconds, if nothing is received 
• Select the time that CuteFTP waits to try again after an interrupted or failed 

download. Select a time between 0 and 1,000 seconds (about 17 minutes).  

Roll back (retry at byte offset) n bytes when resuming transfers 
• Select the number of bytes prior to the transfer failure CuteFTP resends when 

attempting to finish an interrupted transfer. Select between 0 and 65536 bytes. 

Send REST command prior to APPE when resuming a transfer 
• Select this check box to send the REST (Restart) command to resume a transfer, 

before sending the APPE (Append) command. 
• Clear this check box to send the APPE (Append) command to resume a transfer 

without first sending the REST (Restart) command. 

Receive and send buffers 
Default setting for both send and receive is 65536 bytes. It is unlikely you will ever need to 
adjust these settings, but if you have problems with dropped transfers, you can use them to 
fine tune transfers over high latency or lossy connections like those over satellite links or 
with legacy CDMA wireless connections. For more, see Tweak the send and receive buffers 
in Improving Slow Transfers. 

Tip: 
Most of these controls are intended for advanced users only. For 
example, the REST/APPE sequence is only intended for problem 
servers that don't support the proper resume sequence. Transfer type 
should only be changed when you need to force files to transfer a certain 
way. The data port mode should only be changed if you are having 
problems establishing a data connection (on LIST or RETR for 
example). Limiting the local port range can have adverse affects when 
transferring many small files over a narrow range of ports. 

 

EVENT SETTINGS 

After all transfers have finished 
• Choose Do Nothing to keep the connection and CuteFTP open after all transfers 

are complete. 
• Choose Disconnect from site to close the connection but keep CuteFTP open after 

all transfers are complete. 
• Choose Disconnect and close program to close all connections an close CuteFTP 

after all transfers are complete.  
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• Choose Disconnect from Internet to close a dial-up connection automatically after 
all transfers are complete. 

• Choose Shut Down Computer to close all connections, close CuteFTP, close a dial-
up connection and shut down the computer after all transfers are complete. 

• Choose Log Off to automatically log the current user off the computer after all 
transfers are complete. 

Verify file integrity when transferring from/to GlobalSCAPE secure FTP 
Server 

• Select this to have CuteFTP Professional and the server double check binary files to 
be certain the files downloaded completely and correctly. 

• Clear this check box to stop binary file checking. 

Remove successful transfer items from the queue automatically 
• Select this to erase items from the queue after they have transferred. 
• Clear this check box to keep items in the queue even after they have transferred. 

Tip: 
As old items build up in the queue it can consume large amounts of 
memory. Selecting this option avoids that problem. 

Close the file transfer thread n seconds after the transfer is finished 
• Select the time that CuteFTP will wait to close the data connection after a transfer is 

complete. Leaving data connections open allows more transfers to use the same 
connection, avoiding the need to open new connections. Select a time between 0 and 
1,000 seconds.  

Preserve remote time stamp for downloaded files 
• Select this to keep a downloaded file's time stamp the same on the local machine as it 

is on the server. 
• Clear this check box to allow the local machine to give downloaded files a new time 

stamp. 

Preserve the local time stamp for uploaded files if the server allows 
MDTM 

• Select this to keep an uploaded file's time stamp the same on the server as it is on the 
local machine. 

• Clear this check box to allow the server to give uploaded files a new time stamp. 
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Note: 
Using MDTM to modify a remote file's time stamp is not endorsed by 
the IETF Extensions to FTP working group or any formal RFC. 
However it is supported by quite a few FTP servers. CuteFTP will 
attempt the command when requested and report any errors to the log (if 
received). 

RENAME RULES SETTINGS 

You can set CuteFTP to automatically change the name of files it transfers. 

To access the Rename Rules options 
1. From the menu, choose Tools > Global Options. 
2. Expand Transfer. 
3. Select Rename Rules. 

Apply auto-rename rules to transfers 
• Select this check box and CuteFTP will change the names of transferred files with 

names that are listed in the large box of the Rename Rules window. 
• Clear this check box and CuteFTP will not rename any files. 

To create an auto-rename rule 
1. Type the original file name in the text box on the upper left. 
2. Type the desired new file name in the text box on the upper right. 
3. Click Add. 

To remove an auto-rename rule 
1. In the large list box, highlight the rule you want to delete. 
2. Click Remove. 

Configuration notes 
• The rules are case sensitive. 
• These rules will apply to all uploads, downloads, and site-to-site transfers.  
• You can create rules with wildcard masks to change just the extension of several files 

of the same type.  For example, if your .jpg files need the extension in upper case 
(.JPG) on the server, create the rule:  

 
Rename 
from 

Rename 
to 

*.jpg *.JPG 
 

• You can create a rule to strip extensions from file names.  For instance if you want 
to transfer a file called "index.htm" as simply "index" add this rule to your list:  
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Rename 
from 

Rename 
to 

index.htm index.* 

ASCII TRANSFER SETTINGS 

Select, by file extension, file types that should always be transferred in ASCII mode. 

To access the ASCII transfer options 
1. From the menu, choose Tools > Global Options. 
2. Expand Transfer. 
3. Select ASCII Types. 

ASCII Extensions 
• Type the file extension for files you want to transfer in ASCII mode in this box. 
• Select Add to add the extension to the list. 
• Select Remove to delete the selected extension from the list. 

 

Note: 
You can specify a Transfer type from the main menu (see Transferring 
files in binary or ASCII mode). You can also specify a Transfer type for 
an individual site by highlighting the site in the Site Manager, clicking 
the Type tab, and choosing from the Transfer list. Auto is the default 
transfer type, and sends files in the mode specified for each file's 
extension.  All extensions are sent in binary mode unless they are listed in 
the ASCII Extensions list. 

Navigation settings 

SMART OVERWRITE SETTINGS 

When you try to transfer a file to a destination with a file of the same name, use Smart 
Overwrite to determine the proper action to take. Smart overwrite settings apply to both 
uploads and downloads.  Some servers are case sensitive. Such servers will not recognize 
files names as identical if the letter case of the two file names does not match. 

To access the Smart Overwrite settings 
1. From the menu, choose Tools > Global Options. 
2. In the left pane, expand Transfer. 
3. Select Smart Overwrite. 

For matching files 
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• Prompt: CuteFTP displays a window asking you to overwrite or skip the file in the 
destination folder that has the same name as the file you are transferring. 

• Overwrite: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP replaces the destination file with the transferred file. 

• Skip: If a file in the destination folder has the same name as the file you are transferring 
CuteFTP does not transfer the file and leave the destination file as it is. 

• Rename: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP asks you for a new file name for the transferred file. 

• Resume: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP treats the destination file as an incomplete transfer. If the 
destination file is already a complete file, the transferred file replaces the destination file. 

• Numerate: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP renames the transferred file to 'Copy of file.txt'. If the same 
transfer occurs again CuteFTP renames the transferred file to 'Copy (2) of file.txt' 

• Use Rules: If a file in the destination folder has the same name as the file you are 
transferring, CuteFTP uses the rules you define in Overwrite Rules. 

Ignore Zero byte files 

• Select this and CuteFTP ignores any files with a size of zero bytes. 
• Clear this check box and CuteFTP applies all rules and settings to all files regardless of 

size. 

For matching folders 
• Prompt: CuteFTP displays a window asking what you want to do to a folder in the 

destination folder that has the same name as the folder you are transferring. 
• Replace All: If a folder in the destination folder has the same name as the folder you 

are transferring CuteFTP replaces every destination file with matching names with files 
in the transferred folder. 

• Use Rules: If a folder in the destination folder has the same name as the folder you are 
transferring, CuteFTP uses the rules you define in the Overwrite Rules window to 
determine how to handle all files with matching names. 

Configure Rules 
Configure Rules defines the rules you want CuteFTP to use when two files have the same 
name.  You must select Use rules to enable these options. 

• If destination file date is 

o newer replaces a file if it has a time stamp more recent than the file you are 
transferring. 

o no matter replaces any file regardless of when it was created in relation to 
the file you are transferring. Select this option if you don't want to replace 
files based on when they were created. 

o older replaces a file only if it has a time stamp further in the past than the file 
you are transferring. 

o the same replaces a file if it has the same time stamp as the file you are 
transferring. 
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o different replace a file if it has a time stamp that is older or newer than the 
file you are transferring. 

• and size is 

o larger replaces a file if it is larger than the file you are transferring. 
o no matter replaces a file regardless of its size. Select this option if you don't 

want to replace files based on their size in relation to the file you are 
transferring. 

o smaller replaces a file if it is smaller than the file you are transferring. 
o the same replaces a file if it is same size as the file you are transferring. 
o different replaces a file if it is larger or smaller than the file you are 

transferring. 
• during 

o any transfer replaces files whether you are uploading or downloading. 
o download replace only the files on the local machine with files transferred 

from a remote site.  
o site to site transfer replaces files when with the same name when 

transferring from one remote site to another. 
o upload replace only the files on the remote site with files transferred from 

the local machine. 
• then 

o overwrite completes the transfer by replacing the file that's already in the 
destination folder.  

o numerate completes the transfer by renaming the transferred file with 
"Copy (n) of..." added before the name. 

o resume treats the transfer as an attempt to continue an interrupted transfer. 
o show prompt pauses the transfer and display the message that asks the user 

which action to take. 
o skip cancels the transfer and leave the original file in the destination folder. 

• Select Add >>\ places the rule into the list. If you are using rules, CuteFTP checks 
every rule in the list during all transfers. 

• Select << Remove to delete a rule you have highlighted in the list and CuteFTP will 
no longer use the rule when it encounters two files of the same name. 

• Select Defaults to delete every rule from the list. 
For more information, see Smart Overwrite Example. 

Prompt timeout action  
Defines the action CuteFTP takes if no rules apply, or if you enable a timeout value. When 
you select the Timeout in n seconds check box, a prompt appears, but after waiting the 
defined amount of time, CuteFTP takes one of the following actions: 

• Overwrite: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP replaces the destination file with the transferred file. 
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• Skip: If a file in the destination folder has the same name as the file you are transferring 
CuteFTP does not transfer the file and leave the destination file as it is. 

• Rename: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP asks you for a new file name for the transferred file. 

• Resume: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP treats the destination file as an incomplete transfer. If the 
destination file is already a complete file, the transferred file replaces the destination file. 

• Numerate: If a file in the destination folder has the same name as the file you are 
transferring CuteFTP renames the transferred file to 'Copy of file.txt'. If the same 
transfer occurs again CuteFTP renames the transferred file to 'Copy (2) of file.txt'. 

Resend LIST command as necessary 
• The LIST command retrieves file details and determine similarities and differences 

between a transferring file and destination file with the same name.  
• Clear this check box and CuteFTP does NOT use the LIST command. 

Use SIZE and MDTM to gather precise details 
• The SIZE command retrieves file size and the MDTM command retrieves file 

modification time to determine similarities and differences between a transferring file 
and destination file with the same name.  

• Clear this check box and CuteFTP will NOT use the SIZE  and MDTM command. 

Compare using XCRC and overwrite, skip, or resume accordingly 
• Use file integrity checking (cyclical redundancy checksums) to determine overwrite, skip 

or resume status based on similarities and differences between a source and destination 
file with the same name. 

Note: 
This feature only works with GlobalSCAPE Secure FTP Servers. 

Note: 
The resulting action of Compare using XCRC... takes precedence over 
your standard overwrite action settings.  

NAVIGATION SETTINGS 

To access the navigation settings 
1. From the menu, choose Tools > Global Options. 
2. Select Navigation. 

Event Handling 
• When adding items to the queue, choose: 

o Transfer immediately to start transfer of the queued item as soon as it is dropped 
in the queue. 

o Suspend to place the item in the queue, but to hold the transfer. 
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o Schedule to display the scheduling window when an item is placed in the queue. 
• When dragging an item to the local pane, choose: 

o Transfer to current folder to send the dragged item to the folder currently listed in 
the Local Drives pane. 

o Transfer to default folder to send the dragged item to the default transfer folder 
listed in General Settings. 

o Add to queue & suspend to place the dragged item in the queue, but hold the 
transfer. 

• When double-clicking an item, choose: 
o Transfer immediately to send the item to the displayed remote site or the default 

download folder.  
o Add to queue & suspend to place the double-clicked item in the queue, but hold 

the transfer. 
o Launch in viewer to open the item in the File Viewer program chosen in Helper 

Applications. 
o Execute to run the item if it is a program. 
o Edit to open the item in the File Editor program chosen in Helper Applications. 

More options 
• Link the remote and its associated local pane when working with multiple sites 

o Ties the local and remote panes to each other. If you have more than one remote 
pane open and you switch between the remote panes, the last path in the local pane 
used for that remote pane is recalled.  

o Clear this checkbox to retain the same path in the local pane regardless of the remote 
pane selected. 

• Auto-refresh the remote pane after an upload 

o Update the remote folder's listing after every upload to that folder. 
o Clear this check box to stop sending LIST requests to a remote site after every 

upload. 
• Switch from the Site Manager to the Local Drives Pane upon connection 

o Automatically displays the Local Drives pane when a connection is made. 
o Clear this check box to leave the Site Manager displayed when a connection is 

made. 
• Switch from the Local Pane to the Site Manager upon closing all connections 

o Automatically displays the Site Manager when all connections are closed. 
o Clear this check box to leave the Site Manager hidden when all connections are 

closed. 
• Use the logical parent (not physical parent) on CDUP command 

o Returns to the folder you just linked from when clicking the Move up directory 
button. 

o Clear this check box to change to the actual folder the item resides in, and not a 
folder with a link to the item, when clicking the Move up directory button. 
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TOC FILE SETTINGS 

You may connect with remote folders that have Table of Contents (TOC) files. TOC files 
contain detailed information about the folder.  In long and complicated directories the TOC 
files can be quite large. If you download very large TOC files, they may interfere with 
CuteFTP's performance or operation. 

To access the TOC File settings 
1. From the menu, choose Tools > Global Options. The Global Options dialog 

appears. 
2. In the left pane, expand Navigation. 
3. Select TOC Files. 

Settings 
• Load TOC Files 

o Automatically downloads Table of Contents files whenever connecting to a remote 
folder. 

o Clear this check box to never download Table of Contents files. 
• If the TOC file size exceeds n Kbytes, then prompt before loading.   

o Choose the maximum size TOC file CuteFTP downloads without prompting for 
permission. Choose a size between 1 and 1,000 kilobytes. 

• TOC include masks 

o Enter file names or extensions that CuteFTP should consider as TOC files.  You can 
use wildcard masks. 

o Add includes your entry in the list of TOC include masks. 
o Remove deletes the selected item from the TOC include masks list. 

• TOC exclude masks 

o Enter file names or extensions that CuteFTP should NOT consider as TOC files. 
 You can use wildcard masks. 

o Add includes your entry in the list of TOC exclude masks. 
o Remove deletes the selected item from the TOC exclude masks list. 

Note: 
The TOC include masks and the TOC exclude masks act as a double 
filter to help CuteFTP determine whether or not a file is a TOC file. For 
example, if you put "Index*" in the TOC include masks and *.html in 
the TOC exclude masks, a file named "Index.txt" would be considered 
a TOC file, but a file named "Index.html" would not. 

SYMBOLIC LINK OPTIONS 

You can determine how CuteFTP handles Symbolic Links. Symbolic Links are similar to 
shortcuts, they point to items in other locations on a server. 

To access the Link options 
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1. From the menu, choose Tools > Global Options. 
2. Expand Navigation. 
3. Select Links. 

 

Server side link resolution 
• Attempt link resolution using LIST-L command 

o Sends the LIST-L command instead of LIST to display folder contents. LIST-L 
attempts to list the actual file or folder rather than the link that points to the file or 
folder. 

o Clear this check box to send just the LIST command to display folder contents and 
leave links in the list. 

Note:  
Servers are not always able to resolve links using LIST-L. 

• Client side link resolution 

o Try to determine the link's target type by its extension - CuteFTP tries to tell if 
the link points to a file or a folder. CuteFTP treats the link as if it were the item it 
references. 

o Always assume the link is a file (don't attempt to resolve) - treats symbolic links 
as files. If you download the link it displays as a file with size 0 in your local folder.   

Tip:  
This option is useful when you download large directories or folders with 
many files and subfolders.  

o Always assume the link is a folder (don't attempt to resolve) - treats symbolic 
links as folders that you can double-click to see folder contents. 

Note: 
CuteFTP attempts to show the actual path of a file or folder link in the 
Remote pane, under the Name column.  For example, a link to a file 
called archive.zip might show .3/networks/bbs_info/archive.zip 

TOLERANCE OPTIONS 

You may encounter some servers that treat PASV mode and links differently.  You can 
choose from the following options to help when connecting with these servers. 

To access the Tolerance options 
1. From the menu, choose Tools > Global Options. The Global Options window 

appears. 
2. In the left pane, expand Navigation. 
3. Select Tolerance. 

Configuration notes  
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• Use correct timing of PASV mode command  

o This option works with most FTP servers.  See RFC compliant PASV mode 
example. 

o Clear this check box to connect with a server when having difficulty connecting in 
PASV mode.  

• Use PWD to determine current folder 

o Uses the 'Print Working Directory' command to determine what remote folder is 
currently open on the server. 

o Clear this check box and CuteFTP attempts to determine the current remote folder 
based upon the relative location from the root login folder. Uncheck this box only if 
your server does not support PWD. 

• Use absolute paths for DELE, RETR, and STOR commands 

o Sends the absolute path to the file to complete delete, download, or upload  file 
operations. For example: "RETR /pub/cuteftp/cuteftp.exe". 

o Clear this check box if your server doesn't support absolute path names for these 
commands. CuteFTP sends the relative path to the file instead. For example: "RETR 
cuteftp.exe". 

• Use absolute paths for the LIST command 

o Uses the complete absolute path to retrieve the listings for a folder. For example: 
"LIST /pub/cuteftp". 

o Clear this check box if your server doesn't support absolute path names for the LIST 
command. CuteFTP uses the relative file path to retrieve the listings for a folder. For 
example: "LIST". 

• Use NLST instead of LIST (retrieves an abbreviated listing) 

o Retrieves a list of just file names for each folder. The list does not include time 
stamps, file size, or other details. 

o Clear this check box to use the LIST command and retrieve a list with details for 
each file and folder. 

• Treat 5xx errors as 4xx errors during login 

o Continues login attempts if the server returns permanent errors (5xx) 
inappropriately, such as when the server is full or busy. 

Warning:  
Selecting this option may result in being banned from a server. CuteFTP 
will repeatedly try to connect to the server (according to retry and retry 
delay settings). If the retry delay period is set too low, these repeated 
attempts may end up being considered "hammering," and the server 
administrator or service may ban your accounts. 

o Clear this check box to always accept permanent errors, to stop further connection 
attempts, and to avoid being banned for hammering. 
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Display settings 

DISPLAY SETTINGS 

To access CuteFTP display settings 
1. From the menu, choose Tools > Global Options. 
2. Select Display. 

Configuration Notes 
Select the toolbars to display 

• Select the toolbars you want to display by clicking the checkbox next to the toolbars. 
• Click the name of the toolbar to select it. 
• With a toolbar in the list highlighted, click the Customize selected toolbar button 

to add or remove buttons on the toolbar. 

Customize selected toolbar - add a button 

1. Select a button from the Available Toolbar buttons column. 
2. Click Add, or double-click the button. 
3. Click Close to accept changes, Reset to cancel changes. 

Customize selected toolbar - remove a button 

1. Select a button from the Current Toolbar buttons column. 
2. Click Remove, or double-click the button. 
3. Click Close to accept changes, Reset to cancel changes. 

Customize - move a button 

1. Select a button from the Current Toolbar buttons column. 
2. Click Move Up to move a button one icon to the left on the toolbar.  
• Click Move Down to move the button one icon to the right on the toolbar. 
3. Click Close to accept changes, Reset to cancel changes. 

Note: 
Reset does not cancel changes made when the Customize Toolbar 
dialog box was opened and closed previously. 

Show large toolbar icons 

• Select this to display the large (32x32 pixel) set of main toolbar icons. 
• Clear this to display the small (16x16 pixel) set of main toolbar icons. 

Auto-hide Quick Connect bar 

• Select this to cause the Quick Connect bar to hide upon connection to a site. 
• Clear this to cause the Quick Connect bar to stay in view upon connection to 

a site.. 

Display menu icons 
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• Select this to display small icons in the menus next to commonly used menu 
items. 

Highlight active pane 

• Select this to display a thin blue line at the top of the window pane that 
currently has the focus. 

Show grid lines on all view panes 

• Select this check box to display borders between rows and columns in the 
queue window, and in the Local and Remote panes when in Detail view. 

• Clear this check box to hide all borders between rows and columns. 

Display File Sizes in 

• Adaptive causes CuteFTP to decide when to show files in Bytes, KB, MB, or 
GB. 

• Kilobytes causes CuteFTP to always display values in KB. 

Local, Remote, Queue Pane Font 

Allows you to adjust the font type and size display of all text in the Local Drives 
tab, Queue pane, and Remote pane. 

Smart Sorting 

• Use standard lexicographic sorting for alphanumeric file names 
Select this option to sort file lists by the value of each individual digit. 
o Use Smart Sorting for alphanumeric file names 

Select this option to sort file lists by whole number value. 

Tip: 
Smart Sorting always lists file names with smaller numbers first.  For 
example, A2 comes before A12.  David Wincelberg developed Smart 
Sorting. CuteFTP uses it by default. 
Standard Lexicographic sorting lists file names using one character at a 
time reading from left to right.  For example, A12 comes before A2. MS 
Windows uses Standard Lexicographic sorting by default. 

 
Smart Sorting Standard sorting 

FileA1.ext FileA1.ext 
FileA2.ext FileA12.ext 
FileA6.ext FileA2.ext 
FileA9.ext FileA20.ext 
FileA12.ext FileA21.ext 
FileA20.ext FileA6.ext 
FileA21.ext FileA9.ext 
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SOUND OPTIONS 

To access CuteFTP sound options 
1. From the menu, choose Tools > Global Options. 
2. In the left pane, expand Display. 
3. Select Sounds. 

Configuration Notes 
• Add sounds 

o Select this to hear audio cues for certain events in CuteFTP and to edit the sounds 
associated with events. 

o Clear this check box to silence all sounds from CuteFTP and disable sound 
association editing. 

• Events 

The Event column lists possible CuteFTP events. The File column lists the sound file 
that plays for each event.  If there is nothing in the File column, the event to the left 
does not cause a sound. Select an event in the list to add or change the sound 
associated with it. 

• File  

o Browse or type the path to a sound that you want.  To remove a sound from an 
event, select it, then choose (None). 

Tip: 
With a sound listed in the File entry box you can preview the sound by 
clicking the speaker button. 

PROMPT SETTINGS 

To access CuteFTP prompt settings 
1. From the menu, choose Tools > Global Options. 
2. Expand Display. 
3. Select Prompts. 

Confirmations 
• Confirm when deleting from local drive 

o A confirmation prompt appears before each delete and asks if you are sure you want 
to delete the item before removing it. 

o Clear this check box and when you try to delete an item from the Local Drives pane, 
it will be remove without a confirmation prompt. 

o Confirm when deleting from remote drive 

o Select this check box and when you try to delete an item from a remote folder, 
CuteFTP asks if you are sure you want to delete the item before removing it. 
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o Clear this check box and when you try to delete an item from a remote folder, it will 
be removed immediately. 

o Confirm when deleting from queue 

o Select this check box and when you try to delete an item from the queue, CuteFTP 
will ask if you are sure you want to delete the item before removing it. 

o Clear this check box and when you try to delete an item from the queue, it will be 
removed immediately. 

o Confirm when closing a remote pane 

o Select this check box and when you try to close a window for an active connection, 
CuteFTP will ask if you want to disconnect first. 

o Clear this check box and when you try to close a window for an active connection, 
the window and connection will be closed immediately. 

Prompts 
• Show prompt upon error Select this to display a dialog upon certain server errors 

(5xx range). 
• Show login prompt if connection fails or is missing data Select this to display a 

dialog when the site password is rejected or missing. 
• Show prompt when new tasks are scheduled Select this to display a dialog 

notifying you that a task was scheduled and added to the queue. 
• Show prompt when new tasks are started Select this to display a dialog notifying 

you that a scheduled task has started to run. 
• Show prompt after successful decompression Select this to display a dialog 

notifying you that the archive was expanded successfully. 
• Show warning when transferring binary files in ASCII mode Select this to 

display a dialog warning you when you may be transferring a certain file type in the 
wrong mode. 

• Show connection progress prompts Select this to display a connection status 
dialog when connecting. If the log view is unavailable when connecting, this dialog 
will show you if there may be a problem with the connection. This is disabled by 
default. 

LANGUAGE SETTINGS 

CuteFTP's resources are independent from the main application executable and are 
contained in a file called Default.lng. You can modify the text and dialogs displayed in the 
program or localize the entire resources in order to use CuteFTP in your own language. 

To modify the resource file using Microsoft Visual Studio 
1. Locate the default.lng file in the CuteFTP installation folder. 
2. Make a copy of this file in the same folder and rename it with a dll extension. For 

example: custom.dll 
3. Launch Visual Studio. 
4. Choose File > Open from the menu. 
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5. In the Look in field of the Open dialog, locate your CuteFTP installation folder. 
6. In the Files of type field, select Executable Files (.exe; .dll; .ocx). 
7. In the Open as field, select Resources. 
8. Select the resource dll file you just created and select Open. 
9. In Visual Studio's main editor window, select one of the resource folders shown, 

such as String Table. 
10. Modify the resource strings. Take special care to not modify dynamic string place 

holders (i.e. %d or %s)  or escape sequences (\n). The & sign represents a 
mnemonic and must remain intact. 

11. Once you've completed your modifications, save your changes by choosing File > 
Save from the main menu. 

12. Close Visual Studio. 
13. Locate the resource dll you just modified. 
14. Change its extension back to lng. For example: custom.lng 
15. Launch CuteFTP. 
16. Choose Tools > Global Options > Display > Language from the menu. 
17. Select the new language file from the left-hand pane of the Language settings dialog. 
18. Select OK, close the Global Options dialog and restart CuteFTP. 

The resource changes take place throughout the program. You can also modify the resource 
file using other third party tools, such as the free utility called Resource Hacker (search for 
it using Google) used for modifying resource files.  

To modify the resource file using Resource Hacker 
Follow the same steps as above with the following exceptions: 

1. When opening the dll file in Resource Hacker, select Win32 PE files as the Files of 
type. 

2. As you edit the resources of each node in the resource tree, make sure to select 
COMPILE SCRIPT after making changes to that node. 

Tip: 
Make sure you save your changes from the File > Save menu once 
finished. Resource Hacker automatically makes a backup of the original 
dll file. All other steps are the same, including the naming of the file back 
to something.lng and the steps on how to load it in CuteFTP. 

Note: 
CuteFTP's License Agreement contains specific language prohibiting 
reverse engineering, decompiling or otherwise modifying the application 
or any one of its components. You are permitted to modify the resource 
file for your own personal use on your own system only. You are not 
allowed to distribute your modified resource file to others. We are 
considering a program in the near future that will permit users to localize 
their resources and submit them to GlobalSCAPE for redistribution to 
others. If you are interested in taking part in any localization efforts and 
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feel that you are able to provide timely, high-quality translations of the 
CuteFTP resources file, please contact the CuteFTP Product Manager. 

Helper Applications 

HELPER APPLICATIONS 

You can choose the programs to use for viewing and editing documents from within 
CuteFTP.   

To access Helper Applications 
1. From the menu, choose Tools > Global Options. 
2. Select Helper Applications. 

File Viewer 
• Use the integrated HTML editor to view files 

o Select this check box to open files in CuteFTP's built-in HTML editor when clicking 
a file and going to File > View. 

o Clear this check box to open files in a program you choose in the long box below the 
check box. 

o File viewer 
o Browse or type the path to the program you want to use when clicking a file and 

going to File > View. 

File Editor 
• Use the integrated HTML editor to edit files (recommended) 

o Select this check box to open files in CuteFTP's built-in HTML editor when clicking 
a file and going to File > Edit. 

o Clear this check box to edit files in a program you choose in the long box below the 
check box. 

o File editor 
o Browse or type the path to the program you want to use when clicking a file and 

going to File > Edit. 

Note: 
If you choose a third party editor with which to edit remote files, 
CuteFTP launches the editor and then monitor the folder containing the 
temporary file being modified. Once you've made your changes in the 
editor and saved them, CuteFTP will upload the changes back to the 
server.  

Tip: 
If you prefer to use a direct editor over a WYSIWYG editor but find the 
integrated editor too limited in functionality, consider trying out our 
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CuteHTML Pro tool. It is powerful editor for working with HTML, ASP, 
PHP, Perl, and many more file types. 

Note: 
If you open an HTML file in the built-in HTML editor using File > 
View you can still edit and save the file. 

HTML EDITOR SETTINGS 

To view or edit HTML Editor settings 
1. From the menu, select Tools > Global Options. 
2. Expand Helper Applications and select HTML Editor. 

Display editor using Full Screen view 
• The editor can display in full screen or as a tab in the CuteFTP window. By default, 

CuteFTP displays the the HTML editor in tab view mode. To change to full screen 
view, select Display editor using Full-Screen view. 

Enable word wrap 
• Select this check box and the HTML editor will add line breaks at the right end of 

long lines, so that you can see entire lines of Code without scrolling to the left or 
right. 

• Clear this check box and the HTML editor will use line breaks where you add them. 
 You might have to scroll to the right to see the ends of longer lines of code. 

Prefix each line with line numbers 
• Select this check box to display numbers at the beginning of each line of code. If 

word wrap is enabled, the numbers will only display after line breaks you have 
entered.  The line numbers are not saved as part of the document. 

• Clear this check box and no line numbers will be displayed. 

Allow editing beyond the end of line 
This check box is only available if Enable word wrap is cleared. 

• Select this check box to allow the cursor to keep moving to the right after the last 
character in a line. 

• Clear this check box to force the cursor to return to the left end of the following line 
after the last character in a line. 

Note: 
If you disable Allow editing beyond the end of line, you can still add 
more characters after the right-most character. 

Tab size 
Enter the number of spaces you want the cursor to move to the right when you hit the Tab 
key.  You can choose from 1 to 32. 

Edit new document template 

139 



CuteFTP Professional User's Guide 

Select Edit new document template to open a window where you can change the HTML 
code and text that is generated automatically when you start a new document in the HTML 
editor. When you have finished making changes, click the CLOSE button. 

Choose font for editor 
Select Choose font for editor to open a dialog where you can choose the type, style and size 
of the font displayed in the HTML Editor.  When you have made your selections click OK, 
or if you don't want to change the font click Cancel. 

CHOOSING DISPLAY COLORS FOR THE HTML EDITOR 

To specify display colors for HTML tags and Perl scripts 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Colors. 
4. Select a color from the list for each tag set and for Perl script components. 
5. Select Apply or OK. 

To specify background and standard font colors for the HTML editor 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Colors. 
4. To use the system default colors, select the Use system settings check box and skip 

to step 7. 
OR 

• To choose different colors, clear the Use system settings check box and continue 
with step 5. 

5. Select a color for the background from the Background list. 
6. Select a color for the font from the System font list. 
7. Select Apply or OK. 

CHOOSING THE FOLDER FOR HTML CODE SNIPPETS AND JAVA SCRIPTS 

To specify the folder for code snippets and previewing HTML 
documents from CuteFTP 

1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Folders. 
4. In the Code snippets box, browse or type the path to the folder where you want to 

store code snippets. 
5. In the Java scripts box, browse or type the path to the folder where you want to 

store Java scripts. 
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6. Select OK. 

CHOOSING TO WRITE HTML FOR A SPECIFIC BROWSER 

The HTML Editor can automatically provide suggestions for HTML tags that work for 
specific browsers. The HTML Editor offers HTML tag choices in drop down boxes.  These 
are called tag tips.   

To show tag tips 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. Select the Show tag tips check box. 
Or 
• Clear the Show tag tips check box to keep tag tips hidden. 

5. Select OK or Apply. 
The tags shown in the tag-tip drop down boxes are controlled by the primary and secondary 
browsers you choose. 

To display only tag tips that apply to certain browsers 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. Select your first browser choice from the top list, First primary browser tags. 
5. Select your second browser choice from the next list, Second primary browser 

tags. 
6. Select your third browser choice from the list Secondary browser tags. 
7. Select a color for tag tips that apply only to the third browser choice in Secondary 

browser color. 
8. Select OK or Apply. 

When more than one primary browser is selected, the tag tips in the drop down that are 
common to both browsers display in black. This enables you to code for two types of 
browsers, such as Netscape and IE, or two versions of the same browser. 

Example 

If you want to code for IE 5.0, but conserve backwards compatibility with 4.0, then choose 
5.0 and 4.0 as the two primary browsers. Tags in common to both are available in the tag 
tips box. Newer 5.0 tags that didn't exist in 4.0 don't even appear, which helps you code your 
HTML without having to worry about which tags may be supported or not. 
Choosing a secondary browser lets you see ALL the tags for a certain browser in a different 
color. In the example above, if you wanted to code for IE 4.0 and 5.0 but add certain tags 
from OPERA, you would select OPERA as the secondary browser. When you saw a colored 
tag in the tag tips box, you would know it was an OPERA tag, which may or may not work 
in IE or Netscape. This enables you to decide whether or not to insert the particular tag. 
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To choose how long the tag tips take to appear 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. In the Tag tips delay in milliseconds box, enter a time for the HTML editor to 

wait before showing tag tips. 
5. Select OK or Apply. 

To capitalize all tag tips 

1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. Select the Capitalize tag tips check box. 
Or 

• Clear the Capitalize tag tips check box to leave tag tips in lower case. 
5. Select OK or Apply. 
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Integrated HTML Editor 

HTML Editor overview 
CuteFTP has a built in HTML editor. You can edit HTML and other ASCII (text) based 
documents. 
 
The built-in editor was added primarily for remote file editing. This enables Webmasters and 
users to select a document on the remote site, load it in the editor, make quick changes, and 
then save the document back to the remote location. 

TO OPEN THE HTML EDITOR 

• From the menu, choose File > New > HTML Document. 
The editor has the following features: 

• Auto-tag completion feature for HTML tags 
• Auto validation using code-for-browser settings 
• Customizable color-coded HTML and PERL tags 
• Color and RBG to HEX converter 
• Unlimited Undo and Redo commands 
• Document weight feature 
• Word wrap toggle 
• Smart Anchor and Image dialogs that remember commonly used data 
• Sophisticated word/paragraph Find and Replace feature 
• Dynamic view in browser function 
• Highly customizable Java script support for commonly used scripts 
• Handy and customizable Code Snippet feature that allows you to save and reuse 

code 
• Customizable default template for new HTML docs 
• Line numbering option for better code management 
• Easy to use Bold, Italic, and Font selector for those commonly used tags 
• Optional end of line or extended editing cursor placement 
• Color printing for easy document comprehension/layout 
• View unsaved changes in browser feature for fast assessment of proposed 

changes 
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• Plus most standard text editor features 

Editor Menu Tools 

SEARCH AND REPLACE 

You can search and replace characters, words, sentences or entire paragraphs with the 
integrated editor's powerful search and replace tool. 
 

• From the menu, choose Edit > Find / Replace. 
 

1. Enter the word(s) you wish to search for or change in the Search for field.  
2. Enter the replacement word(s) or phrase in the Replace with field. 
3. Select whether to search only the open document or all open documents by checking 

the appropriate field under Where to search in the lower left part of the screen. 
4. Select the open box next to Match case if you want the system to match 

capitalization. (A check mark in the box indicates matching will occur.) 
5. Select Find. 
6. The first match is located and replaced. To continue to search and replace 

throughout the document, select Find Next for each instance (or hit F3 on your 
keyboard) 

 

WARNING: 
Because it replaces all occurrences, be very careful when choosing the 
replace option. For example, if you want to change all occurrences of 
'one' to '1', it will also change words like 'everyone' to 'every1'. 

Tip: 
When entering text into the Search for or Replace with fields, use 
Ctrl+Enter to enter a line break. 

COLOR TO HEX 

The Color to HEX utility eliminates the need to know HEX codes. It will also provide 
HTML values if desired. Find the desired color in the color grid and the integrated editor 
will insert it into your open document at the cursor location. 
 

1. From the menu, choose Tools > Color to HEX. 
2. Select a basic color or choose one from the color wheel.  
3. If you desired to use HTML safe colors only, select Paste browse safe. 
4. Choose OK to insert the HEX code for the selected color into your document. 
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DOCUMENT DATA 

The Document Data screen contains information about the document currently being 
edited. 
 

Text 
Size 

The total size of text contained in the 
document, shown in kilobytes. 

Image 
Size 

The total size of images contained in 
the document, shown in kilobytes. 

Total 
Size 

Total of text and images size, shown in 
kilobytes. 

Weight Number of seconds your page will take 
to load based on size and modem 
speed. Use the down arrow at the end 
of this field to adjust modem speed. 

Images A list of all images appearing in the 
document. 

Anchors A list of all anchors appearing in the 
document. 

 

Working with HTML documents 

CREATING A NEW HTML DOCUMENT 

You can create new HTML documents within the CuteFTP interface. 

To create a new HTML document 
1. From the menu, choose File > New > HTML Document. A new HTML 

document opens. You may begin coding. 

SAVING HTML DOCUMENTS 

To save an HTML document 
1. Make sure the file you want to save is visible in the main window. 
2. From the menu, choose File > Save.  The file is saved.  

Note:  
If the file has never been saved before, CuteFTP opens the Save As 
dialog box. 

To save an HTML document with a new name and/or location 
1. Make sure the file you want to save is visible in the main window. 
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2. From the menu, choose File > Save As.  The Save As dialog box appears.   
3. Choose a name and location for the file. 
4. Select Save. 

To save all open HTML documents at the same time 
1. From the menu, select File > Save All. All open documents are saved.  If you have 

not saved all of them previously, the Save As dialog box appears for each new file. 
2. Choose a name and location for each new file. 
3. Select Save for each new file. 

Note: 
Each open HTML document has a tab with its name on it that appears 
near the lower left of the document. Each time you make a change to an 
HTML document the name on the tab appears in red until you save or 
close the document. 

OPENING AN HTML DOCUMENT 

You can open HTML documents for editing within CuteFTP. 

To open an HTML document 
1. From the menu, choose File > Open. 
2. Browse to the folder containing the document. 
3. Select the document. 
4. Select Open. 

EDITING AN HTML DOCUMENT ON A REMOTE SITE 

To edit HTML documents on a remote site 

1. Connect to a remote server. 
2. Highlight an HTML document in the Remote pane. 
3. On the menu bar, click File > Edit. 
4. The document will be downloaded and opened in the built-in HTML editor. 
5. Make your changes to the document. 
6. On the menu bar, click File > Save. The saved document will be uploaded to the 

remote server. 

PRINTING AN HTML DOCUMENT 

To print a document 
1. Open a document in the HTML editor. 
2. From the menu, choose File > Print.  
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Warning:  
The document prints as it appears in the HTML editor, NOT as it 
appears in a browser. 

To see a print preview 
1. Open a document in the HTML editor. 
2. From the menu, choose File > Print Preview. 
3. From the preview screen, select Print to send the document to the printer. 
4. Select Zoom In to increase magnification or Two Page to display facing pages. 

To change the printer setup (such as the printer, paper size or 
orientation) 

1. Open a document in the HTML editor. 
2. From the menu, choose File > Print Setup. 
3. Make any desired changes.  
4. Selct OK  to accept, or Cancel to make no changes to the Print Setup. 

Note: 
While a document is printing, a printer icon appears next to the clock on 
the taskbar. When this icon disappears, your entire document has been 
sent to the printer. 

CLOSING AN HTML DOCUMENT 

To close an HTML document 
1. Make sure the document you want to close is visible in the main window 
2. From the menu, choose File > Close. 
3. If your document has unsaved changes you will be asked if you want to save the 

changes. Choose one of the following:  
• Yes to save the document.  
• No to exit without saving the document or changes.  
• Cancel to return to the document without saving the document or changes.  

PREVIEWING AN HTML DOCUMENT IN A BROWSER 

You can check to see how an HTML document will look as a Web page, from within 
CuteFTP. 

To preview an HTML document in a browser 
1. Open an HTML document in CuteFTP.  
2. Click anywhere in the document. 
3. From the menu, choose Tools > View in Browser.   

To close the preview 
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• Select the Close  button in the upper right of the browser window. 

OPENING A DOCUMENT IN THE HTML EDITOR IN A FRAME, RATHER THAN IN A 
FULL WINDOW 

The HTML editor opens to either a frame or a full window depending on the display state of 
the Remote Pane.  If the Remote Pane is in a window, then the HTML editor will open to 
a window state.  Conversely, if the Remote Pane is maximized, the HTML editor opens to 
a maximized state. 

Working with HTML 

LEARNING HTML 

Within HTML you use tags to define how text, pictures, and other objects should appear in 
a Web browser. The topics within Working with HTML discuss many of the tags you can 
use to create Web pages. You use most tags in pairs - a start and ending tag. You can visit 
various web sites that explain HTML and how to use it. 

To learn more about HTML 
• See the NCSA Beginner's guide to HTML. 
OR 

• Getting started with HTML from W3C by Dave Raggett. 

STARTING HTML DOCUMENTS 

To start an HTML document  
All HTML documents should have the following codes:  

• Document Type <HTML></HTML> (beginning and end of file)  
• Head <HEAD></HEAD> (after the HTML tag, but before the BODY tags, 

includes descriptive info, such as title)  
• Title <TITLE></TITLE> (must be in header)  
• Body <BODY></BODY> (after the HEAD tags, bulk of the page)  

Example 

<HTML> 
<HEAD> 

<TITLE>Your page title</TITLE> 
</HEAD> 
<BODY> 

The main part of your Web page for public viewing. 
</BODY> 
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</HTML> 

SETTING HTML DOCUMENT STRUCTURE 

Use the following tags to set the overall structure of your Web pages. 

spec. defines 6 levels)  

ER|JUSTIFY></DIV>  
 

as italic)  
 displayed as bold)  

lics)  
e code listings)  

SAMP>  

idely implemented)  
ESS>  

Large Font Size <BIG></BIG>  
MALL>  

ags to alter the appearance and format of text. 

  
IKE> (not widely implemented yet)  

t widely implemented yet)  

 font)  

haracters)  
)  

 
Heading <H?></H?> (the 
Align Heading <H? ALIGN=LEFT|CENTER|RIGHT></H?>  
Division <DIV></DIV>  
Align Division <DIV ALIGN=LEFT|RIGHT|CENT
Block Quote <BLOCKQUOTE></BLOCKQUOTE> (usually indented) 
Emphasis <EM></EM> (usually displayed 
Strong Emphasis <STRONG></STRONG> (usually
Citation <CITE></CITE> (usually ita
Code <CODE></CODE> (for sourc
Sample Output <SAMP></
Keyboard Input <KBD></KBD>  
Variable <VAR></VAR>  
Definition <DFN></DFN> (not w
Author's Address <ADDRESS></ADDR

Small Font Size <SMALL></S

FORMATTING HTML PAGES 

Use these HTML t
 
Bold <B></B>  
Italic <I></I>  
N3.0b Underline <U></U> (not widely implemented yet)
Strikeout <STRIKE></STR
N3.0b Strikeout <S></S> (no
Subscript <SUB></SUB>  
Superscript <SUP></SUP>  
Typewriter <TT></TT> (displays in a monospaced
Preformatted <PRE></PRE> (display text spacing as-is)  
Width <PRE WIDTH=?></PRE> (in c
Center <CENTER></CENTER> (for both text and images
N1.0 Blinking <BLINK></BLINK>  
Font Size <FONT SIZE=?></FONT> (ranges from 1-7)  

149 



CuteFTP Professional User's Guide 

Change Font Size <FONT SIZE="+|-?"></FONT>  
N1.0 Base Font Size <BASEFONT SIZE=?> (from 1-7; default is 3)  

LTICOL GUTTER=?></MULTICOL>  
  

block>  

N3.0b Dimensions <SPACER WIDTH=? HEIGHT=?>  

s, and other graphics to your Web pages. 

Link Somethin

nt)  
(if in current document)  
" TARGET=""></A>  

Defi   
Disp

isplayed)  

PACE=?> (in pixels)  
RC="URL">  

Imag

Imag

NOHREF>  
URL=URL">  

2.0 Embed Object <EMBED SRC="URL"> (insert object into page)  
N2.0 Object Size <EMBED SRC="URL" WIDTH=? HEIGHT=?>  

Font Color <FONT COLOR="#$$$$$$"></FONT>  
N3.0b Select Font <FONT FACE=""></FONT>  
N3.0b Multi-Column <MULTICOL COLS=?></MULTICOL>  
N3.0b Column Gutter <MU
N3.0b Column Width <MULTICOL WIDTH=?></MULTICOL>
N3.0b Spacer <SPACER>  
N3.0b Spacer Type <SPACER TYPE=horizontal|vertical|
N3.0b Size <SPACER SIZE=?>  

N3.0b Alignment <SPACER ALIGN=left|right|center>  

ADDING LINKS AND GRAPHICS TO HTML DOCUMENTS 

Use the following tags to add hyperlinks, picture
 

g <A HREF="URL"></A>  
Link to Target <A HREF="URL#"></A> (if in another docume

<A HREF="#"></A> 
N2.0 Target Window <A HREF="URL

ne Target <A NAME=""></A>
lay Image <IMG SRC="URL">  
Alignment <IMG SRC="URL" 
ALIGN=TOP|BOTTOM|MIDDLE|LEFT|RIGHT>  
Alternate <IMG SRC="URL" ALT=""> (if image not d
Dimensions <IMG SRC="URL" WIDTH=? HEIGHT=?> (in pixels)  
Border <IMG SRC="URL" BORDER=?> (in pixels)  
Runaround Space <IMG SRC="URL" HSPACE=? VS
N1.0 Low-Res Proxy <IMG SRC="URL" LOWS
emap <IMG SRC="URL" ISMAP> (requires a script)  
emap <IMG SRC="URL" USEMAP="URL">  
Map <MAP NAME=""></MAP> (describes the map)  
Section <AREA SHAPE="RECT" COORDS=",,," HREF="URL"|

N1.1 Client Pull <META HTTP-EQUIV="Refresh" CONTENT="?; 
N
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ADDING DIVIDERS TO HTML DOCUMENTS 

Use t

cessary)  
>  

 
Hori

Width <HR WIDTH=?> (in pixels)  
 page width)  

ook)  
 

nts line breaks)  
N1.0 Word Break <WBR> (where to break a line if needed) 

REATING LISTS IN HTML DOCUMENTS 

Use t nd other lists. 
 
Unordered Lis

Compact <UL COMPACT></UL>  
 the whole list)  

SQUARE> (this & subsequent)  
 
Ordered List <OL>

Numbering Ty hole list)  
<LI TYPE=A|a|I|i|1> (this & subsequent)  

 subsequent)  

efinition)  

Menu List <MENU><LI></MENU> (<LI> before each list item)  

he following tags to add breaks to your Web pages. 
 
Paragraph <P></P> (closing tag often unne

Align Text <P ALIGN=LEFT|CENTER|RIGHT></P
 
Line Break <BR> (a single carriage return)  

Clear Text Wrap <BR CLEAR=LEFT|RIGHT|ALL>  

zontal Rule <HR>  
Alignment <HR ALIGN=LEFT|RIGHT|CENTER>  
Thickness <HR SIZE=?> (in pixels)  

Width Percent <HR WIDTH="%"> (as a percentage of
Solid Line <HR NOSHADE> (without the 3D cutout l

N1.0 No Break <NOBR></NOBR> (preve

C

hese tags to create bulleted, numbered, a

t <UL><LI></UL> (<LI> before each list item)  

Bullet Type <UL TYPE=DISC|CIRCLE|SQUARE> (for
<LI TYPE=DISC|CIRCLE|

<LI></OL> (<LI> before each list item)  
Compact <OL COMPACT></OL>  

pe <OL TYPE=A|a|I|i|1> (for the w

Starting Number <OL START=?> (for the whole list)  
<LI VALUE=?> (this &

 
Definition List <DL><DT><DD></DL> (<DT>=term, <DD>=d

Compact <DL COMPACT></DL>  
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Compact <MENU COMPACT></MENU>  
 
Directory List <DIR><LI></DIR> (<LI> before each list item)  

to your Web pages. 

="URL">  
$$$$$$"> (order is red/green/blue)  

isited Link <BODY VLINK="#$$$$$$">  
ctive Link <BODY ALINK="#$$$$$$">  

 
 

Compact <DIR COMPACT></DIR>  

USING BACKGROUNDS AND COLORS IN HTML DOCUMENTS 

Use these tags to set colors, and add colored backgrounds 
 
Tiled Bkground <BODY BACKGROUND
Bkground Color <BODY BGCOLOR="#
Text Color <BODY TEXT="#$$$$$$">  
Link Color <BODY LINK="#$$$$$$">  
V

A

Note: 
The dollar signs represent a hexadecimal code. The first two digits 
represent the amount of red, the middle two digits represent the amount 
of green and the last two digits represent the amount of blue in your 
color. Replace the dollar signs with any number from 0 to 9, or any letter 
from A to F. The numbers are additive, and the letters are higher than 
the numbers, so #000000 is black, #777777 is gray,  #FFFFFF is white, 
#FF0000 is pure red, #00FF00 #0000FF is pure blue.  is pure green, and 
  

USING SPECIAL CHARACTERS IN HTML DOCUMENTS 

You may need to use certain symbols that require special codes in HTML to appear properly 
ages. Use these codes to place special symbols in your Web pages. 

74;  
g;  

Non-Breaking Space &nbsp  

in Web p
 
< &lt;  
> &gt;  
& &amp;  
" &quot;  
Registered TM &#1
Registered TM &re
Copyright &#169;  
Copyright &copy;  
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Speci cter &?; (where ? is the ISO 8859-1 code)  al Chara

Note: 
The letters in the character strings must all be in the same letter case.  

INCLUDING FORMS IN HTML DOCUMENTS 

Use the following tags to add different input fields to your Web pages. 

>  
FORM>  

hecked? <INPUT CHECKED> (checkboxes and radio boxes)  

Input Fie CHECKBOX|RADIO| 
ESET">  

Max Length <INPUT MAXLENGTH=?> (in characters)  

Selec

Multiple Choice <SELECT MULTIPLE> (can select more than one)  

Opti

Default Option <OPTION SELECTED>  

Inpu >  
ME=""></TEXTAREA>  

WRAP=OFF|VIRTUAL|PHYSICAL></TEXTAREA>  

 

 
Define Form <FORM ACTION="URL" METHOD=GET|POST></FORM
N2.0 File Upload <FORM ENCTYPE="multipart/form-data></
C

 
ld <INPUT TYPE="TEXT|PASSWORD|
IMAGE|HIDDEN|SUBMIT|R

Field Name <INPUT NAME="">  
Field Value <INPUT VALUE="">  
Field Size <INPUT SIZE=?> (in characters)  

 
tion List <SELECT></SELECT>  
Name of List <SELECT NAME=""></SELECT>  
Number of Options <SELECT SIZE=?></SELECT>  

 
on <OPTION> (items that can be selected)  

 
t Box Size <TEXTAREA ROWS=? COLS=?></TEXTAREA
Name of Box <TEXTAREA NA
N2.0 Wrap Text <TEXTAREA 

 

Note: 
Receiving input from a form generally requires a script on the server. 

INCLUDING TABLES IN HTML DOCUMENTS 

Use these tags to add tables to your Web pages. 
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Defin

LE> (you can set the value)  

Width Percent <TABLE WIDTH=%> (percentage of page)  

Tabl

Alignmen  
VALIGN=TOP|MIDDLE|BOTTOM>  

Tabl

Alignmen   
E|BOTTOM>  

  

ge of table)  
N3.0b Cell Color <TD BGCOLOR="#$$$$$$">  

Tabl ered)  
Alignmen   

|BOTTOM>  

  

age of table)  
N3.0b Cell Color <TH BGCOLOR="#$$$$$$">  

Tabl

Alignment <CAPTION ALIGN=TOP|BOTTOM> (above/below table)  

USING FRAMES IN HTML DOCUMENTS 

se these tags to separate the Web browser into frames. 

e Table <TABLE></TABLE>  
Table Border <TABLE BORDER></TABLE> (either on or off)  
Table Border <TABLE BORDER=?></TAB
Cell Spacing <TABLE CELLSPACING=?>  
Cell Padding <TABLE CELLPADDING=?>  
Desired Width <TABLE WIDTH=?> (in pixels)  

 
e Row <TR></TR>  

t <TR ALIGN=LEFT|RIGHT|CENTER

 
e Cell <TD></TD> (must appear within table rows)  

t <TD ALIGN=LEFT|RIGHT|CENTER
VALIGN=TOP|MIDDL

No linebreaks <TD NOWRAP>  
Columns to Span <TD COLSPAN=?>
Rows to Span <TD ROWSPAN=?>  
N1.1 Desired Width <TD WIDTH=?> (in pixels)  
N1.1 Width Percent <TD WIDTH="%"> (percenta

 
e Header <TH></TH> (same as data, except bold cent

t <TH ALIGN=LEFT|RIGHT|CENTER
VALIGN=TOP|MIDDLE

No Linebreaks <TH NOWRAP>  
Columns to Span <TH COLSPAN=?>
Rows to Span <TH ROWSPAN=?>  
N1.1 Desired Width <TH WIDTH=?> (in pixels)  
N1.1 Width Percent <TH WIDTH="%"> (percent

 
e Caption <CAPTION></CAPTION>  

U
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N2.0

N2.0 Column Widths <FRAMESET COLS=></FRAMESET> ( = relative size)  

N3.0 ">  

N3.0b Border Color <FRAMESET BORDERCOLOR="#$$$$$$">  

N2.0 frame)  

bottom margins)  
|NO|AUTO">  

N3.0b Border Color <FRAME BORDERCOLOR="#$$$$$$">  

N2.0 Unframed Content <NOFRAMES></NOFRAMES> (for non-frames browsers)  

INCLUDING JAVA IN HTML DOCUMENTS 

se these tags to include Java scripts in your web pages. 

Appl

 

TER">  

Spacing <APPLET HSPACE=? VSPACE=?> (in pixels) 

USING MISCELLANEOUS TAGS IN HTML DOCUMENTS 

se these tags for advanced Web functions. 

 Frame Document <FRAMESET></FRAMESET> (instead of <BODY>)  
N2.0 Row Heights <FRAMESET ROWS=,,,></FRAMESET> (pixels or %)  
N2.0 Row Heights <FRAMESET ROWS=></FRAMESET> ( = relative size)  
N2.0 Column Widths <FRAMESET COLS=,,,></FRAMESET> (pixels or %)  

 
b Borders <FRAMESET FRAMEBORDER="yes|no
N3.0b Border Width <FRAMESET BORDER=?>  

 
 Define Frame <FRAME> (contents of an individual 
N2.0 Display Document <FRAME SRC="URL">  
N2.0 Frame Name <FRAME NAME=""|_blank|_self|_parent|_top>  
N2.0 Margin Width <FRAME MARGINWIDTH=?> (left and right margins)  
N2.0 Margin Height <FRAME MARGINHEIGHT=?> (top and 
N2.0 Scrollbar? <FRAME SCROLLING="YES
N2.0 Not Resizable <FRAME NORESIZE>  
N3.0b Borders <FRAME FRAMEBORDER="yes|no">  

 

U
 

et <APPLET></APPLET>  
File Name <APPLET CODE="">  
Parameters <APPLET PARAM NAME=""> 
Location <APPLET CODEBASE="URL">  
Identifier <APPLET NAME=""> (for references)  
Alternative Text <APPLET ALT=""> (for non-Java browsers)  
Alignment <APPLET ALIGN="LEFT|RIGHT|CEN
Size <APPLET WIDTH=? HEIGHT=?> (in pixels)  

U
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Comment <!-- --> (not displayed by the browser)  
Prologue <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">  

)  

  
RL"> (in header)  

e in header)  
>  

Scripts <SCRIPT></SCRIPT>  

Customizing the Editor 

CHOOSING THE PREVIEW BROWSER FOR HTML DOCUMENTS 

u will 
cuments in your computer's default browser, unless you specify a different 

To cuments from CuteFTP 

Applications and HTML Editor. 

4. puter's default browser, select Preview using the default 

5. , browse or type the path to the program you want to use 
 of HTML. 

6. Select OK. 

CHOOSING THE FOLDER FOR HTML CODE SNIPPETS AND JAVA SCRIPTS 

de snippets and previewing HTML 
doc

Applications and HTML Editor. 

4. s box, browse or type the path to the folder where you want to 
store code snippets. 

Searchable <ISINDEX> (indicates a searchable index)  
Prompt <ISINDEX PROMPT=""> (text to prompt input)  
Send Search <A HREF="URL?"></a> (use a real question mark
URL of This File <BASE HREF="URL"> (must be in header)  
N2.0 Base Window Name <BASE TARGET="">(must be in header)
Relationship <LINK REV="" REL="" HREF="U
Meta Information <META> (must b
Style Sheets <STYLE></STYLE

When previewing HTML documents created or edited in CuteFTP's built-in editor yo
see the do
browser. 

specify the browser for previewing HTML do
1. From the menu, choose Tools > Global Options. 
2. Expand Helper 

3. Select Folders. 
If you want to use the com
browser and select OK.  

Or, to choose a different browser: 

4. Cllear Preview using the default browser. 
In the Browser path box
for previews

To specify the folder for co
uments from CuteFTP 

1. From the menu, choose Tools > Global Options. 
2. Expand Helper 

3. Select Folders. 
In the Code snippet
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5. In the Java scripts box, browse or type the path to the folder where you want to 
store Java scripts. 

6. Select OK. 

CHOOSING TO WRITE HTML FOR A SPECIFIC BROWSER 

The HTML Editor can automatically provide suggestions for HTML tags that work for 
specific browsers. The HTML Editor offers HTML tag choices in drop down boxes.  These 
are called tag tips.   

To show tag tips 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. Select the Show tag tips check box. 
Or 

• Clear the Show tag tips check box to keep tag tips hidden. 
5. Select OK or Apply. 

The tags shown in the tag-tip drop down boxes are controlled by the primary and secondary 
browsers you choose. 

To display only tag tips that apply to certain browsers 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. Select your first browser choice from the top list, First primary browser tags. 
5. Select your second browser choice from the next list, Second primary browser 

tags. 
6. Select your third browser choice from the list Secondary browser tags. 
7. Select a color for tag tips that apply only to the third browser choice in Secondary 

browser color. 
8. Select OK or Apply. 

When more than one primary browser is selected, the tag tips in the drop down that are 
common to both browsers display in black. This enables you to code for two types of 
browsers, such as Netscape and IE, or two versions of the same browser. 

Example 

If you want to code for IE 5.0, but conserve backwards compatibility with 4.0, then choose 
5.0 and 4.0 as the two primary browsers. Tags in common to both are available in the tag 
tips box. Newer 5.0 tags that didn't exist in 4.0 don't even appear, which helps you code your 
HTML without having to worry about which tags may be supported or not. 
Choosing a secondary browser lets you see ALL the tags for a certain browser in a different 
color. In the example above, if you wanted to code for IE 4.0 and 5.0 but add certain tags 
from OPERA, you would select OPERA as the secondary browser. When you saw a colored 
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tag in the tag tips box, you would know it was an OPERA tag, which may or may not work 
in IE or Netscape. This enables you to decide whether or not to insert the particular tag. 

To choose how long the tag tips take to appear 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. In the Tag tips delay in milliseconds box, enter a time for the HTML editor to 

wait before showing tag tips. 
5. Select OK or Apply. 

To capitalize all tag tips 

1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Tag tips. 
4. Select the Capitalize tag tips check box. 
Or 

• Clear the Capitalize tag tips check box to leave tag tips in lower case. 
5. Select OK or Apply. 

CHOOSING DISPLAY COLORS FOR THE HTML EDITOR 

To specify display colors for HTML tags and Perl scripts 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Colors. 
4. Select a color from the list for each tag set and for Perl script components. 
5. Select Apply or OK. 

To specify background and standard font colors for the HTML editor 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications and HTML Editor. 
3. Select Colors. 
4. To use the system default colors, select the Use system settings check box and skip 

to step 7. 
OR 

• To choose different colors, clear the Use system settings check box and continue 
with step 5. 

5. Select a color for the background from the Background list. 
6. Select a color for the font from the System font list. 
7. Select Apply or OK. 
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CHOOSING OTHER HTML EDITOR SETTINGS 

To keep text from running off the right end of the HTML editor screen 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications.  
3. Select HTML Editor. 
4. Select the Enable word wrap check box. 
• Clear the Enable word wrap check box to allow text to continue beyond the right 

edge. 
5. Select OK or Apply. 

To display line numbers in HTML documents 
1. From the menu, choose Tools > Global Options. 
2. Expand Helper Applications.  
3. Select HTML Editor. 
4. Select Prefix each line with line numbers. 
• Clear Prefix each line with line numbers to hide line numbers. 
5. Select OK or Apply. 

 

To change the tags and text that appear in new HTML documents 

1. From the menu, choose  Tools > Global Options. 
2. Expand Helper Applications.  
3. Select HTML Editor. 
4. Select Edit new document template. 
5. Make changes in the New document template dialog. 
6. Select OK. 
7. Select OK or Apply. 

159 





 

12 

Transfer Engine (SDK) 

Transfer Engine Overview 

ABOUT THE TRANSFER ENGINE 

What is the Transfer Engine?  
Built on a modular design platform, CuteFTP Professional's FTP Transfer Engine (TE) is 
completely independent of the main application's interface. You can control the TE through 
an industry standard COM (Component Object Model) interface using your favorite 
programming or scripting language, such as Visual Basic, Perl, ASP or JavaScript.  
   
Unique to CuteFTP's TE are powerful encryption properties that dictate how the control 
and data channels communicate with the FTP server. From SSL to S/key or SSH2, the TE 
covers all your secure file transfer needs.  

Benefits 
The Transfer Engine:  

•  Is COM enabled  
•  Takes up minimal resources  
•  Handles background transfers  
•  Handles transfers outside the main interface  
•  Handles continuous folder synchronization events 
• Can be used with a custom application or script to perform FTP related tasks.  

Capabilities 
The TE exposes most of the popular commands previously accessibly only through the 
application's main interface. Some of the actions you can accomplish using the TE: 

• Login to an FTP server over a defined port 
• Login using an encrypted authentication mechanism, such as OTP 
• Login and transfer files using industry standard SSL/TLS (explicit & implicit modes 

supported) 
• Login and transfer files using SSH2 
• Login to sites through Firewalls, Socks or Proxy servers 
• Transfer files one at a time or simultaneously 
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• Transfer files using multi-part transfers to increase throughput 
• Transfer files from one remote site to another 
• Transfer files using a wildcard mask 
• Transfer files obtained from server-side links 
• Perform folder synchronization tasks 
• Check on an item's transfer status 
• Much more 

TRANSFER ENGINE (TE) INITIAL SETUP 

As a typical COM Component, the TE Object must be registered as such on the target 
system. The TE automatically performs COM Registration if it has been manually executed 
(run once) prior to a script or application instantiating the TE Object.  

To register the TE COM component 

1. Launch CuteFTP Professional. 
2. Close CuteFTP Professional. It should now be registered. 

or 
1. Locate the CuteFTP Professional program folder. 
2. Double-click on the file named "ftpte.exe". 
3. Exit the TE by right-clicking on the TE icon in your Systray. 

Note: 
In order to run script files, you must have the Windows Scripting Host 
(WSH). WSH relies on the Visual Basic Script and JavaScript engines 
provided with Internet Explorer 3.0 or later. WSH is also installed as a 
part of Windows 98, Windows 2000, and Internet Information Server 
4.0. 

RUNNING SCRIPTS 

You can execute a script you have created directly in Windows, from the command line, 
from within CuteFTP's interface, or even as a scheduled task to be run with no user logged 
in. 

To execute a script directly in windows 
1. Launch CuteFTP Professional. 
2. From the menu, choose Tools > Macros & Scripting > Run. 
3. Browse to the script file you created (example, sample.vbs) 
4. Click Open to launch the script. 

The log and queue view in CuteFTP populates with session and transfer information. 

To execute a script from the command line 
1. From Windows, select Start > Run. 
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2. Enter CMD and hit Enter 
3. Navigate to the script file 
4. Enter the name of the file, then press Enter. 

TE launches (the TE icon display in the system tray) and executes your script. 

To execute a script directly in Windows 
1. Navigate to the script file in Windows Explorer. 
2. Double click the script file to launch it. 

TE launches (the TE icon displays in the system tray) and executes your script. 

CREATING SCRIPTS 

You can interact with the TE directly from your own custom applications using common 
programming languages such as Visual Basic (VB) or in a scripting language supported by 
the Windows Scripting Host (WSH).  
You can create a script from the development IDE of your choice, or you can create scripts 
from within CuteFTP Professional by selecting Tools > Macros & Scripting > New 
Script. CuteFTP will open a template script file in a document window.  
To create a new script file, you need to have some familiarity with programming concepts 
and, ideally, some experience with VB or Java. For those of you who have neither, or just 
want a template to work from, load one of the predefined scripts included with CuteFTP or 
the TE and edit it to suit your needs. A few sample scripts are included in this document.  

Tip: 
If you don't have any programming experience, you can still create scripts 
using the session Record & Playback functionality in CuteFTP 
Professional. 

Configuration notes 
• Due to the wide range of scripts that CuteFTP is able to accommodate we are unable 

to offer technical support on individual scripts other than what is available in the 
help files and online Knowledge Base. 

• If you are having trouble with your script, try to perform the desired action manually, 
using the CuteFTP GUI.  If you cannot, then troubleshoot that problem first and 
then re-try your script.   

• If you are able to perform the desired actions, and in the desired sequence when 
using the GUI, then the problem is not with CuteFTP or the FTP Server.  The next 
thing to do is to troubleshoot your script line by line. 

• Once the TE COM component is registered, you can create script files that will 
interface to it.  

• Most of this document, including the various samples and glossary, are geared 
toward the novice programmer. 
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SCRIPT CONVENTIONS FOR EXAMPLES 

The examples in this guide use the following conventions: 
• maroon text is used for the syntax of a method or property 
• "Bold font in double quotes" display parameters for a method or property 
• red text indicates the method or property within an example script 
• ' (apostrophe or single quote mark) shows comments that do not affect the script 
• [Square brackets] are a place for optional items. You should enter the option, but not 

the brackets.  Here's an example: 
• The syntax says;  

String Object.Option("[option name]") = true | false 
• Enter it into a program like this: 

MySite.Option("FilterDirs")=False 

METHODS, PROPERTIES AND WILDCARDS OVERVIEW 

Use methods and properties to operate the Transfer Engine. Methods and properties are 
defined below.  

Methods 
A method can be described as a command or function that may accept arguments 
(parameters) and may return a certain type of value.  
 

Example  

Boolean Object.LocalExists(BSTR bstrName);  
For this method, the type of the return value is Boolean. The command accepts an argument 
as a string value, here shown as BSTR (the type) and bstrName (a place holder for the 
argument).  

 
In a program, you can execute a method and assign the return value to a variable all in one 
command.  
 

Example  

Exists = MySite.LocalExists "c:\temp\file.txt"  
The argument "c:\temp\file.txt exists" is passed to the method LocalExists as a string 
(reason for the quotes). The variable Exists is then populated with a 1 or a 0 which is, in 
essence, true or false. You can then perform actions in your script based on those results.  

Properties 
A property is simply an attribute of a function (another word for method) or object internal 
to the TE framework. All properties have default values. Methods that rely on these 
properties will use default values unless you specify otherwise.  
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Most of the time, you can assign a value to a property or retrieve its value into a variable. 
You can set a property much like a local variable to your script.  
 

Example 

String Object.Protocol  
The above property can accept a predefined set of string values or can be assigned to a 
variable to retrieve the currently selected value. The default in this case is “FTP”.  

You can assign a value to a property as follows:  

Example  

MySite.Protocol = “FTPS”  
Upon subsequent connections, the TE will attempt to login using FTP over SSL, rather then 
via FTP, the default attribute for this property.  

Wildcard masks 
Wildcard masks are patterns of special characters used to filter file names. When a wildcard 
mask is matched against a file name, the two patterns are compared, letter-by-letter, from left 
to right until a mismatch occurs. If all the characters in both patterns compare positively, the 
file name matches the Wildcard Mask. 

USING A SCRIPT TO CONNECT TO A REMOTE SITE  

This script connects the TE to the public GlobalSCAPE FTP server and displays the words 
Connected OK in a message box after a successful connection. 
 
Set MySite= CreateObject("CuteFTPPro.TEConnection") 
MySite.Option ("ThrowError") = False 
MySite.Protocol = "FTP" 
MySite.Host = "ftp.cuteftp.com" 
if cbool(MySite.Connect) then 
MsgBox "Connected OK" 
else 
MsgBox MySite.ErrorDescription 
end if 
MySite.Disconnect 
MySite.Close 
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Note: 
Save this script using notepad or other text editor with a .vbs extension. 
Then simply double-click on the file to execute the script. 

USING A SCRIPT TO DOWNLOAD  

This script connects to the GlobalSCAPE FTP site and downloads a file called 'index.txt' to 
two local folders; c:/temp1 and c:/temp2.  
 
Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Host = "ftp.globalscape.com"  
MySite.Connect 'Recommended: call connect first  
'next line changes to a predetermined folder so I can use 
a relative path in the download method  
MySite.RemoteFolder = "/pub/cuteftp"  
MySite.LocalFolder = "c:\temp1"  
MsgBox (MySite.RemoteFolder) 'display current remote 
folder  
MySite.Download "index.txt"  
MySite.Download "index.txt", "c:\temp2\index.txt"  
'now verify that it downloaded okay  
If MySite.LocalExists ("c:\temp1\index.txt") Then  
MsgBox "File1 downloaded OK."  
End If  
If MySite.LocalExists ("c:\temp2\index.txt") Then  
MsgBox "File2 downloaded OK."  
End If  
MsgBox "Done"  
MySite.Disconnect 
MySite.Close 

RUNNING SCRIPTS FROM THE WINDOWS SCHEDULED TASKS FOLDER 

The Windows Task Scheduler is the recommended tool for setting your TE scripts to run at 
specific times, but you can also use the NT 4 AT Scheduler.  

To schedule a task 
1. In Windows, choose Start. 
2. Choose Programs > Accessories > System Tools > Scheduled Tasks. 
3. Double-click Add Scheduled Task. The Scheduled Task Wizard appears. 
4. Select Next. 
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5. Select Browse. The Select Program to Schedule dialog appears. 
6. Select your script and select Open. You are returned to the Scheduled Task 

Wizard. 
7. Choose how often to run the script and select Next. 
8. Select a starting time, recurrence, and starting date and select Next. 
9. Enter a user name and password for the account that will run the script, and select 

Next. 
10. Select Finish. 

Configuration Notes 
• In Windows 2000 or Windows XP you can set up the Transfer Engine so that it can 

run when no one is logged in. 
• In Windows NT 4 you must have Internet Explorer 4 or higher and the Offline 

Browsing Pack installed to see the Scheduled Tasks folder. 
• If you do not have the Scheduled Tasks folder, you can use the NT 4 AT scheduler. 

RUNNING SCRIPTS WITH THE WINDOWS NT 4 AT SCHEDULER 

The Windows Task Scheduler is the recommended tool for running TE scripts at specific 
times, but you can also use the NT 4 AT scheduler.  
If you want to use the Windows NT 4 AT Scheduler to run TE scripts at specific times, 
follow these guidelines:  

• A user must be logged in at the time the task is scheduled to run, though the 
computer can be locked. 

• Include the /interactive switch in each task. 
• Include the full path to the script with the file name and extension.   

The following example runs a script at 2:12 pm, every day of the week. The script is on the 
computer's C drive, in the example folder, and is named te-test.vbs.  

Example 

at 14:12 /interactive /every:M,T,W,Th,F,S,Su 
c:\example\te-test.vbs 

Configuration Notes 
• For more details and switches for the AT Scheduler type AT/? at the command 

prompt. 
• You can install a GUI task scheduler as part of Internet Explorer if you have version 4 

or higher, see http://support.microsoft.com/default.aspx?scid=kb;EN-US;171229. The 
task scheduler is part of the Offline Browsing Pack.  
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Distributing the Transfer Engine 

DISTRIBUTING THE TE 

The Transfer Engine (TE) is a sub-component of CuteFTP Professional. It is COM enabled 
and provides an interface from which developers can access most of CuteFTP’s file transfer 
related methods.  
 
If you have created a script or application that calls the TE, you may wish to distribute your 
script or application to a group of end-users. In order for the TE to work properly on the 
end users' machines, you must license, install and register the TE on each machine.  
 
Subsequently you must configure the TE so that it can run properly without the CuteFTP 
GUI (interface) installed, especially if you plan to run automated or scheduled tasks while 
not logged in, or if you plan to connect to SSL enabled FTP servers. 

LICENSING THE TE (FOR DISTRIBUTION) 

Licensing - Steps to License the TE 
1. Determine how many end-user seats you will need. 
2. Go to http://www.globalscape.com/cuteftppro. 
3. Select on the Purchase link located on the page. 
4. Purchase one license for each seat you need. If you need to purchase a license to 

cover a large amount of seats, please call us at 1-800-290-5054 or 1-210-308-8267. 
5. Once registered, check your e-mail for the Serial Number 

Licensing Considerations 
• The TE inherits its registration process from CuteFTP. If running on a system that 

has a registered copy of CuteFTP installed, you do not need to register the TE. If 
CuteFTP is not installed (or registered), you must register the TE. 

• The TE runs through a 30-day trial just like CuteFTP. Therefore, the TE may be 
distributed royalty-free with unlimited runtimes for 30 days from the time it is 
installed on an end-user’s computer.   

• After residing 30 days on the target computer, it disables itself if not properly 
registered. The TE must be registered either prior to first launch, during the trial, or 
after the trial has expired.  

• When you purchase a license for CuteFTP you may NOT distribute CuteFTP or any 
of its sub-components (such as the Transfer Engine) in an unlimited royalty free 
fashion. 

• Each copy of the distributed Transfer Engine must be licensed for each computer 
where it is installed. This means you must purchase a full license of CuteFTP for 
each distributed copy of the TE.  
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• You can purchase the necessary amount of licenses up front or after the TE has 
expired on the end-user machine. The benefit of licensing up front is that you can 
distribute the TE and register it on the end-user’s machine. They will not see any 
prompts or registration related dialogs. 

• Once you have licensed the TE, you must install it (if not already installed) and then 
register it on each target machine. 

• You are not permitted to distribute the TE as a component of an FTP client or other 
product that competes with CuteFTP or GlobalSCAPE's Secure FTP Server. 

INSTALLING THE TE (FOR DISTRIBUTION) 

Installation - Steps to Install the TE 
1. Locate the TE component (ftpte.exe), the End User License Agreement (license.txt), 

and the TE’s subordinate dynamic link libraries (sftp21.dll, ssl.dll, etc.) and the 
resource file (default.lng) on your developer (source) machine.  

2. Package the TE along with the other items mentioned in Step 1, along with your 
installation program, script, or executable. 

Note: 
You do NOT need to install the full copy of CuteFTP on the end-user’s 
machine unless you require interaction from CuteFTP' GUI. If you were 
distributing a custom made application, this would not be the case.  

 

Note: 
For setting specific options only available through the GUI (that is, no 
property or method available), you can copy specific registry settings 
from the source computer to the destination. Most all settings are stored 
in the registry under the following hive: 
HKEY_CURRENT_USER\Software\GlobalSCAPE\CuteFTP 
Professional 

 

REGISTERING THE TE (FOR DISTRIBUTION) 

Registration - Automated Registration 
The first method of registering the TE is the most efficient when dealing with a large 
amount of target systems, or when you do not have direct access to the target system. Your 
application installer or script can perform the steps below to transparently register the TE. 

1. Purchase a license for the amount of TE seats you want to distribute. 
2. Install a copy of the Transfer Engine and related components onto the target 

machine. 
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3. Create a new registry key on the target machine at the following location: 
HKEY_USERS\.DEFAULT\Software\GlobalSCAPE\CuteFTP 
Professional\Index 

4. Create a new string value in the key above and insert the serial number as the data 
value. 
String Value = "1"                   Data = "[Your 
Serial Number]" 

5. When the transfer engine is called for the first time, it retrieves this value (the serial 
number) and uses it to complete the registration with GlobalSCAPE. 

Note: 
The target machine must have access to the Internet. If no Internet 
access is available, the registration process may fail and  disable the TE. 

Note: 
The TE is automatically registered if it is installed onto a computer with a 
registered copy of CuteFTP Professional. Keep in mind that the TE must 
be the same version as CuteFTP. The TE from CuteFTP Professional 7.0 
is NOT automatically registered if it is installed on a computer with a 
registered copy of CuteFTP version 3.0. 

Registration - Manual Registration 
If you have physical access to the target machine, or you wish to register the copy installed 
on your developer machine, do the following: 

1. Right-click on the TE icon in the systray to display the context menu (while 
running, the TE is represented by a yellow folder icon with up and down arrows) 

2. Select Enter Serial Number. 
3. Paste or type the Serial Number. 
4. Select Register.  

A message should appear declaring that the registration was successful. The TE can now be 
used on that computer without interruptions.  
If you receive an error message, verify that the serial number was typed correctly and that 
the number of licensed machines didn't exceed the licenses purchased. If all this is correct 
and you are still unable to register, contact our support department and provide them with 
the exact details of the error received. 

COM REGISTRATION OF THE TE (FOR DISTRIBUTION) 

As a typical COM Component, the TE must be registered as such on the target system. The 
TE will automatically perform COM Registration if it has been manually executed prior to a 
script or application instantiating the TE Object.  
The preferred method (for distributed versions of the TE on end-user's systems) is to set the 
appropriate registry entries before trying to call the TE. 

COM Registration via the Registry 
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1. From your installation program, script, or custom application, write the registry entries 
below to the target system. The entries are shown in the standard .reg file notation.  

Note: 
Include the correct the path to the Transfer Engine 
(/[installpath]/ftpte.exe) where %MODULE% is shown below. 

 
REGEDIT4 
[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnecti
on.6] 
@="TEConnection Class" 
[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnecti
on.6\CLSID] 
@="{02172B7A-11D6-42b6-9550-41B281804714}" 
[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnecti
on] 
@="TEConnection Class" 
[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnecti
on\CLSID] 
@="{02172B7A-11D6-42b6-9550-41B281804714}" 
[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnecti
on\CurVer] 
@="CuteFTPPro.TEConnection.6" 
[HKEY_CURRENT_USER\Software\Classes\CLSID\{02172B7A-11D6-
42b6-9550-41B281804714}] 
@="TEConnection Class" 
"AppID"="{310D78A7-4474-4c17-937A-7FF9D5A1B56C}" 
[HKEY_CURRENT_USER\Software\Classes\CLSID\{02172B7A-11D6-
42b6-9550-41B281804714}\LocalServer32] 
@="%MODULE%" <---PATH TO TE!!! 
[HKEY_CURRENT_USER\Software\Classes\CLSID\{02172B7A-11D6-
42b6-9550-41B281804714}\ProgID] 
@="CuteFTPPro.TEConnection.6" 
[HKEY_CURRENT_USER\Software\Classes\CLSID\{02172B7A-11D6-
42b6-9550-41B281804714}\Programmable] 
[HKEY_CURRENT_USER\Software\Classes\CLSID\{02172B7A-11D6-
42b6-9550-41B281804714}\TypeLib] 
@="{1B04F22B-5012-432d-8EA0-B57DD75EBF9D}" 
[HKEY_CURRENT_USER\Software\Classes\CLSID\{02172B7A-11D6-
42b6-9550-41B281804714}\VersionIndependentProgID] 
@="CuteFTPPro.TEConnection" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\ftpte.exe] 
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"AppID"="{310D78A7-4474-4c17-937A-7FF9D5A1B56C}" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{310D78A7-
4474-4c17-937A-7FF9D5A1B56C}] 
@="TEConnection Class" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{02172B7A-
11D6-42b6-9550-41B281804714}] 
@="TEConnection Class" 
"AppID"="{310D78A7-4474-4c17-937A-7FF9D5A1B56C}" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{02172B7A-
11D6-42b6-9550-41B281804714}\LocalServer32] 
@="%MODULE%" <---PATH TO TE!!! 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{02172B7A-
11D6-42b6-9550-41B281804714}\ProgID] 
@="CuteFTPPro.TEConnection.6" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{02172B7A-
11D6-42b6-9550-41B281804714}\Programmable] 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{02172B7A-
11D6-42b6-9550-41B281804714}\TypeLib] 
@="{1B04F22B-5012-432d-8EA0-B57DD75EBF9D}" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{02172B7A-
11D6-42b6-9550-41B281804714}\VersionIndependentProgID] 
@="CuteFTPPro.TEConnection" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CuteFTPPro.TEConnect
ion] 
@="TEConnection Class" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CuteFTPPro.TEConnect
ion\CLSID] 
@="{02172B7A-11D6-42b6-9550-41B281804714}" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CuteFTPPro.TEConnect
ion\CurVer] 
@="CuteFTPPro.TEConnection.6" 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CuteFTPPro.TEConnect
ion.6] 
@="TEConnection Class" 

FINALIZING TE DISTRIBUTION 

Once the TE has been licensed, installed, registered, and COM registered on the target 
system, your script or custom application should be able to instantiate the TE object, and 
invoke any one of the supported methods or properties.  
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For a complete description of the TE, including its supported methods and properties, 
sample scripts and extended trouble shooting guide, please refer to the related topics in this 
user guide and our online knowledge base. 

TROUBLESHOOTING TE DISTRIBUTION 

Problems with running scripts while not logged in (suppressing 
message prompts or dialogs) 
Your script should not contain Message Box functions or any other function that requires 
user input or shows a window. These prompts do not display when the system is not logged 
in.  
You can physically suppress prompts from ever appearing. Use the –noprompt flag and 
execute the TE from the shell on the target machine before calling it from the script. For 
example,  run c:\program files\mycustomapp\ftpte.exe – 
noprompts.  

Warning: 
Suppressing prompts may cause lockups if no default action is available 
for the event in question, or if the prompt was produced by an error.  

The best way to avoid prompts is to properly configure the TE ahead of time to cover all 
possible prompt scenarios, such as overwrite conditions, or SSL server certificate acceptance 
dialogs. For example, set your overwrite actions under CuteFTP's global settings to Always 
Overwrite to avoid any overwrite prompts, or pre-define various rules to cover various 
overwrite scenarios.  You can then export those rules as registry entries and import them 
onto the target machine. 
You can also tell the TE to auto-accept SSL or SSH certificates using the 
AutoCloseMethod parameter of the Option method. Also refer to the following trouble 
shooting topic regarding running the TE while not logged in. 

Locked TE 
If your script or application runs the TE and does not return control to the script, it is 
possible that the TE has locked. Before trying to troubleshoot the problem, make sure you 
exit the locked TE process using the Windows Task Manager (kill the ftpte.exe process). 
If your script is connecting to an SSL enabled server, double check the steps listed under 
Handling SSL Certificates. The primary cause for a locked TE during an SSL connection is 
the fact that the TE could not locate the client or server certificate, or the client certificate 
does not reside in the server’s trusted list. 
An incorrect FTP host address or other common connection problem (host not available, 
connection refused, etc.) may possibly lock up the TE. Verify that the host, proxy, socks, 
user and password property value are correct. 
 The TE may also lock up if an improperly registered TE is launched and unsuccessfully tries 
to display the registration reminder (Web nag dialog). 
Lastly, not properly configuring DCOM configuration for the TE to access the target user’s 
settings may cause the TE to lock up.  
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Note: 
If the system is currently logged in when the TE is run, it runs as the user 
specified under DCOMCNFG. The TE icon does not display in the 
system tray when the CuteFTP's main interface runs. Also, the hard 
coded user's settings are employed when the TE is run, not those of the 
currently logged in user. This is not an issue if you are running the TE 
when the system is not logged in. 

HANDLING SSL CERTIFICATES (WHEN RUNNING A SCRIPT WHILE NOT LOGGED IN) 

Setting up the TE to connect to an FTP server over SSL (via scripting) involves several 
steps. Follow the instructions below carefully. 
You must know whether the TE will require the use of server certificates only, or both 
server and client certificates. 

Server Certificates 
Most FTP SSL servers will provide a certificate to the client during authentication. The 
certificate proves the server's legitimacy to the client. The server’s certificate must be added 
the client’s Trusted Certificate store prior to any connection, otherwise the TE will lock up 
when trying to authenticate. 
 

1. Export or obtain a copy of the server’s certificate from the FTP server administrator. 
Otherwise connect to the server with the CuteFTP GUI (interface) from the 
developer machine and manually accept the server’s certificate. You can then export 
it from the Trusted List under Global Options > Security > SSL Security to a 
staging directory of your choice.  

2. Place/Install the certificate into the target machine’s Default User directory. For 
example: 
C:\Documents and Settings\Default User\Application 
Data\GlobalSCAPE\CuteFTP Pro\Security 

3. If you will also be running the TE while logged in, place a copy of the server 
certificate under the USER folder on the target machine, as follows: 
C:\Documents and Settings\[USERNAME]\Application 
Data\GlobalSCAPE\CuteFTP Pro\Security  
- where [USERNAME] is the login name for the user. 

4. Configurel the TE to auto-accept SSL or SSH certificates using the 
AutoCloseMethod parameter of the Option method. Also refer to the following 
trouble shooting topic regarding running the TE while not logged in. 

Now when you connect, the TE sees the server’s certificate and proceed with the 
connection.  

Client Certificates 
Some FTP SSL servers require that the client provide a certificate. The certificate proves the 
veracity of the client and is an important factor in weeding out spurious FTP clients 
masquerading as legitimate ones. 
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To setup the target system to use client certificates 

1. On the developer machine, create the client certificate and private key pair using the 
CuteFTP GUI (interface). The certificate creation utility is located under the Tools 
> Global Settings > Security > SSL dialog. 

2. Add the client certificate to the server’s trusted list. Do this by connecting to the 
server with the CuteFTP GUI (interface) from the developer machine. On the 
server, move the certificate from the Pending to the Trusted list. If your server only 
has a Trusted list, manually import the client certificate into the Trusted list. 

3. Place the client certificate and private key into the target machine’s USER folder: 
C:\Documents and Settings\[USERNAME]\Application 
Data\GlobalSCAPE\CuteFTP Pro\Security 

- where [USERNAME] is the login name for the user. 
4. If you created the certificate set on the developer machine, export the following 

registry key: 
HKEY_CURRENT_USER\Software\GlobalSCAPE\CuteFTP 
Professional\Settings\SecuritySSL 

5. Import the registry key from step 4 onto the target machine, or manually create the 
necessary entries. The entries are shown in standard .reg file notation. 
REGEDIT4 
[HKEY_CURRENT_USER\Software\GlobalSCAPE\CuteFTP 
Pro\Settings\SecuritySSL] 
"SSLCertificate"="C:\\Documents and 
Settings\\[USERNAME]\\Application 
Data\\GlobalSCAPE\\CuteFTP Pro\\Security\\client.crt" 
"SSLPrivateKey"="C:\\Documents and 
Settings\\[USERNAME]\\Application 
Data\\GlobalSCAPE\\CuteFTP Pro\\Security\\client.key" 
"UseSSLCertificate"=dword:00000001 
"UseSSLCertPassphrase"=dword:00000001 
"ReuseSSLData"=dword:00000000 
"WarnWhenToNonSecure"=dword:00000001 
"DataTransportMethod"=dword:00000001 
"SSLCertPassphrase"="[PASSWORD]" 

 
- Where [USERNAME] is the login name for the target system and where 
[PASSWORD] is the encrypted password exported from the source machine. Don't 
modify the password! 

At the next connection, the TE finds the client certificate and uses it to authenticate with the 
server. 

Example 
Here is a sample script that connects to a fictitious site running SSL Implicit over port 990. 
It also writes to the event log for debugging purposes. if you use this script to test your 
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setup, make sure you modify the MySite.Host line to include your actual FTP SSL server 
host and login information. 
 

#file test.vbs 
Const EVENT_SUCCESS = 0  
Set objShell = Wscript.CreateObject("Wscript.Shell")  
objShell.LogEvent EVENT_SUCCESS,"AT Loaded me"  
Set MySite= CreateObject("CuteFTPPro.TEConnection")  
MySite.Option ("ThrowError") = True  
MySite.Host = 
"ftp://myuser:mypass@ftp.mysslserver.com:990 
objShell.LogEvent EVENT_SUCCESS,"vars set"  
MySite.Connect  
objShell.LogEvent EVENT_SUCCESS, "connected"  
MySite.Disconnect  
MySite.Close 

Methods 

FINDING A METHOD ALPHABETICALLY 

 
AbortAsync RemoteCommand

Close RemoteExists

Connect RemoteRemove

CreateLocalFolder RemoteRename

CreateRemoteFolder S2Sxfer

Disconnect Synchronize

Download TECommand

DownloadAsync TransferURL

GetList TransferURLAsync

LocalExists Upload

LocalRemove UploadAsync

LocalRename Wait

 WriteToLOG
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FINDING A METHOD BY CATEGORY 

Here you can link to every method listed in the help file. 

Connection Files and Folders 

Connect CreateLocalFolder
Disconnect LocalExists
Close LocalRename
 LocalRemove
 CreateRemoteFolder
Transfer RemoteExists
Upload RemoteRename
Download RemoteRemove
S2Sxfer  
Synchronize  
TransferURL Commands 

 AbortAsync
Asynchronous Transfer RemoteCommand
UploadAsync TECommand
DownloadAsync Wait
TransferURLAsync WriteToLOG

BASIC 

Connecting to a remote server  
Description 

Use the Connect method to log in to the remote server. Before calling it, you set the 
protocol, host address, user name, and password to establish a successful connection.    
Syntax  

Object.Connect  
Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTP"  
MySite.Host = "ftp.cuteftp.net"  
MySite.Login = "username"  
MySite.Password = "password"  
MySite.Connect  
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Note:  
Any time you call a Transfer function, the connect function is called 
indirectly. It is recommended you explicitly invoke the Connect function 
though it is not necessary. You can always use the IsConnected property 
to determine whether you are connected at any given time.  

Downloading files 
Description  

Use the Download method to transfer a file or folder from a remote location to your 
local hard drive.   
Syntax 

Object.Download (BSTR strRemoteName ,BSTR strLocalName , 
long nMultiPartNumber)  

Parameters 

strLocalName 

This is optional, use it only if you want to change 
the destination name or path for the downloaded 
files or folder. You can use absolute or relative 
paths with or without wildcards.  

strRemoteName 
This is the path to the remote item you are downloading. 
You can use absolute or relative paths with or without 
wildcards. 

nMultiPartNumber 
Use this to split the download into multiple parts.  The 
default value = 1.  The value specifies the number of parts 
used for the download. 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Specify user, pass, host, and connect as normal...  
MySite.Connect ‘Recommended: call connect first  
‘next line changes to a predetermined folder so you can 
use a relative path in the download method  
MySite.RemoteFolder = "/c:/Inetpub/ftproot/Temp/Temp/"  
MsgBox (MySite.RemoteFolder) 'display current remote 
folder  
MySite.Download "agent.ini", "c:\temp\agent1.ini"  
'now verify downloaded ok  
If CBool(MySite.LocalExists ("c:\temp\agent1.ini")) Then  
MsgBox "File downloaded OK."  
End If  

Configuration Notes 
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• Setting the Multi-part download attribute can greatly increase the transfer speed for 
larger files under certain conditions. For example, the site must support multiple 
concurrent connections from the same user and you must have significant bandwidth. 

• The Download method is a syncrhonous command, meaning it must finish executing 
before subsequent commands in your script can be called. Use the method 
DownloadAsync (which also supports Multi-part transfers) to asyncrhonously 
download files, which allows you to execute the rest of the script while the download(s) 
take place. 

Uploading files 
Description 

Use the Upload method to transfer a file or folder from a local hard drive to a remote 
server.  

Syntax 

Object.Upload(BSTR strLocalName ,BSTR strRemoteName , 
long nMultiPartNumber)  

 

Parameters 

strRemoteName 

This is optional, use it only if you want to change the 
destination name or path for the uploaded files or 
folders. You can use absolute or relative paths with or 
without wildcards.  

strLocalName 
This is the path to the local item you are uploading. You 
can use absolute or relative paths with or without 
wildcards. 

nMultiPartNumber 
Use this to split the upload into multiple parts.  The 
default value = 1.  The value specifies the number of 
parts used for the download. 

 

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Specify user, pass, host, and connect as normal...  
MySite.Connect ‘Recommended: call connect first  
MySite.RemoteFolder = "Temp"  
MySite.LocalFolder = "C:\123"  
‘using relative path, all files in folder 123 are 
uploaded to the folder Temp off the current folder on the 
server.  
MySite.Upload "*.*" 
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Configuration Notes 

• You can only use multi-part uploads with servers that support the COMB command. 
Currently, only GlobalSCAPE Secure FTP server supports the COMB command.  

• Setting the Multi-part upload attribute can greatly increase the transfer speed for 
larger files under certain conditions. For example, the site must support multiple 
concurrent connections from the same user and you must have significant 
bandwidth. 

• The Upload method is a syncrhonous command, meaning it must finish executing 
before subsequent commands in your script can be called. Use the method 
UploadAsync (which also supports Multi-part transfers) to asyncrhonously upload 
files, which allows you to execute the rest of the script while the upload(s) take place. 

Transferring from a URL  
Description 

Use the TransferURL method  to download files directly from a Web address.  
 

Syntax  

Object.TransferURL(BSTR bstrRemoteName, long 
nMultipartNumber)  

 

Parameters 

bstrRemoteName 
This is a string value for the URL for the file transfer such as; 
(ftp://ftp.globalscape.com/pub/cuteftp/cuteftp.exe). 

nMultipartNumber 
This is optional and will split a file into parts for transfer. 
 The default = 1. 

 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.TransferURL 
"ftp://ftp.globalscape.com/pub/cuteftp/cuteftp.exe"  

 

The TE recognizes these URL formats:  
ftp://user:pass@ ftp.sitename.com:port 
ftp://user:pass@ ftp.sitename.com  
ftp://user@ ftp.sitename.com  
ftp:// ftp.sitename.com:port  
ftp:// ftp.sitename.com  
ftp://ftp.sitename.com/pub l: user p: pass ß l: user is a 
lowercase "L", not "one"  
ftp://ftp.sitename.com/pub:44 l: user p: pass  
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ftp://ftp.sitename.com/pub port:44 l: user p: pass  
ftp://ftp.sitename.com/pub l/p: user/pass  
ftp://ftp.sitename.com/pub:44 l/p: user/pass  
ftp://ftp.sitename.com/pub p:44 l/p: user/pass  
ftp://ftp.sitename.com/pub port:44 l/p: user/pass  
ftp://ftp.sitename.com/pub l: user p: pass  
ftp://ftp.sitename.com/pub:44 l: user p: pass  
ftp://ftp.sitename.com/pub p:44 l: user p: pass  
ftp://ftp.sitename.com/pub port:44 l: user p: pass  

Creating a local folder 
Description  

Use the CreateLocalFolder method to create a new folder (directory) on your local hard 
drive.  

Syntax 

Object.CreateLocalFolder(BSTR strName)  

Parameters 

BstrName This contains the folder's relative or absolute path. 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.CreateLocalFolder "c:\temp\New Folder"  
'now check to see if it was created  
MySite.LocalFolder = "c:\temp\New Folder"  
currentdir = MySite.LocalFolder  
MsgBox currentdir  

Creating a remote folder  
Description  

Use the CreateRemoteFolder method to create a new folder (directory) on a remote server.  

Syntax  

Object.CreateRemoteFolder(BSTR strName)  
 

Parameters 

BstrName This contains the folder's relative or absolute path.
 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
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‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MySite.Connect  
MySite.CreateRemoteFolder("/dir") ‘creates /dir (because 
absolute path was used)  
MySite.RemoteFolder = "/dir" ‘now change to the newly 
create ‘dir’ folder  
MySite.CreateRemoteFolder("dir2") ‘creates /dir/dir2 
(because relative path was used)  

Renaming a remote file or folder 
Description  
Use the RemoteRename method to rename a file or folder on the remote server.  

Syntax  

Object.RemoteRename(BSTR bstrFrom, BSTR bstrTo)  
 

Parameters 

BstrFrom 
This contains the folder's old name in a relative or 
absolute path.  The path must be the same in both 
parameters. 

BstrTo 
This contains the folder's new name in a relative or 
absolute path. The path must be the same in both 
parameters. 

 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
‘Initialize all necessary fields for MySite : host name, 
user, password, 
etc. 
MySite.RemoteRename "/pub/user1/file.txt", 
"/pub/user1/file3.txt" 

Renaming a local file or folder  
Description  
Use the LocalRename method to rename a file or folder on your local hard disk.  

Syntax  

Object.LocalRename(BSTR bstrFrom, BSTR bstrTo)  
 

Parameters 

BstrFrom This contains the folder's old name in its full 
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absolute path. 

BstrTo This contains the folder's new name in its full 
absolute path. 

 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MySite.LocalRename "c:\file.txt", 
"e:\temp\users\file.exe"  

 

Note: 
Make sure you specify the full source and destination path. If you had 
written the command as MySite.LocalRename "c:\file.txt", “file.exe”, 
thinking it would rename it using relative paths, you might be surprised 
to find that your file has been moved to your profiles folder (system 
dependent). In essence, the LocalRename is similar to a MOVE 
command issued through drag and drop with the added name change 
sequence.  

Deleting a remote file or folder 
Description 

Use the RemoteRemove method to delete a remote file or folder. You can specify the file 
or folder with absolute or relative paths. If the command fails, make sure you have specified 
the correct path and that you have the appropriate permissions required to delete the item.  

Syntax 

Object.RemoteRemove(BSTR bstrName) 
   

Parameters 

BstrName This contains the folder's relative or absolute path. 

   

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
‘Initialize all necessary fields for MySite : host name, 
user, password, etc. 
MySite.RemoteRemove "/pub/user1/file.txt" 
MySite.RemoteRemove("file.ext") ‘removes if exact match  
MySite.RemoteRemove("*.obj") ‘wild card match with a 
specific extension  
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MySite.RemoteRemove("*.aaa" & Chr(10) & "*.bbb" & Chr(10) 
& "t*") ‘various wildcard filters  

Deleting a local file or folder 
Description  

Use the LocalRemove method to delete a local file or folder. Use the absolute path name 
for the item you want to delete.  
 

Syntax 

Object.LocalRemove(BSTR bstrName)  
 

Parameters 

BstrName 
This contains the items full 
absolute path. 

   

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MySite.LocalRemove "c:\temp\file.txt"  

   

Note: 
You can also you wild cards to replace the string value of bstrName. 
These wild card masks include "*", "?", and ‘\n" (new line symbol, also 
known as Chr(10) in VB) 

   

Example 2 

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MySite.LocalFolder = "c:\temp"  
MySite.LocalRemove("file.ext") ‘removes if exact match  
MySite.LocalRemove("*.obj") ‘wild card match with a 
specific extension  
MySite.LocalRemove("*.aaa" & Chr(10) & "*.bbb" & Chr(10) & 
"t*") ‘various wildcard filters 

Checking for a remote file or folder 
Description 
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Use the RemoteExists method to verify that a remote file or folder exists. BstrName should 
be the full path.  

Syntax 

Boolean Object.RemoteExists(BSTR bstrName) 

Parameters 

Return values  

true  File or folder does exist  

false File or folder does not exist

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
R = MySite.RemoteExists( "/pub/user/file.txt")  
If (R) Then  
MsgBox "File exists on remote side"  
Else  
MsgBox "File doesn't exist on remote side"  
End if 

 

Note: 
If using an "if not" conditional, use CBool instead of boolean as the 
return type. 

Correct:  

if not CBool(MySite.RemoteExists(strRemote)) then 
MsgBox "Error! " & MySite.ErrorDescription 

Incorrect:  

if not MySite.RemoteExists(strRemote) then 
MsgBox "Error! " & MySiteErrorDescription 

Checking for a local file or folder  
Description  

Use the LocalExists method to verify that a local file or folder exists. BstrName 
should be the full path.  
Syntax  

Boolean Object.LocalExists(BSTR bstrName);  

Parameters 
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Return values  

True  File or folder does exist  

False File or folder does not 
exist 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
L = MySite.LocalExists("c:\temp\file.txt")  
If (L) Then  
MsgBox "File exists on local side"  
Else  
MsgBox "File doesn't exist on local side"  
End if  

ADVANCED 

Sending commands to the Transfer Engine 
Description 

Use the TECommand method to pass various commands to the Transfer Engine 
component. If you leave the Transfer Engine running for a long time, it is recommended 
you include the DeleteFinished or DeleteAll in your scripts to occasionally empty the 
queue.  The Transfer Engine does not empty the queue automatically.  
 

Syntax 

Object.TECommand(BSTR bstrParameter) 
 

Parameters 

"CLOSE" or "EXIT"  Closes the TE (all tasks will be stopped) 

"EXITNOPENDING" Closes the TE if no pending tasks are available 

"UPDATESETTINGS"  Reloads settings from the registry (Note you can modify 
the registry from VBS) 

"DELETEFINISHED" Removes finished items from queue 

"DELETEALL"  Removes all items from queue 
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Note: 
You can use any number of spaces or underscores inside these 
parameters. For example, "update setting" and 
"_UPDATE_SETTINGS_" are the same.  

 
If the Transfer Engine has several tasks, or must run for a long time, you should include the 
DeleteFinished command in your scripts to occasionally clear items from the queue.  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.TECommand("delete finished")  

Sending commands to a server 
Description  

Use the RemoteCommand method to send the server any supported command. 
This function acts like the raw input command found in CuteFTP.  
 
Syntax  

Object.RemoteCommand(BSTR bstrCmd)  
 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  

MySite.RemoteCommand "PWD" ‘sends a print working directory 
command  

 

Note:  
If you include the word "LIST", or "RETR", or "STOR" in bstrCmd 
then the Transfer Engine will open the data connection, perform the 
operation (to the buffer) and then discard it. You should use the GetList, 
Download or Upload methods to accomplish these tasks. 

 
You can concatenate strings to perform custom commands. For example, if you wanted to 
do use CHMOD on a file, you could do as shown in the example below:  
 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
strMODE = "777" ‘full permissions  
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strFile = InputBox("Type in the file name below ", "CHMOD 
Dialog", "cftppro10.log") ‘an input dialog with some 
default content  
strvar = "SITE CHMOD " & strMODE & " " & strFile 
‘concatenate the values  
MySite.RemoteCommand strvar 'send the command  

Synchronizing folders with the TE 
Description  

Use the Synchronize method to perform one or two way mirrors of a remote and local 
folder’s contents.  
 

Note:  
The synchronize method contains as many as 9 parameters. Be sure to 
use absolute path names for both local and remote folder paths. 

Syntax  

Object.Synchronize(BSTR bstrRemoteName, BSTR bstrLocalName, 
long nDirection, long nAction, long nCasehandling, BOOL 
bRecursive, BOOL bIgnoreLinks, BOOL bDelDestination, BOOL 
bPromptDel);  
 

Parameters 

# Name Value 
1 BstrRemoteName String value that specifies the absolute path name of the 

remote folder 
2 BstrLocalName String value that specifies the absolute path name of the 

local folder 
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# Name Value 
3 nDirection 0 = Mirror Local (make the remote look just like the local) 

1 = Mirror Remote (make the local look just like the remote)  
2 = Mirror Both 

4 nAction When nDirection = 2 (Mirror Both) 
0 = Mirror the more recent file 
1 = Mirror the larger file  
2 = Prompt for matching file names 
3 = Skip mirroring files with the same names 
----------------------------------------------------------------- 
When nDirection = 0 or 1 (Mirror Local or Remote) 
0 = Use Global Overwrite settings in the CuteFTP shell 
for matching filenames  
1 = Always overwrite the file with a matching name  
2 = Numerate the file (filename[1]) 
3 = Skip 

5 nCaseHandling 0 = Transfer first and skip the rest (default) 
1 = Show rename prompt 
2 = Numerate 
Note: This action applies when matching filenames are 
found and the only difference is the filename case. 

6 bRecursive 0 = Don't sync subfolders 
1 = Apply sync to subfolders (default)       

7 bIgnoreLinks 0 = Don't ignore symbolic links 
1 = Ignore symbolic links (default) 

8 bDelDestination 0 = Don't remove destination 
1 = Remove destination if source does not exist (default) 
Note: This action only applies to one-way mirroring. If a 
file exists in the destination that isn’t in the source being 
mirrored, then delete the destination file. 

9 bPromptDel 0 = Don't prompt before removing destination 
1 = Prompt before removing destination (default) 
Note: Only applies to one-way mirroring when 
DelDestination is True. 

 

Examples  

'Simple synchronize using minimal parameters 
Set MySite = CreateObject("CuteFTPPro.TEConnection") 
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‘Don’t forget to initialize all necessary fields for MySite : host name, user, password, etc. 
 
MySite.Connect 
MySite.Synchronize "/pub/myfolder", "C:\mysitesfiles", 0, 1 
'This will perform a local mirror, overwriting any matching filename. 
 
 
'Simple synchronize using minimal parameters 
Set MySite = CreateObject("CuteFTPPro.TEConnection") 
‘Don’t forget to initialize all necessary fields for MySite : host name, user, password, etc. 
 
MySite.Connect 
MySite.Synchronize "/pub/myfolder", "C:\mysitesfiles", 2, 0 
'This will perform full mirror (both), overwriting older files when a matching filename is 
found. 
 
 
 
'Slightly more complex synchronize routine used to synchronize bookmarks. Uses variables 
for the path names 
strRemotePath = "\Favorites" 
strLocalPath = "C:\Documents and Settings\username\Favorites" 
‘Don’t forget to initialize all necessary fields for MySite : host name, user, password, etc. 
MySite.Connect 
            If (Not (MySite.IsConnected)) Then 
            MsgBox "Unable to connect to server:" + MySite.Host  
            End if  
MySite.Synchronize strRemotePath, strLocalPath, 2, 3, 0, 1, 1, 0, 1 
'Performs a full mirror, skips matching filenames, transfers only the first file if multiple files 
are found with the same name but different case, applies to subfolders, ignores symbolic 
links, does not remove destination files if the source doesn't exist (N/A when dealing with 
dual mirror), and prompt prior to deleting anything (N/A when dealing with dual mirror). 
MsgBox "DONE!" ‘Alert me to the completed task 
MySite.Disconnect ‘Disconnects from the site when done 
MySite.Close ‘Close the Transfer Engine process 
 
 
‘A full synchronizaiton VB subroutine: 
Sub Sync() 
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            Dim MySite 
            Set MySite = CreateObject("CuteFTPPro.TEConnection") 
 
            strHost = "ftp.yourhost.com" 
            strPath = "/pub" 
            strLocalPath = "c:\temp\sync_test" 
 
            strHost = InputBox("Enter host", "CuteFTP Pro", strHost) 
            strPath = InputBox("Enter remote path", "CuteFTP Pro", strPath) 
            strLocalPath = InputBox("Enter local path", "CuteFTP Pro", strLocalPath) 
 
            MySite.Host = strHost 
 
            MySite.CaseHandling = 1 
            MySite.Recursive = False 
            MySite.IgnoreLinks = True 
            MySite.DeleteDestination = False 
            MySite.PromptDelete = True 
 

nUserChoise = MsgBox ("Mirror remote: " & strHost & strPath & " to local " & 
strLocalPath & " ?", vbYesNoCancel) 

            If nUserChoise = vbYes Then 
                        MySite.Synchronize strPath, strLocalPath, 1, 0 
            else 

nUserChoise = MsgBox ("Mirror local: " & strHost & strLocalPath & " to 
remote " & strPath & " ?", vbYesNoCancel) 

                        If nUserChoise = vbYes Then 
                                    MySite.Synchronize strPath, strLocalPath, 0, 0 
                        else 

nUserChoise = MsgBox ("Mirror both: " & strHost & strPath & " <- 
> " & strLocalPath & " ?", vbYesNoCancel) 

                                    If nUserChoise = vbYes Then 
                                                MySite.Synchronize strPath, strLocalPath, 2, 1 
                                    else 
                                    End if 
                        End if 
            End if 
 
End Sub 
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Transferring from site to site (FXP) 
Description  

Use the S2Sxfer method to transfer a file from one remote site to another. You must use 
absolute path names for the source and target folders.  

Syntax  

Boolean Object.S2Sxfer(BSTR bstrSourceName, BSTR 
bstrDestName, BSTR bstrPeerHost, BSTR bstrPeerLogin, BSTR 
bstrPeerPassword, long Port, BSTR bstrPeerProtocol);  

 

Parameters  

bstrSourceName  source file and folder name  

bstrDestName  target file and folder name  

bstrPeerHost  target host name  

bstrPeerLogin  target login  

bstrPeerPassword  target password  

Port  target port  

BstrPeerProtocol  
target protocol (FXP can be applied 
for hosts with different protocols 
FTP, FTP-S)  

 

Return values  

true  Transfer was successful 

false Transfer failed 

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
‘Initialize all necessary fields for MySite : host name, 
user, password, etc. 
MySite.Connect 
MySite.S2Sxfer "/cftppro14.log", 
"/home/myfolder/cftppro14.log", 
"ftp.destinationhost.com", "username", "passwrd" 
'everything else left as default   

Writing messages in a log 
Description 
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Use the WriteToLOG method to write a message directly to the connection log saved in the 
path set in CuteFTP Professional's global options. It is useful for documenting events to aid 
in script debugging.  

Syntax  

Object.WriteToLOG(BSTR bstr , BSTR bstrType)  

Parameters  

bstr The log message. 

bstrType 
A log message, type: "STATUS", "ERROR", "NOTE", 
"COMMAND", "RAW". The default is "STATUS".  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MySite.TransferURLAsync 
"ftp://ftp.cuteftp.com/pub/cuteftp"  
strResult = MySite.Wait  
If (strResult = "FINISHED") then  
MySite.WriteToLOG "Transfer successful!!"  
MySite.WriteToLOG "Transfer successful!!", "error"  
MySite.WriteToLOG "Transfer successful!!", "note"  
End if  
As result, the log will contain the following strings:  
STATUS: > Transfer successful!!  
ERROR: > Transfer successful!!  
Note > Transfer successful!!  

Resuming a transfer 
Though there is no resume method you can use the RemoteCommand method to send the 
APPE (Append) command to a server. APPE is the FTP command to resume a transfer.  

Example 

MySite.RemoteCommand "APPE html/test.txt" 
 
 

Note: 
The RemoteCommand method exists to allow you to manually pass any 
command to the server, even if that command is not natively supported 
through the TE API. 

Waiting for a task to complete 
Description  
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Use the Wait method to tell the Transfer Engine to hold all other tasks until a specific 
asynchronous task is completed. Then continue with the rest of the script.  

Syntax  

String Object.Wait (long taskIndex, long timeout)  

Parameters  

taskIndex 

This is the task index in the asynchronous tasks 
array. The default = -1 (which is current task). 
It can range from 0 to the total number of tasks 
minus one.  

timeout 
Determines how long (in milliseconds) to wait 
for a finished, cancelled, or errored status 
before continuing with the script.  

   

Return value  

"CANCELLED" Transfer was stopped by the user 

"FINISHED" Transfer was successfully finished  

"ERROR" There were errors during the transfer 

"SKIPPED" 
The transfer was skipped (file 
overwrite rules) 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MySite.TransferURLAsync 
"ftp://ftp.cuteftp.com/pub/cuteftp"  
strResult = MySite.Wait  
If (strResult = "ERROR") then  
MsgBox "warning! An error has occurred!"  
End if  

Configuration Notes 

• The default timeout value for the Wait method is 21,805,184 milliseconds, or 
approximately 6 hours.  

• The maximum possible value for timeout is 2,147,483,647 milliseconds, or just under 
25 days.  
You can set the Wait method to never timeout by using a timeout value of 0 (zero). • 

• For hints on Wait method timeouts, see Timeout strategies. 

Stopping transfers and other events 
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Description 

Use the Disconnect method to end an event in progress. It is normally used to stop a file 
transfer.  

Syntax  

Object.Disconnect()  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.TransferURLAsync  
MySite.Disconnect  

Configuration Notes  

Disconnect is not the same as the standard FTP command QUIT. Instead it is simply a 
command to stop the current transfer task. You can issue a QUIT command prior to 
invoking Disconnect by using the RemoteCommand function.  

• 

• A socket disconnect (more brutal than QUIT) to an FTP server occurs automatically 
after all transfers and other commands have finished. This is similar to the Connect 
command, which is implicitly called when a transfer method is invoked.  

• The example above uses the TransferURLAsync command to pass the TE an FTP file 
location to download. Since the TransferURLAsync command is asynchronous, you 
could called TransferURLAsync multiple times consecutively.  

• What happens if you issue a Disconnect command after issuing multiple 
TransferURLAsync commands? The last called TransferURLAsync request is the one 
that is cancelled.  

Closing the Transfer Engine  
Description  

Use the Close function to exit the Transfer Engine.  You can include parameters to only exit 
on certain conditions.  

Syntax  

Object.Close (BSTR bstrParameter)  
 

Parameters  

""(default empty), 
"CLOSE", "EXIT"  

Closes TE (all tasks will be 
stopped) 

"EXITNOPENDING" Closes TE if no pending 
tasks available 

Note: 
You can use any number of spaces or underscores inside these 
parameters. For example, "exit no pending" and 
"_EXIT_NO_PENDING_" are the same.    

Example  
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Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.LocalFolder = "c:\temp" 
MySite.TransferURLAsync 
"ftp://ftp.cuteftp.com/pub/cuteftp" 
MySite.Close "EXITNOPENDING" 

Uploading items asynchronously  
Description  

Use the UploadAsync method to upload a file or folder to a remote server asynchronously. 
 An asynchronous upload starts and then returns control to the script before the transfer 
finishes. This allows you to perform many simultaneous transfers because the method does 
not wait for the upload to end. 
Immediately after you call this method subsequent methods in your script will be called, so 
be careful when timing certain events.  
If UploadAsync encounters a problem when trying to complete its task, it will not throw a 
COM, ATL, or VB error. UploadAsync will also adhere to your max global and per site 
settings. 

Syntax  

Object.UploadAsync(BSTR strLocalName [,BSTR strRemoteName 
[, long nMultiPartNumber]])  

Parameters 

strRemoteName 

This is optional, use it only if you want to change the 
destination name or path for the uploaded files or 
folders. You can use absolute or relative paths with or 
without wildcards.  

strLocalName 
This is the path to the local item you are uploading. You 
can use absolute or relative paths with or without 
wildcards. 

nMultiPartNumber 
Use this to split the upload into multiple parts.  The 
default value = 1.  The value specifies the number of 
parts used for the download. 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
‘Initialize all necessary fields for MySite : host name, 
user, password, etc. 
MySite.Connect 
MySite.UploadAsync "c:\temp\*.vob", "/DVDFiles" 'uploads 
as many .vob files as concurrent connection settings 
allow 
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Note:  
The Multi-part parameter for the UploadAysnc is currently limited to 
servers that support this operation, due to the need to recombine the 
files after the upload of each part has completed. As of September 2002, 
GlobalSCAPE’s Secure FTP server was the only server to support this 
function. 

Downloading items asynchronously  
Description  

Use the DownloadAsync method to download a file or folder to the local hard drive 
asynchronously. An asynchronous download starts and then returns control to the script 
before the transfer finishes. This allows you to perform many simultaneous transfers because 
the method does not wait for the download to end. Immediately after you call this method 
subsequent methods in your script will be called, so be careful when timing certain events. 
If DownloadAsync encounters a problem when trying to complete its task, it will not throw 
a COM, ATL, or VB error. DownloadAsync will also adhere to your max global and per 
site settings. 

Syntax  

Object.DownloadAsync(BSTR strRemoteName ,BSTR 
strLocalName , long nMultiPartNumber)  

Parameters 

strLocalName 

This is optional, use it only if you want to change 
the destination name or path for the downloaded 
files or folder. You can use absolute or relative 
paths with or without wildcards.  

strRemoteName 
This is the path to the remote item you are downloading. 
You can use absolute or relative paths with or without 
wildcards. 

nMultiPartNumber 
Use this to split the download into multiple parts.  The 
default value = 1.  The value specifies the number of parts 
used for the download. 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftp.cuteftp.com" 
MySite.Connect 
MySite.DownloadAsync "/pub/cuteftp/english/*", "c:\temp" 
'downloads all files in the pub/cuteftp folder   

 

Note: 
You can call the DownloadAsync method many times sequentially in a 
script. Each call, in turn, opens a new data connection to the specified 
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server, enabling you to transfer multiple files simultaneously. This, 
combined with the ability to transfer the file in multiple parts, greatly 
increases the overall transfer speed and execution of your task.  

Transferring from URLs asynchronously  
Description  

Use the TransferURLAsync method to start a download from a web address, and 
return control to the script immediately. This method does not wait for the transfer 
to end. You can use it to perform many simultaneous transfers.  

• 

• The difference between this method and DownloadAsync is simply the ability to 
specify all of the necessary parameters in one command, rather than having to set the 
user name, port, host, etc. and then transfer a file.  

• Immediately after you call this method subsequent methods in your script will be 
called, so be careful when timing certain events. 

• If TransferURLAsync encounters a problem when trying to complete its task, it 
will not throw a COM, ATL, or VB error. TransferURLAsync will also adhere to 
your max global and per site settings. You can't use wildcards in this method.  

Syntax  

Object.TransferURLAsync(BSTR bstrURL [, long 
nMultipartNumber])  

Parameters  

bstrURL  
A string value for the URL for the 
file transfer 
(ftp://ftp.cuteftp.com/pub/cuteftp) 

nMultipartNumber 
An optional multipart parameter 
with default = 1 

   

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.TransferURLAsync 
"ftp://ftp.cuteftp.com/pub/cuteftp/english" 
‘this will transfer the entire English CuteFTP directory 
from the CuteFTP.com ftp site. 

 

Normal Formats Supported  

ftp://user:pass@ ftp.sitename.com:port  
ftp://user:pass@ ftp.sitename.com  
ftp://user@ ftp.sitename.com  
ftp:// ftp.sitename.com:port  
ftp:// ftp.sitename.com  
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ftp://ftp.sitename.com/pub l: user p: pass ß l: user is a 
lowercase "L", not "one"  
ftp://ftp.sitename.com/pub:44 l: user p: pass  
ftp://ftp.sitename.com/pub port:44 l: user p: pass  
ftp://ftp.sitename.com/pub l/p: user/pass  
ftp://ftp.sitename.com/pub:44 l/p: user/pass  
ftp://ftp.sitename.com/pub p:44 l/p: user/pass  
ftp://ftp.sitename.com/pub port:44 l/p: user/pass  
ftp://ftp.sitename.com/pub l: user p: pass  
ftp://ftp.sitename.com/pub:44 l: user p: pass  
ftp://ftp.sitename.com/pub p:44 l: user p: pass  
ftp://ftp.sitename.com/pub port:44 l: user p: pass  

 

Extended URL formats  

Aside from the standard URL formats shown above, additional specifiers may be used to 
denote the direction of transfer and download path. Use the extended format to perform site 
to site transfers, uploads, targeted downloads, and more. 
 
The standard url ftp://user:pass@ftp.host.com will be used in the following examples: 
 
Format: Normal URL transfer 
Example: MySite.TransferURLAsync 
"ftp://user:pass@ftp.host.com"  
'download site to the default download folder 
 
Format: URL [space] "-->" [space] LPATH 
Example: MySite.TransferURLAsync "ftp://user:pass@ftp.host.com 
--> c:\temp"  
'download site to the c:\temp folder 
 
Format: URL [space] "<--" [space] LPATH 
Example: MySite.TransferURLAsync "ftp://user:pass@ftp.host.com 
<-- c:\web"  
'upload files from c:\web to the site 
 
Format: URL1 [space] "<->" [space] URL2 
Example: MySite.TransferURLAsync "ftp://user:pass@ftp.host.com 
<-> 
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ftp://user2:pass2@ftp.host2.com" 'perform a site to site 
transfer 
 
Format: URL [space] "<==" [space] LPATH 
Example: MySite.TransferURLAsync "ftp://user:pass@ftp.host.com 
<== c:\web"  
'synchronize (mirror local) the c:\web folder to the site 
 
Format: URL [space] "==>" [space] LPATH 
Example: MySite.TransferURLAsync "ftp://user:pass@ftp.host.com 
==> c:\web" 
'synchronize (mirror remote) the site to c:\web 
 
Format: URL [space] "<=>" [space] LPATH 
Example: MySite.TransferURLAsync "ftp://user:pass@ftp.host.com 
<=> c:\web" 
'synchronize both local and remote (mirror both) 

Stopping asynchronous transfers  
Description  

Use the AbortAsync function to stop an asynchronous task created previously by 
UploadAsync, DownloadAsync or TransferURLAsync. Refer to those methods for 
more information.  
Syntax  

Object.AbortAsync(long taskIdx)  
Parameters 

TaskIdx  

This is a task index in the array of tasks created by the various 
asynchronous methods. The default value of taskIdx is - 1 
which specifies all the asynchronous tasks in array.  
TaskIdx should be between 0 and AsyncTaskNumber minus 
one.  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Option("CleanupAsync") = False 
‘Initialize all necessary fields for MySite : host name, 
user, password, etc. 
MySite.Connect 
MySite.DownloadAsync "*.*", "c:\temp" 
MsgBox "Number of tasks created: " & 
MySite.AsyncTaskNumber 
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If MySite.AsyncTaskNumber > 10 then 
MsgBox "Aborting 11th task" 
MySite.AbortAsync ( 10 ) 'abort task # 11 (one less then 
total, since 
starts from 0) 
End if 

 
 

Note: 
You must set MySite.Option("CleanupAsync") = False 
so that all asynchronous tasks are counted. Otherwise, only the last 
asynchronous task launched will be referenced when calling the 
AbortAsync method. 

Automatically encrypting and compressing transfers 
To automatically encrypt and compress files before transfer, you will need both CuteZIP and 
CuteFTP Professional. You can also compress and encrypt files after transferring them by 
using GlobalSCAPE Secure FTP Server's Custom Site Commands. The benefits of 
encrypting files prior or post transfer depends on the circumstances and level of trust for the 
particular host. 
 
In the example script below, an entire folder (including sub-folders) is compressed, 
encrypted (using Twofish 128 bit encryption) and then transferred via regular FTP to an 
FTP server. Since the archived file is encrypted, there is no need to connect using SSL, OTP, 
or SSH2 unless you wished to also protect the login process. 

Example 

Dim WshShell, MySite, Return 
Set WshShell = CreateObject("WScript.Shell") 'Window's 
Scripting Host shell object 
'next line calls the run method of the WSH shell object. 
It returns true once CuteZIP does its thing. 
'The complete command line instructions for CuteZIP are 
located here. 
If Return = WshShell.run 
("c:\progra~1\global~1\CuteZIP\cutezip.exe -c -p12345 
c:\archive c:\temp", 0, true) Then 
  Set MySite = CreateObject("CuteFTPPro.TEConnection") 
  MySite.Option ("ThrowError") = True 
  MySite.Host = "ftp://user:pass@myftpsite.com" 'one of 
the ways to connect using the TE 
  MySite.Connect 
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  MySite.Upload "c:\archive.zip" 'upload the new archive, 
then check to see if it made it up to the server. 
  if not CBool(MySite.RemoteExists("\archive.zip")) then 
     MsgBox "Failed to Upload, Exiting!" 
  Else 
     MsgBox "Success!" 
  End If 
  MySite.Disconnect 
  MySite.Close 
Else 
MsgBox "Compression and Encryption Failed, Exiting!" 
End If 

 

Note: 
You can optionally protect the FTP login by connecting with SSL, SSH2 
or OTP using CuteFTP Professional's Transfer Engine (GlobalSCAPE's 
Secure FTP Server 2 supports SSL, OTP, and SSH2 logins). Use the 
protocol property to set the connection type prior to calling MySite.Host 
and MySite.Connect. 

Retrieving a folder listing 
Description 

Use the GetList method to download folder listings. 

Syntax 

Object.GetList(BSTR bstrPath, BSTR bstrLocalFile, BSTR 
bstrFormat, BOOL *pVal) 

Parameters 

bstrPath 
The remote path to be listed. Leave it empty if 
its the current path. 

bstrLocalFile 
Specifies a local file name where the listing can 
be saved. 

bstrFormat 

Can be used to format the listing. If left empty, 
a raw listing will be returned. You can specify 
%NAME, %DATE, and %SIZE as return 
values in a string. 

 

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftp.cuteftp.com/pub" 
MySite.Connect 
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MySite.GetList "", "c:\temp_list.txt" 'saves a raw 
listing for the default path to the file temp_list.txt 
MsgBox MySite.GetResult 'retrieves and displays the 
listing 

Example 2 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftp.cuteftp.com" 
MySite.Connect 
MySite.GetList "/pub", "", "FILE NAME:   %NAME" 'goes to 
pub folder, doesn't save the listing to file, and formats 
it as shown 
MsgBox MySite.GetResult 'retrieves and displays the 
listing 

Example 3 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftp.cuteftp.com" 
MySite.Connect 
MySite.GetList "/pub", "", "NAME= %NAME SIZE= %SIZE DATE= 
%DATE" 'goes to pub folder, doesn't save the listing to 
file, and formats it as shown 
MsgBox MySite.GetResult 'retrieves and displays the 
listing 

Note: 
GetResult is an optional method used only with GetList.  It simply 
retrieves the data. Without GetResult the data is written to the buffer, or 
if defined in the parameters, the data is written to the log. 

Properties 

FINDING A PROPERTY ALPHABETICALLY 

Here you can link to any property listed in the Help file. 
 
AsyncTaskNumber IsPending RemoteSiteFilter

AutoRename Links RestSupport

ClearCommandChannel LocalFilterExclude Retries

ClearDataConnection LocalFilterInclude SocksInfo

CombSupport LocalFolder Speed

203 



CuteFTP Professional User's Guide 

DataChannel Log Status

Delay Login TimeElapsed

ErrorDescription MaxConnections TimeLeft

FileSize Option TotalSize

FileTimeModified Password TransferredSize

FileType Port TransferType

HomeDir Protocol UseProxy

Host ProxyInfo  

IgnoreLinks Recursive  

IsConnected RemoteFilterExclude  

 

 

RemoteFilterInclude  

RemoteFolder  

 

FINDING A PROPERTY BY CATEGORY 

You can find properties here listed by: 
Connection properties • 

• 

• 

• 

• 

Read-only connection properties 
Transfer properties 
Read-only transfer properties 
Filter properties 

 

Connection properties 

Protocol ClearDataConnection

Host ClearCommandChannel

Login Retries

Password Delay

Port Links

UseProxy LocalFolder

ProxyInfo RemoteFolder

SocksInfo MaxConnections
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DataChannel Option
 

Read-only connection properties 

IsConnected HomeDir

ErrorDescription Log

 

Transfer properties 

TransferType Recursive

LocalFolder IgnoreLinks

RemoteFolder Option

AutoRename  

 

Read-only transfer properties 

AsyncTaskNumber Speed

Combsupport TimeLeft

IsPending TimeElapsed

Status FileType

RestSupport FileSize

TotalSize FileTimeModified

TransferredSize  

  

Filter properties 

LocalFilterInclude RemoteFilterInclude

LocalFilterExclude RemoteFilterExclude

 RemoteSiteFilter
 

CONNECTION PROPERTIES 

Setting protocols 
Description  

Use the Protocol property to set or retrieve the value for the protocol type.  
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Syntax  

String Object.Protocol  
 

Parameters  

"FTP"  File Transfer Protocol  
"FTPS"  FTP using SSL in explicit mode (standard port 21)  

"FTPS_IMPLICIT" Extension of FTP using SSL -- FTP using SSL in implicit mode 
(specific port)  

"SFTP"  Secure protocol based on SSH2  

"FTP_SKEY_MD4"  Secure one time password login using MD4  

"FTP_SKEY_MD5" Secure one time password login using MD5  

"HTTP"  Hypertext Transfer Protocol  

"HTTPS"  HTTP with SSL  

 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTPS_IMPLICIT "  
MySite.Host = "ftp.ftp.net"  
MySite.Port = 990  
MySite.Login = "username"  
MySite.Password = "password"  
MySite.Connect  

 

Note: 
You can find more options for using SSL in ClearDataChannel. 

Setting a host address for a connection 
Description  

Use the Host property to set or retrieve the value for the host name of a site when you are 
connecting.  

Syntax  

int Object.Host  
Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTP"  
MySite.Host = "ftp.ftp.net"  
MySite.Port = 21  

206 



Transfer Engine (SDK) 

MySite.Login = "username"  
MySite.Password = "password"  

Setting your user name  
Description  

Use the Login property to set or retrieve the value for the user name (login) you use to 
connect.    

Syntax  

String Object.Login  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTP"  
MySite.Host = "ftp.cuteftp.com"  
MySite.Login = "username"  
MySite.Password = "password"  
MySite.Connect  

Setting the password for a connection 
Description  

Use the Password property to set or retrieve the value for the password you use to connect.  

Syntax  

String Object.Password  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTP"  
MySite.Host = "ftp.ftp.net"  
Object.Login = "username"  
MySite.Password = "password"  
MySite.Connect  

Setting the port for a connection 
Description  

Use the Port property to set or retrieve the value for the Port on the server when you 
connect.  

Syntax  

int Object.Port  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTP"  
MySite.Host = "ftp.cuteftp.com"  
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MySite.Port = 21  
MySite.Login = "username"  
MySite.Password = "password"  
MySite.Connect  

Transferring files in an unencrypted data channel 
Description  

Use the ClearDataConnection property to specify whether the data channel should be 
encrypted or not when using FTP over SSL.  

Syntax  

long Object.ClearDataConnection  

Parameters   

True 
Your login is encrypted but data transfers are not. This is the 
default. 

False Your login and data transfers are encrypted. 

 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTPS"  
MySite.ClearDataConnection = false ‘encrypt FTP data channel  

Configuration Notes  

• The default is true (encrypted), so only set this property if you wish to log in securely 
but transfer data in the clear.  

• This property will only work if the remote server supports SSL and clear data channel 
connections (PROT C command according to RFC 2228) and you have specified FTPS 
as the protocol type.  

Sending unencrypted commands over an SSL connection 
Description  

Use the ClearCommandChannel property to specify that the command channel should 
not be encrypted  over SSL.  

Syntax  

long Object.ClearCommandChannel  
 

Parameters   

True 
Your login is encrypted but as data transfers start, commands 
are not encrypted.  

False 
Your login and subsequent commands are encrypted. This is 
the default 
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Example  

MySite.Host = "host" 
MySite.Protocol = "FTPS" 
MySite.ClearCommandChannel = true '<-- CCC will be sent 
prior to the first data connection operation. 
MySite.Connect 

Configuration Notes 

• The default is false (encrypted), so only set this property if you wish to log in securely 
but send subsequent commands in the clear. 

• This property will only work if the remote server supports SSL and clear command 
channel connections (according to RFC 2228) and you have specified FTPS as the 
protocol type. 

Connecting through a proxy or SOCKS server 
Description  

Use the UseProxy property to retrieve or set the value for the type of SOCKS or proxy 
server that is being (or should be) used. Since OFF is the default, you don't need UseProxy 
for regular connections which do not pass through proxy or SOCKS servers.  

Syntax  

String Object.UseProxy  
Parameters  

"OFF"  Direct connection without any socks and proxy 

"SOCKS"  
SOCKS server only - the user must specify the SOCKS 
parameters by setting the SocksInfo property 

"PROXY"  
Proxy server only -  the user must specify the proxy server 
parameters by setting the ProxyInfo property  

"BOTH"  
Use both SOCKS and proxy - the user should specify the 
appropriate information for both the proxy and the socks server 
with ProxyInfo and SocksInfo. 

Example  

Object.UseProxy = "SOCKS" ‘specify that socks will be 
used, then configure SocksInfo  
Object.SocksInfo = "socks5://globalscape.com:1080"  
‘Rest of connection code follows... 

Setting and retrieving proxy server configurations  
Description  

Use the ProxyInfo property to set or retrieve FTP and HTTP proxy server configurations. 
Do not use this function if you do not connect through a proxy server.  
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Authentication Parameters 

"ftp://proxyusername:proxypassword@proxyhostname:proxyport" 

For FTP 
proxies that 
require 
authentication.

"http://proxyusername:proxypassword@proxyhostname:proxyport" 

For HTTP 
proxies that 
require 
authentication.

"ftp:// proxyhostname:proxyport" 

For FTP 
proxies that 
don't require 
Authentication.

"http:// proxyhostname:proxyport" 

For HTTP 
proxies that 
don't require 
Authentication.
 

 
 

Additional parameters  

"proxyusername" The user name for login to the proxy server 

"proxypassword"  The password for login to the proxy server 

"proxyhostname" The proxy server address 

"proxyport"  The proxy server connection port 

 

Syntax  

String Object.ProxyInfo  
Example 1  

MySite.ProxyInfo = http://globalscape.com:8000 ‘use http 
proxy without authorization  

Example 2  

MySite.ProxyInfo = 
ftp://joeuser:maypass@globalscape.com:21 ‘use ftp proxy 
with authorization for user "joesuser" & password 
"mypass"  
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Example 3  

str = MySite.SocksInfo ‘retrieve the current value of 
SocksInfo (empty if none)  
MsgBox str ‘now display it  

Setting or retrieving values for SOCKS servers  
Description  

Use the SocksInfo property to set or retrieve values for SOCKS4 or SOCKS5 servers. 
(SOCKS is a protocol for a TCP proxy across firewalls.)  

Syntax  

String Object.SocksInfo  

Authentication Parameters 

"socks4://socksusername:sockspassword@sockshostname:socksport" 

For SOCKS4 
servers that 
require 
authentication.

"socks5://socksusername:sockspassword@sockshostname:socksport" 

For SOCKS5 
servers that 
require 
authentication.

"socks4:// sockshostname:socksport" 

For SOCKS4 
servers that do 
not require 
authentication.

"socks5:// sockshostname:socksport" 

For SOCKS5 
servers that do 
not require 
authentication.

 

Additional parameters 

"socksusername" 
The user name or log in name to the 
SOCKS server.  

"sockspassword" The password for the SOCKS server. 

"sockshostname" 
The address and port for the SOCKS 
server.  

Example 1  

MySite.SocksInfo = "socks4//globalscape.com:1080" 'use 
socks4 without authorization  
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Example 2  

MySite.SocksInfo = 
"socks5://joeuser:mypass@globalscape.com:1080" ‘use 
socks5 with authorization for user "joeuser" with 
password "mypass"  

Example 3  

str = MySite.SocksInfo ‘retrieve the current value of 
SocksInfo (empty if none)  
MsgBox str ‘now display it  

Choosing ASCII, binary, or auto transfer types 
Description  

Use the TransferType property to retrieve or set the value for the way the Transfer Engine 
should transfer files (ASCII, binary or auto).  

Syntax 

String Object.TransferType  
Parameters  

"ASCII"  All files should be transferred in ASCII mode 

"BINARY"  All files should be transferred in BINARY mode 

"AUTO" 
(default)  

The TE will reference an internal list editable from CuteFTP's Global 
Options to determine the proper transfer type for that particular file. For 
example, if the ASCII list contains a filter mask of "txt" then all files with 
extension ".txt" will be transferred in ASCII. If a file doesn't correspond to 
any mask in this list then it will be transferred in binary mode.  

Example  

Object.TransferType = "AUTO" ‘the Transfer Engine will use the shell’s 
default settings to establish whether the transfer should occur in binary or 
ASCII. ‘write file transfer code next...  

Choosing a PASV or PORT connection 
Description  

Use the DataChannel property to set or retrieve values for the method in which the data 
port is established for the data channel (PASV or PORT). The default is PORT.    

Syntax  

String Object.DataChannel  
Parameters  

"PORT" 
The client specifies what port to use for 
the data connection 

"PASV" Lets the server specify the port used for 
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the data connection port 

"DEFAULT" 
Uses the method defined in Global 
Options 

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Host = "ftp://ftp.cuteftp.com"  
MySite.useProxy = "off"  
MySite.DataChannel = "PASV"  
MySite.RemoteCommand("LIST")  
MySite.DataChannel = "PORT"  
MySite.RemoteCommand("LIST")  
MsgBox MySite.Log  

Setting the number of retry attempts 
Description  

Use the Retries property to retrieve or set the value for the maximum number of attempts 
the Transfer Engine should make to connect to a remote host. 

Syntax  

int Object.Retries  
Example  

MySite.Retries = 10  

Note: 
Some older versions of CuteFTP Pro help files state that you can use the 
Retries property with transfers. That is incorrect, Retries only works 
with connections. 

Setting the delay between retries  
Description  

Use the Delay property to set the delay between connection retry attempts (in seconds).  

Syntax  

int Object.Delay  
Example  

MySite.Delay = 90  

Note: 
Some older versions of the CuteFTP Pro help file state that you can use 
the Delay property with transfers. That is incorrect, you can only use 
Delay with connections. 

Resolving or retrieving links 
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Description  

Use the Links property to both set and retrieve values for working with links on a remote 
server.  

Syntax  

String Object.Links  
Parameters  

"Resolve"  The TE will attempt to resolve the link 
prior to transfer.  

"GetAsFile"  
The TE will assume it’s a file and transfer 
as is (This is used to avoid endless loops 
in a large multi-directory transfer).  

 

Example  

MySite.Links = "Resolve"  

Ignoring links 
Description 

Use the IgnoreLinks property when working with Unix servers. Use IgnoreLinks to set or 
retrieve the value that determines whether or not you want to bypass links.    

Syntax 

Bool Object.IgnoreLinks 

Parameters 

"True" Skip symlinks during synchronization 

"False" 
Handle symlinks during synchronization as files or 
folders 

 

Example 

Mysite.IgnoreLinks = "False" 

Choosing a local folder 
Description  

Use the LocalFolder property to retrieve or set the current folder on your local hard disk. 
You can use relative or absolute paths.  

Syntax  

String Object.LocalFolder  

Example  

Object.LocalFolder = "c:\temp"  

Choosing a remote folder 
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Description  

Use the RemoteFolder property to retrieve or set the current remote folder. You can use 
absolute or relative paths.  

Syntax 

String Object.RemoteFolder  

Example  

‘Connect to site following previous samples  
MySite.RemoteFolder = "/pub/cuteftp" ‘Changes the remote 
folder to /pub/cuteftp (absolute paths used)  
‘subsequently  
MySite.RemoteFolder = "test" ‘Changes to the folder 
called "test" located in "/pub/cuteftp", using relative 
paths.  

Using the auto-renaming feature in transfers 
Description  

Use the AutoRename property to set or retrieve the renaming values prior to the transfer of 
a file or folder. To configure the auto-rename rules open the CuteFTP Professional interface 
and go to Tools > Global Options > Transfer > Rename Rules.  

Syntax  

String MySite.AutoRename  

Parameters  

"ON"  
AutoRename feature 
turned on 

"OFF" 
AutoRename feature 
turned off 

Example  

MySite.AutoRename = "ON"  

Setting the maximum number of connections 
Description  

Use the MaxConnections property to set or retrieve the most connections the script is 
allowed to open.  

Syntax  

long Object.MaxConnections  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.MaxConnections = 1 ‘restrict connections to 1  

Choosing to include or exclude subfolders in a task 
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Description 

Use the Recursive property to set or retrieve the value that determines whether or not 
subfolders will be included in a transfer task.  This property is used often in synchronization 
scripts.   

Syntax 

Bool Object.Recursive 

Parameters 

"True" Include subfolders 

"False" 
Do not include 
subfolders 

Example 

Mysite.Recursive = "True" 

Setting or retrieving other settings 
Description 

Use the Option property to set or retrieve various settings, such as Auto-rename, include 
folder names when filtering, cache invalidation, error handling, cleaning up of asynchronous 
tasks, and to auto-close prompts.  

Syntax 

String Object.Option("[option name]") = true | false 

Parameters 

"ThrowError" (defaults to True) - TE COM will call AtlReportError (showing a 
VB runtime error message box) on 
connection/transfer/IO/other error which will terminate script 
execution. If set to False, then if some transfer method fails the 
script will continue to the next command. 

"AutoRename" (defaults to False) - The same as the AutoRename property. 
"CleanupAsync" (defaults to True) - All task IDs accumulated by previous Async 

methods will be lost. If set to False, all task IDs will be added to 
the ones created by previous Async methods. 

"InvalidateCache" (defaults to True) - Remove cached file (containing listings) 
before uploading, downloading, renaming or deleting files. If 
false, then don't remove cached listing. You can obtain the 
specific file information when needed by using one of the file 
property methods. InvalidateCache optimizes LIST traffic. 

"FilterDirs" (defaults to True) - Apply filters to folder names. If set to False, 
then don't apply. 

“AutoCloseMethod” (default to 0)  1 - auto accept, 2 - auto reject, 0 – Don't accept 
(default). This handles hidden prompts (such as SSL Accept Cert 
Prompt when running a script while not logged in). 
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“AutoCloseDelay” (default value is 60 seconds). Time delay before CuteFTP should 
perform the action specified by the AutoCloseMethod option. 

Example 1 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftp://ftp.cuteftp.com" 
MySite.Option("FilterDirs")=False          'don't filter 
folder names 
MySite.LocalFilterExclude= "TDImon; *.txt; *.vbs" 
                                           'now set the 
item names to exclude MySite.Upload "c:\test"  
                                           'uploads all 
of test including sub dirs. 
                                           'Even sub dirs 
that match the filter, such as TDIMon.  
                                           'If I had left 
FilterDirs=True, then the folter  
                                           'TDImond would 
not have been uploaded. 

Example 2 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftp://ftp.somestrangedomain.com" 
MySite.Option("ThrowError") = false 
if not CBool(MySite.Connect) then 
  MsgBox "Error : " & MySite.ErrorDescription 
end if 

Example 3 

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
MySite.Host = "ftps://ftp.asecuredomain.com" 
MySite.Option("AutoCloseMethod") = 1  'will auto accept 
cert and continue 
MySite.Option("AutoCloseDelay") = 5   'wait 5 seconds 
before accepting 
MySite.Connect                        'now connect to the 
secure site. The TE will accept the server’s SSL cert 
after 5 seconds and continue executing the rest of the 
script. 

READ-ONLY PROPERTIES 

Checking for a connection  
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Description  

Use the IsConnected property to indicate whether or not you are presently connected to 
the remote site.  
 

Syntax  

Boolean Object.IsConnected  

Parameters 

"True" 
The Transfer Engine is currently connected to 
the server. 

"False" 
The Transfer Engine is not currently 
connected to the server. 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
If Cbool(MySite.IsConnected) Then  
MsgBox "Connected to server:" + MySite.Host  
End if    

Note: 
You can set how long the Transfer Engine will leave the data connection 
open after a completed transfer. In the CuteFTP GUI, go to Tools > 
Global Options > Transfer Settings and set the time in Close the file 
transfer n seconds after the transfer is completed.  

 

Retrieving the number of Asynchronous tasks  
Description  

Use the AsyncTaskNumber property to return the number of tasks created by the 
UploadAsync, DownloadAsync and TransferURLAsync methods.  

Syntax  

Long Object.AsyncTaskNumber  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection") 
‘Initialize all necessary fields for MySite : host name, 
user, password, 
etc. 
MySite.Option("CleanupAsync") = False 
MySite.DownloadAsync "/path/*.*" 
MsgBox "task number created" & MySite.AsyncTaskNumber 
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Note: 
You must set MySite.Option("CleanupAsync") = False so that all 
asynchronous tasks are counted. Otherwise, only the last asynchronous 
task launched will be referenced when calling the AsyncTaskNumber 
property.   

Checking if a server supports multi-part uploads 
Description  

Use the CombSupport property to check if the server supports the COMB (multi-part 
upload) command.  

Syntax  

Boolean Object.CombSupport  
 

Return values  

-1 Server supports COMB 

0  Server does not support 
COMB  

Example 

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
If (not MySite.CombSupport) Then  
MsgBox "This server doesn't support the COMB command!"  
End if  

Retrieving error descriptions  
Description  

Use the ErrorDescription property to get the string describing the last error condition. It 
may consist of some messages taken from the transfer log.  

Syntax  

String Object.ErrorDescription (long taskIdx)  

Parameter  

TaskIdx 

This is a task index in the array of tasks created by the various 
asynchronous methods. The default value of taskIdx is - 1 
which specifies all the asynchronous tasks in array.  
TaskIdx should be between 0 and AsyncTaskNumber minus 
one.  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
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MySite.Option("ThrowError") = false ‘disable ATL 
exceptions  
if cbool(MySite.Connect) then  
MsgBox "Connected OK"  
else  
MsgBox "Error! " & MySite.ErrorDescription  

Retrieving the server's home directory 
Description 

Use the HomeDir property to return a string value containing the name of the server’s 
home directory.  

Syntax  

String Object.HomeDir  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
MsgBox "Home dir for server " + MySite.Host + " is: " + 
MySite.HomeDir  

Checking if a transfer is active 
Description  

Use the IsPending property to determine whether a transfer is active or if it is already 
finished with success or error. This can be useful in combination with async commands or 
during an interactive script. The IsPending property will return a value of either true or 
false.  

Syntax  

Boolean Object.IsPending(long taskIdx)  
   

Parameter 

TaskIdx  

This is a task index in the array of tasks created by the various 
asynchronous methods.  [0.. AsyncTaskNumber minus one, or - 1 
(last asynchronous task started)] 
This has a default value (if nothing is specified) of ALL tasks. 
Therefore, IsPending will return true if any task is still pending. It 
will return false if none are pending.  

Example 1 

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
'Regular connection code here:  
MySite.Download inbound/*.*", "c:\temp"  
If CBool(MySite.IsPending) Then  
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MsgBox "task is in working state" + MySite.Host  
End if    

Example 2  

Here is another example that checks an asynchronous transfer and will return various 
transfer progress properties of each transfer while IsPending is true.  
 

Warning:  
If you copy and paste this code, be aware that line breaks may 
be inserted into the code.  

   
Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Protocol = "FTP"  
MySite.Port = "21"  
MySite.Host = "ftp.url"  
MySite.login = "loginname"  
MySite.Password = "your pass"  
MySite.Connect  
MySite.Option("CleanupAsync") = False 
' line break  
strNL = (Chr(13) & Chr(10))  
MySite.MaxConnections = 3  
MySite.Option("ThrowError") = false  
MySite.DownloadAsync "inbound/*.*", "c:\temp"  
bContinue = true  
while CBool(MySite.IsPending) and bContinue  
str = "LOOP, Total: " & MySite.AsyncTaskNumber & strNL  
for i = 0 to MySite.AsyncTaskNumber - 1 step 1  
str = str & i & ": size: " & MySite.TransferredSize(i) & 
", speed: " & MySite.Speed(i) & ", time left: " & 
MySite.TimeLeft(i) & ", status: " & MySite.Status(i) & 
strNL  
next  
str = str & "YES - continue loop, NO - stop tasks, CANCEL 
- exit loop"  
nUserChoise = MsgBox(str, vbYesNocancel) 'press YES many 
time to see transfer progresses  
if nUserChoise = vbCancel then  
bContinue = false  
elseif nUserChoise = vbNO then  
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MySite.AbortAsync 'abort all tasks  
bContinue = false  
end if  
wend  
str = "DONE, Total: " & MySite.AsyncTaskNumber & strNL  
for i = 0 to MySite.AsyncTaskNumber - 1 step 1  
str = str & i & ": size: " & MySite.TransferredSize(i) & 
", speed: " & MySite.Speed(i) & ", time left: " & 
MySite.TimeLeft(i) & ", status: " & MySite.Status(i) & 
strNL  
next  
MsgBox str  

Retrieving the status of a transfer  
Description  

Use the Status property to determine whether a transfer is active or it is already finished 
with success or error. This can be useful in combination with asynchronous commands or 
during an interactive script.  The Status property will return a string.  

Syntax  

String Object.Status (long taskIdx)  

Parameters 

TaskIdx 
This is the task index in the array of tasks created 
by asynchronous methods [0.. 
AsyncTaskNumber or - 1 (last started)]  

 

Return Values 

"WAIT" 
Transfer action invoked but not 
initiated yet (followed by connecting) 

"CANCELED" Active transfer canceled by user 

"FINISHED" Transfer completed 

"ERROR" 
Error in transfer (any possible client 
or server error) 

"SUSPENDED" 
Added to queue but no transfer 
initiated yet 

"SCHEDULED" Item is scheduled for future transfer 

"BLOCKED" 
An internal status used for navigation 
and does not pertain to active or 
pending transfers.  You can cancel 
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any transfer requests in BLOCKED 
status without any ill effects. 

"CHILDWAIT" 
Condition when transfer item is 
waiting for a dependant item to finish 
transferring (*) 

"SKIPPED" 
Transfer skipped by user or 
automatically per overwrite rules 

"CONNECTING" 
Connecting to server (status right 
after WAIT) 

"CANCELLING" 
Cancel initiated but not completely 
stopped yet 

"WORKING" 

After connecting but before 
transferring. Could be opening data 
connection, or setting REST params, 
etc. 

"TRANSFERRING" File transfer in progress 

"UNKNOWN" 
Another string was returned other 
than one of the above.  The string 
was unrecognized.  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
If not CBool(MySite.IsPending) Then  
MsgBox "Task done, final status is " + MySite.Status  
End if  

Checking if a server can resume downloads  
Description  

Use the RestSupport property to check if the server supports the REST (resume download) 
command.  

Syntax  

Boolean Object.RestSupport  

Return values  

-1 Server supports REST.  

0 
Server does not support 
REST. 

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
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‘Initialize all necessary fields for MySite : host name, 
user, password, etc.  
If (not cbool(MySite.RestSupport)) Then  
MsgBox "This server doesn't support the REST command"  
End if  

Retrieving a log as a string  
Description  

Use the Log property to return the entire log as a string which can be handled separately in 
your VB application or VB script.  

Syntax  

String Object.Log (long taskIdx)  

Parameters 

TaskIdx 

This is the task index in the array of tasks created by asynchronous 
methods [0.. AsyncTaskNumber minus one, or - 1 (last asynchronous 
task started)] 
It has a default value of -1 = current task.  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Host = "ftp://ftp.cuteftp.com"  
MySite.Connect  
MsgBox MySite.Log  

Checking transfer progress 
Description  

Use the TotalSize, TransferredSize, Speed, TimeLeft, and TimeElapsed properties to 
determine a transfer's progress and various other aspects of the transfer.  

Syntax  

long Object.TotalSize (long taskIdx) = size in bytes  
long Object.TransferredSize (long taskIdx) = size in 
bytes  
long Object.Speed (long taskIdx) = bytes/second  
long Object.TimeLeft (long taskIdx) = seconds  
long Object.TimeElapsed (long taskIdx) =seconds  

Parameters 

TaskIdx 

This is the task index in the array of tasks created by asynchronous 
methods [0.. AsyncTaskNumber minus one, or - 1 (last asynchronous 
task started)] 
It has a default value of - 1 = current task.  
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Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite.Host = host 'set all relavant host, login, pass, 
etc. properties  
MySite.Download "aaa", "c:\temp"  
MsgBox "Size: " & MySite.TotalSize & ", speed: " & 
MySite.Speed & ", time: " & MySite.TimeElapsed  

Retrieving file information 
Description  

Use the FileType, FileSize, and FileTimeModified properties to retrieve information 
about a particular item.  

Syntax  

long Object.FileType  
long Object.FileSize  
string Object.FileTimeModified  

Return values  

For FileType: 

1 Directory 

2 File 

3 Link 

For FileSize: 
the size in bytes of the file  
 
For FileTimeModfied: 
mm/dd/yyyy hh:mm:ss 

Example  

Set fserv = CreateObject("CuteFTPPro.TEConnection")  
strRemote = "somefilename.ext"  
if cbool(fserv.RemoteExists(strRemote)) then  
MsgBox "Remote file/folder info: Type=" & fserv.FileType 
& ", Size=" & fserv.fileSize & ", Date=" & 
fserv.FileTimeModified & strNL & "(type:1-dir,2-file,3-
link)"  
else  
MsgBox "Error! " & fserv.ErrorDescription  
End If  
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FILTER PROPERTIES 

Including local files in lists and transfers  
Description  

Use the LocalFilterInclude property to set or retrieve the values for including local files or 
folders in transfers and listings. The string values may contain wildcards and you can add 
multiple filters by separating them with a semicolon ";".  

Syntax  

String Object.LocalFilterInclude  

Example  

MySite.LocalFilterInclude = "*.jpg;*.gif"  
 

Note: 
If filter causes no file to be transferred then no folders will be created. 

Excluding local files from lists and transfers  
Description  

Use the LocalFilterExclude property to set and retrieve the values for excluding local files 
or folders from transfers and listings. The string values may contain wildcards and you can 
add multiple filters by separating them with a semicolon.  
Syntax  

String Object.LocalFilterExclude  

Example  

MySite.LocalFilterExclude = "*.mp3;*.jpg"  
 

Note: 
If filter causes no file to be transferred then no folders will be created. 

Excluding remote files from lists and transfers 
Description 

Use the RemoteFilterExclude property to set and retrieve the values for excluding remote 
files or folders from transfers and listings. The string values may contain wildcards and you 
can add multiple filters by separating them with a semicolon.  
Syntax  

String Object.RemoteFilterExclude  

Example 

MySite.RemoteFilterExclude = "*.txt;*.swp"  
MySite.Download "*.*" ‘ will download all files except 
those with extensions of *.txt and *.swp  
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Note: 
If filter causes no file to be transferred then no folders will be created. 

Including remote files in lists and transfers 
Description  

Use the RemoteFilterInclude property to set or retrieve the values used to include remote 
files or folders in transfers and listings. The string values may contain wildcards and you can 
add multiple filters by separating them with a semicolon ";".  

Syntax  

String Object.RemoteFilterInclude  

Example  

MySite.RemoteFilterInlcude = "*.jpg;*.gif"  

Note: 
If filter causes no file to be transferred then no folders will be created. 

Adding filters to the LIST command 
Description  

Use the RemoteSiteFilter property to specify a string which will be used as a filter 
parameter by the LIST command.  

Syntax  

string Object. RemoteSiteFilter  

Example  

Set MySite = CreateObject("CuteFTPPro.TEConnection")  
MySite. RemoteSiteFilter = "-l"  
'This will send a "List -l" command to the server.  

Configuration Notes 

These optional parameters to the list command are basically parameters passed to the UNIX 
ls program running on the server (if applicable):  

-l  long listing  

-
a  

show hidden 
files  

-t 
sort by 
timestamp  

-
R 

recursive  

There are various additional parameters. Refer to a UNIX manual or the Web for 
more details. You may want to check http://www.bsdi.com/bsdi-man.  
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Troubleshooting 

DISABLING PROMPTS 

To run the Transfer Engine with prompts disabled 
Launch the TE manually and supply the –noprompts parameter.  

Example  
1. From theWindows Start menu, choose Run.  
2. Enter: "C:\Program Files\Globalscape\CuteFTP 

Professional\TE\ftpte.exe" –noprompts.  
3. Select OK. 

 

Warning: 
Suppressing prompts may cause lockups if no default action is available 
for the event in question, or if the prompt was produced by an error. 
When running the TE in this mode using Windows scheduler from a 
different user account, the TE will not be accessible from its COM or 
GUI interface and can only be unloaded via the Task Manager.  
The best way to avoid prompts is to properly configure the TE ahead of 
time to cover all possible prompt scenarios, such as overwrite conditions, 
or SSL server certificate acceptance dialogs. For example, set your 
overwrite actions under CuteFTP's global settings to Always Overwrite 
to avoid any overwrite prompts, or pre-define various rules to cover 
various overwrite scenarios.  You can then export those rules as registry 
entries and import them onto the target machine. 
You can also tell the TE to auto-accept SSL or SSH certificates using the 
AutoCloseMethod parameter of the Option method. Also refer to the 
following trouble shooting topic regarding running the TE while not 
logged in. 

HIGH MEMORY USAGE WHEN USING THE TRANSFER ENGINE 

If you leave the Transfer Engine running for extended lengths of time, it may begin to 
consume large amounts of memory.  Set the CuteFTP Professional Transfer Engine to 
remove successful items from the queue to avoid this problem.  

To remove successful items from the queue in a script 
Use the TECommand method with the DELETEFINISHED or DELETEALL 
parameter. 

• 
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SETTING THE TE TO RUN WITHOUT A USER PRESENT 

The Transfer Engine is a process, not a service. However, you can execute scripts while the 
system is not logged in if you properly configure Windows DCOM configuration for the 
Transfer Engine. Carefully read and follow the steps below. A sample script is provided. 

To configure the TE under the DCOM configuration applet 
1. Frpm Windows, choose Start > Run. 
3. Enter DCOMCNFG and select OK. 
4. Select TE from the list. 
5. Select Properties. 
6. Select the Identity tab.  
7. You must select This user: and provide a valid login name and password. It must be the 
same user as established under your task scheduler's run as property (if applicable), so that the 
scheduler service can call the COM object as a user. This will enable the Transfer Engine to 
run with the user settings, and if necessary, access pre-established SSL certificates (for secure 
connections). 

 
Screenshot of Identity tab 

Configuration notes 
• If the system is currently logged in when the TE is run, it runs as the user which you 

specified under DCOMCNFG. You will not see the TE icon in the system tray when 
running CuteFTP's main interface. Also, the hard coded user's settings are employed 
when the TE is run, not those of the currently logged in user.  This is not an issue if 
you are running the TE while the system is not logged in. 
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• You should test your script from the command line while logged in. You can also 
write to the event viewer or a local text file to debug a script when run on system 
startup if necessary. Here is a sample script which includes event viewer logging of 
transactions. 

• Your script should not contain Message Box functions or any other function that 
requires user input or shows a window. Windows cannot display these prompts while 
the system is not logged in. Set your overwrite actions under CuteFTP’s global 
options to “Always Overwrite” to avoid any overwrite prompts, or pre-define 
various rules to cover various overwrite scenarios. 

 
Const EVENT_SUCCESS = 0  
Set objShell = Wscript.CreateObject("Wscript.Shell")  
objShell.LogEvent EVENT_SUCCESS,"AT Loaded me"  
Set MySite= CreateObject("CuteFTPPro.TEConnection")  
MySite.Option ("ThrowError") = False  
MySite.Host = 
"ftp://anonymous:user@user.com@ftp.globalscape.com/pub
/cuteftp"  
objShell.LogEvent EVENT_SUCCESS,"vars set"  
MySite.Connect  
objShell.LogEvent EVENT_SUCCESS, "connected"  
MySite.Download "index.txt", "c:\temp"  
objShell.LogEvent EVENT_SUCCESS, "downloaded"  
MySite.Disconnect  
MySite.Close  
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The 

AU  

To automatically encrypt and compress files before transfer, you will need both CuteZIP and 
CuteFTP Professional. You can also compress and encrypt files after transferring them by 
usin rver's Custom Site Commands. The benefits of 
encrypting files prior or post transfer depends on the circumstances and level of trust for the 
par
 
In t
enc g Twofish 128 bit encryption) and then transferred via regular FTP to an 

TP server. Since the archived file is encrypted, there is no need to connect using SSL, OTP, 
or SSH2 unless you wished to also protect the login process. 

Exam
Di
Set WshShell = CreateObject("WScript.Shell") 'Window's 
Scripting Host shell object 
'next line calls the run method of the WSH shell object. 

 thing. 
'The complete command line instructions for CuteZIP are 

lobal~1\CuteZIP\cutezip.exe -c -p12345 
c:\archive c:\temp", 0, true) Then 
  Set MySite = CreateObject("CuteFTPPro.TEConnection") 

Event View Application Log showing a successful download. 

TOMATICALLY ENCRYPTING AND COMPRESSING TRANSFERS

g GlobalSCAPE Secure FTP Se

ticular host. 

he example
rypted (usin

 script below, an entire folder (including sub-folders) is compressed, 

F

ple 
m WshShell, MySite, Return 

It returns true once CuteZIP does its

located here. 
If Return = WshShell.run 
("c:\progra~1\g
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  MySite.Option ("ThrowError") = True 
  MySite.Host = "ftp://user:pass@myftpsite.com" 'one of 
the ways to connect using the TE 

, 

 
  MsgBox "Failed to Upload, Exiting!" 

 

 

  MySite.Connect 
  MySite.Upload "c:\archive.zip" 'upload the new archive
then check to see if it made it up to the server. 
  if not CBool(MySite.RemoteExists("\archive.zip")) then
   
  Else 
     MsgBox "Success!" 
  End If 

nect  MySite.Discon
  MySite.Close 
Else 
MsgBox "Compression and Encryption Failed, Exiting!" 
End If 

Note: 
You can optionally protect the FTP login by connecting with SSL, SSH2 
or OTP using CuteFTP Professional's Transfer Engine (GlobalSCAPE's 
Secure FTP Server 2 supports SSL, OTP, and SSH2 logins). Use the 
protocol property to set the connection type prior to calling MySite.Host 
and MySite.Connect. 

R

You can use SGL function sp_OACreate to create a TEConnection object. SQL runs ftpte 
a ch cannot prompt for 
u
Specify a local download path or filename. While 
it
permissions to allow the T
F used account for scheduled TE tasks. 
O nother instance cannot be created. 
Windows treats the logged-in user differently than the logged-out-user and DCOM errors 

a recurring background process has already run before the user 
logs in, once the user logs in and the b
o u

Example t
DE
DE

UNNING THE TRANSFER ENGINE FROM AN SQL JOB 

nd hides all windows. SQL uses a special instance of ftpte exe, whi
ser name and password.  

optional, it's a good idea to make sure that 
 is going where you intend. Also, make sure that the local path has the appropriate NTFS 

E to have full control. 
or scripted or scheduled tasks use an otherwise un
nce the CuteFTP TE (transfer engine) is started, a

may occur. For instance, if 
ackground process starts again, a DCOM error will 

cc r. 

ransfer script 
CLARE @property varchar(255) 
CLARE @object int 
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DE
DE
PR
EX
OU
EXEC @hr = sp_OASetProperty @object, 'Host', 

.mysite.com' 
EXEC @hr = sp_OAGetProperty @object, 'Host', @property OUT 
PR
EX
OU
PRINT @property 

col', @property 

, 

= sp_OAGetProperty @object, 'Log', @property OUT 

PR

Co
• ot use an already running instance of ftpte exe. The CuteFTP GUI cannot 

• ll be 

X while user X is *not* logged in, the profile path will be 

 

essional\certs.crt 

xy information. Please see Connecting 
through a SOCKS or Proxy Server for more information.  

it gets.  

CLARE @hr int 
CLARE @src varchar(255), @desc varchar(255) 
INT '---start' 
EC @hr = sp_OACreate 'CuteFTPPro.TEConnection', @object 
T 

'ftp

INT @property 
EC @hr = sp_OAGetProperty @object, 'Login', @property 
T 

EXEC @hr = sp_OAGetProperty @object, 'Proto
OUT 
PRINT @property 
EXEC @hr = sp_OAMethod @object, 'Connect' 
EXEC @hr = sp_OAMethod @object, 'download', NULL, '/pub'
"e:/eee" 
EXEC @hr 
PRINT @property 
EXEC @hr = sp_OADestroy @object 
INT '---finish' 

nfiguration Notes 
SQL cann
communicate with an ftpte instance created by SQL.    

When a scheduled task runs as user X while user X is logged in, the profile path wi
set to that user's directory (C:\Documents and Settings\X\). However, when a 
scheduled task runs as user 
set to the default user directory (C:\Documents and Settings\Default User\). 
Therefore, the desired SSL certificates from C:\Documents and 
Settings\X\Application Data\GlobalSCAPE\CuteFTP Professional\certs.crt should
be copied to C:\Documents and Settings\Default User\Application 
Data\GlobalSCAPE\CuteFTP Prof

• If you use UseProxy, be sure to specify any pro

Tips 
• Add a couple of log lines so that it can write to the log whenever something happens 

successfully. Add it after the connect line, so that you can see how far 
• To make sure you are connecting long enough to get data, use the GetList method to 

write a list to a local file. 

233 



CuteFTP Professional User's Guide 

NO TIMEOUT WHEN CONNECTING TO AN UNAVAILABLE HOST 

If the Transfer Engine's Connection method refuses to timeout when connecting to a non-
existing or temporarily unavailable host, try setting the throw err
me
Becaus
stateme

: 
A f

60
Se
for script can continue its processing: 
My
ce
MySite.Option("AutoCloseMethod") = 2 will auto reject 

and finish with error 
Site.Option("AutoCloseMethod") = 0 default: will not 

 is 

just 
s is probably enough time for even the slowest transfer. 

l 
SPENDED, 

or BLOCKED." 
n also write scripts so that they check the condition of a transfer and if it is still in the 

eout value in the script call - Because the first parameter to 
 a "-1" which means "current 

 60 * 60 * 1000 = 

Examp

  
 

or to true.  The Connection 
thod does not have a built-in timeout value. It will keep trying to connect indefinitely. 

e the event is synchronous, subsequent lines in the script, including conditional 
nts for determining the connection status of the TE, never get called.  

Examples
ew possible workarounds, and help for accepting and rejecting certificates: 
MySite.Option("AutoCloseMethod") = 2 '1 - auto accept, 2 
- auto reject, 0 - default no auto 
MySite.Option("AutoCloseDelay") = 12 ' default value is 
 sec 
t Option("AutoCloseMethod") property to 1 or 2 in order 

Site.Option("AutoCloseMethod") = 1 will auto accept 
rt and continue 

cert 
My
close prompt on timeout 

TIMEOUT STRATEGIES FOR THE WAIT METHOD 

The default timeout value for the Wait method is 21,805,184 milliseconds, which
approximately 6 hours. The timeout value is a SIGNED LONG data type, meaning its 
maximum possible value is 2,147,483,647 milliseconds, which is roughly 596.5 hours or 
under 25 days.  Thi
The Wait method supports a "0" timeout value which means "keep waiting forever or unti
the transfer reaches a state of CANCELED, FINISHED, ERROR, SU
SKIPPED, 
You ca
"TRANSFERRING" state, to wait on it again. 

Three timeout strategies for long transfer tasks 
1.  Specify a large tim

the Wait method is a task index, this example uses
task."  For this example, the timeout is set for 10 hours or, 10 *
36000000 milliseconds. 

le 

   strResult = strataFTP.Wait( -1, 36000000 ) 
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2.  After a Wait() function has timed out, check the
this scenario, use the program (or script) logic to keep trying after a 

 STATUS of the transfer - In 
Wait times out 
ords, your polling 

        ( strResult <> "ERROR" ) and ( strResult <> 
"SKI
        ( strResult <> "SUSPENDED" ) and ( strResult <> 
"BLOCKED" ) 

positive outlook of continuing on while the transfer 
task is either WORKING, CONNECTING, or TRANSFERRING: 

Exa p

   Do 
    
   Loop While ( strResult = "TRANSFERRING") or ( strResult 
= "WO
    
 

3. tion point. Most transfers 
eventually either FINISH or receive an error from the server; but there is a minor 

state. This strategy might be considered a little riskier than the first two: 

D IN 

C) 

e in a specific user's folder, like: C:\Documents and 
ettings\jsmith\Application Data\GlobalSCAPE\CuteFTP 
Pro

when the transfer is still in the TRANSFERRING state. In other w
for the termination status has timed out, but not necessarily the transfer itself, so you 
keep going. 
In the following example, you wait up to 10 hours for the transfer, and if that times 

o it out, you check the status of the transfer. If it is still TRANSFERRING, you d
again (please note the last two conditional statements): 

Example 

   Do 
     strResult = strataFTP.Wait( -1, 36000000 ) 
   Loop While ( strResult <> "CANCELED") and ( strResult <> 
"FINISHED" ) and 

PPED" ) and 

 Alternatively, you can take the more 

m le  

 strResult = strataFTP.Wait( -1, 36000000 ) 

RKING" ) or 
    ( strResult = "CONNECTING" ) 

Wait forever, or until the transfer reaches some termina

chance that the transfer in the queue is perpetually stuck in a "TRANSFERRING" 

Example 

     strResult = strataFTP.Wait( -1, 0 ) 

MY SCHEDULED SCRIPTS NO LONGER RUN WHILE NOT LOGGE

If you have installed the Security Update for Microsoft Data Access Components (MDA
Security Patch MS03-033 you may have problems using scripts to connect to secure sites.  
You can get your scripts to work again by moving your certificate file. The CuteFTP 
certificate files generally resid
S

fessional\Security\certs.crt. 
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Move t
Settings\Default User\Application Data\GlobalSCAPE\CuteFTP 
Professional\Security\certs.crt, and your scripts should now work. 

he certs.crt file to the Default User Folder. For example; C:\Documents and 

Note: 
The file name for Security Patch MS03-033 is 
Q823718_MDAC_SecurityPatch.exe. 

SCR T

• D odate 
w other than what is 
a

•  action manually, 
 

when 
the GUI, then the problem is not with CuteFTP or the FTP Server.  The next 

troubleshoot your script line by line.   

 FTP server over SSL (via scripting) involves several 

You
server a

Serve
Mos
certifica
the clie
whe r
 

1. E istrator. 
erface) from the 

ertificate. You can then export 

ory of your choice.  
2. P y. For 

e

3. If you will also be running the TE while logged in, place a copy of the server 
c

IP ING TECHNICAL SUPPORT 

ue to the wide range of scripts that CuteFTP Professional is able to accomm
e are unable to offer technical support on individual scripts, 

vailable in the help files and online Knowledge Base.  
If you are having trouble with your script, try to perform the desired
using the CuteFTP GUI.  If you cannot, then troubleshoot that problem first and
then re-try your script.   

• If you are able to perform the desired actions, and in the desired sequence 
using 
thing to do is to 

HANDLING SSL CERTIFICATES (WHEN RUNNING A SCRIPT WHILE NOT LOGGED IN) 

Setting up the TE to connect to an
steps. Follow the instructions below carefully. 

 must know whether the TE will require the use of server certificates only, or both 
nd client certificates. 

r Certificates 
t FTP SSL servers will provide a certificate to the client during authentication. The 

te proves the server's legitimacy to the client. The server’s certificate must be added 
nt’s Trusted Certificate store prior to any connection, otherwise the TE will lock up 
ying to authenticate. n t

xport or obtain a copy of the server’s certificate from the FTP server admin
therwise connect to the server with the CuteFTP GUI (intO

developer machine and manually accept the server’s c
it from the Trusted List under Global Options > Security > SSL Security to a 
staging direct

lace/Install the certificate into the target machine’s Default User director
xample: 
C:\Documents and Settings\Default User\Application 
Data\GlobalSCAPE\CuteFTP Pro\Security 

ertificate under the USER folder on the target machine, as follows: 
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C:\Documents and Settings\[USERNAME]\
Data\GlobalSCAPE\CuteFTP Pro\Securi
- where [USERNAME] is the login name for the user. 

Application 
ty  

4. C s using the 
A
t

Now when you connect, the TE sees the server’s certificate and proceed with the 
connecti

Client 
Some FT The certificate proves the 
veracity rious FTP clients 
masquer

To setup the target system to use client certificates 

1
s 

gs > Security > SSL dialog. 

server with the CuteFTP GUI (interface) from the developer machine. On the 
r, move the certificate from the Pending to the Trusted list. If your server only 

APE\CuteFTP Pro\Security 
- where [USERNAME] is the login name for the user. 

4. If you created the certificate set on the developer machine, export the following 
r

5. I  
n

P 

ME]\\Application 
t.crt" 

\Documents and 
\\Application 

APE\\CuteFTP Pro\\Security\\client.key" 
"UseSSLCertificate"=dword:00000001 
"UseSSLCertPassphrase"=dword:00000001 
"ReuseSSLData"=dword:00000000 

onfigurel the TE to auto-accept SSL or SSH certificate
utoCloseMethod parameter of the Option method. Also refer to the following 

rouble shooting topic regarding running the TE while not logged in. 

on.  

Certificates 
P SSL servers require that the client provide a certificate. 

of the client and is an important factor in weeding out spu
ading as legitimate ones. 

. On the developer machine, create the client certificate and private key pair using the 
CuteFTP GUI (interface). The certificate creation utility is located under the Tool
> Global Settin

2. Add the client certificate to the server’s trusted list. Do this by connecting to the 

serve
has a Trusted list, manually import the client certificate into the Trusted list. 

3. Place the client certificate and private key into the target machine’s USER folder: 
C:\Documents and Settings\[USERNAME]\Application 
Data\GlobalSC

egistry key: 
HKEY_CURRENT_USER\Software\GlobalSCAPE\CuteFTP 
Professional\Settings\SecuritySSL 
mport the registry key from step 4 onto the target machine, or manually create the
ecessary entries. The entries are shown in standard .reg file notation. 
REGEDIT4 
[HKEY_CURRENT_USER\Software\GlobalSCAPE\CuteFT
Pro\Settings\SecuritySSL] 
"SSLCertificate"="C:\\Documents and 
Settings\\[USERNA
Data\\GlobalSCAPE\\CuteFTP Pro\\Security\\clien
"SSLPrivateKey"="C:\

ERNAME]Settings\\[US
Data\\GlobalSC
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"WarnWhenToNonSecure"=dword:00000001 
"DataTransportMethod"=dword:00000001 
"SSLCertPassphrase"="[PASSWORD]" 

 
- Where [USERNAME] is the login name for the target system and where 
[PASSWORD] is the encrypted password exported from the source machine. Don't 
modify the password! 

At the next connection, the TE finds the client certificate and uses it to authenticate with the 
server. 

Example 
Here is a sample script that connects to a fictitious site running SSL Implicit over port 990. 
It also writes to the event log for debugging purposes. if you use this script to test your 
setup, make sure you modify the MySite.Host line to include your actual FTP SSL server 
host and login information. 
 

#file test.vbs 
Const EVENT_SUCCESS = 0  
Set objShell = Wscript.CreateObject("Wscript.Shell")  
objShell.LogEvent EVENT_SUCCESS,"AT Loaded me"  
Set MySite= CreateObject("CuteFTPPro.TEConnection")  
MySite.Option ("ThrowError") = True  
MySite.Host = 
"ftp://myuser:mypass@ftp.mysslserver.com:990 
objShell.LogEvent EVENT_SUCCESS,"vars set"  
MySite.Connect  
objShell.LogEvent EVENT_SUCCESS, "connected"  
MySite.Disconnect  
MySite.Close 
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Error Resolution 

USING ERROR MESSAGES TO TROUBLESHOOT 

You can help resolve errors by recording information from error messages. A standard error 
dialog box includes a short error message and two buttons, Cancel and Details. Click 
Cancel to dismiss the error dialog box. Click Details to expand the error dialog to show 
more information.  

To use an error message to troubleshoot   
1. Record the error message and what occurred previous to the error. 
2. Click the Details button. 
3. Right-click in the log text area. 
4. 

5. 

Choose Copy All Text. The entire contents of the error log window will be copied 
to the clipboard.  
Paste this information into an email asking for help, and send it to your IS 
department, or paste it directly into the Description field at the GlobalSCAPE tech 
support email page to ask for help from GlobalSCAPE's tech support staff. 

FTP STATUS AND ERROR NUMBERS 

CuteFTP displays FTP status codes in the log window. The codes are numbered according 
to their category. Some codes represent errors, while most codes simply communicate the 
status of the connection. Here are brief explanations for the most common status and error 
codes: 
Code Description 

100 Series  The requested action is being initiated, expect another reply before 
proceeding with a new command. 

110 Restart marker reply. 
120 Service ready in nn minutes. 
125  Data Connection already open, transfer starting. 
150 File status okay, about to open data connection. 
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Code Description 

200 Series The requested action has been successfully completed. 

200 Command okay. 
202  Command not implemented, superfluous at this site. 
211  System status, or system help reply. 
212 Directory status. 
213 File status. 
214 Help message. 
215 NAME system type. (Where NAME is an official system name from the 

list in the Assigned Numbers document.) 
220  Service ready for new user. 
221  Service closing control connection. Logged out if appropriate. 
225 Data connection open; no transfer in progress. 
226 Closing data connection. Requested file action successful (for example; 

file transfer or file abort). 
227  Entering Passive Mode. 
230 User logged in, proceed. 
250  Requested file action okay, completed. 
257 "PATHNAME" created. 
  
300 Series  The command has been accepted, but the requested action is on 

hold, pending receipt of further information. 

331  User name okay, need password. 
332  Need account for login. 
350  Requested file action pending further information. 
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Code Description 

400 Series  The command was not accepted and the requested action did not 
take place, but the error condition is temporary and the action may 
be requested again. 

421 Error 421 Service not available, closing control connection.  
Error 421 User limit reached 
Error 421 You are not authorized to make the connection 
Error 421 Max connections reached 
Error 421 Max connections exceeded 
 
Possible Solutions 

 
You can receive that 421 error if the FTP server you are connected to 
limits the total number of connections available or limits the connections 
available to one user.  There are three things you can do: 
 

1. Limit the number of connections to any one FTP site by selecting 
Tools > Global Options > Connection and set "Per site max 
connections /transfers" to 1 (By default it will be set to 2). 

2. Remove items from the Transfer Queue.  The Transfer Queue is 
where you see items ready for transfer, in transit, or just 
transferred.  Sometimes the Queue Pane can become cluttered 
with unfinished transfers.  To clear the queue, right-click inside it 
and choose Remove All. 

3. Make sure only one instance of CuteFTP is running on your 
system.  Open the Windows Task Manager and see if CuteFTP is 
listed more than once. 

425  Can't open data connection.  Try changing from PASV to PORT mode. Check 
your firewall settings. Try making an HTTP connection. 

426 Connection closed; transfer aborted. 
450  Requested file action not taken. File unavailable (e.g., file busy). 
451 Requested action aborted: local error in processing. 
452 Requested action not taken. Insufficient storage space in system. 
  
500 Series  The command was not accepted and the requested action did not 

take place. 

501  Syntax error in parameters or arguments. 
502  Command not implemented. The server does not support this command.
503 Bad sequence of commands. 
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Code Description 

504  Command not implemented for that parameter. 
530 Not logged in.  Your password is being rejected, contact the server administrator. 
532  Need account for storing files. 
550  Requested action not taken. File unavailable (e.g., file not found, no 

access).  Contact the server administrator. 
552 Requested file action aborted. Exceeded storage allocation (for current 

directory or data set). Contact the server administrator. 
553  Requested action not taken. File name not allowed.  Try changing the file 

name, or getting rid of spaces in the file name. 
  
10,000 series Winsock error codes 

10054 Connection reset by peer. The connection was forcibly closed by the 
remote host.  

10060 Can't connect to remote server (Generally a time-out error).  Try switching 
from PASV to PORT mode, or try increasing the time-out value (See Reconnect and 
resume in Transfer settings). 

10061 Can't connect to remote server. The connection is actively refused by the 
server.  Try switching the connection port. 

10066 Directory not empty. The server will not delete this directory while there 
are files/folders in it. 

10068 Too many users, server is full. Try connecting later. If the problem persists, 
Contact the server administrator. 

CANNOT CLOSE DATA TRANSFER GRACEFULLY 

If the error message "Cannot close data transfer gracefully" is generated after a download is 
complete, it indicates that CuteFTP has received all the data it needs, but the server is still 
sending information. Since that data is still transmitting, CuteFTP forces the connection to 
close.  

CANNOT INITIATE DATA TRANSFER 

If you receive this error from a server it could be one of these problems: 
• The site you are trying to log into requires a special user name and or password in order 

to transfer files.  
o Contact the administrator of the site, and find out if you need to be using a special 

user name or password, and whether or not you can access that site.  
• The permissions on the site are incorrect, so even though your user name and password 

are correct, you are unable to upload or download.  
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o Contact the administrator of the site, and make sure that your user name and 
password have read and write permissions set correctly.  

• You cannot upload because the server you are sending to is full, and will not allow 
more files to be uploaded.  
o Delete files that are no longer used, or ask the administrator for more space on the 

system.  
• The file name you are using has a space or a character that the server will not allow.  

o Double-check with the administrator of your site about which characters are 
accepted on your server, and rename the files to an acceptable name.  

• 

o 

� 

� 

A communication error is occurring between the FTP host and your computer, making 
data transfer impossible.  

If CuteFTP has worked in the past, change nothing and wait a little while to see if 
the problem is caused by Internet traffic. If this is the first time you are trying to 
connect, try using the other hosts types rather than Auto-detect.  

CANNOT RESOLVE HOST NAME MESSAGE 

The Cannot Resolve Host Name message is displayed when CuteFTP cannot make a 
connection to the FTP Host Address that you specified when you set up the connection. It 
could be compared to browsing to a Web site that either is not up at the moment, or does 
not exist. There are several ways to approach this situation: 
� Make sure you are connected to the Internet. If you are not connected to the 

Internet, you will need to connect before you can connect to any FTP sites.  
Make sure you typed in the FTP Host Address correctly. This would be just the 
host address of the server. For example, if you were given an FTP Host Address in 
the format: ftp://ftp.yourhost.com, you would only type in ftp.yourhost.com. Also 
be sure there is nothing after the host address, especially slashes ("/") indicating 
subdirectories. If the server does not automatically put you in your default directory 
when you log in to it, then you can add the directory into the "Default Remote 
Directory" box when configuring this site.  
If you have a firewall or proxy server, make sure CuteFTP is properly configured to 
work with the proxy server. You can edit the firewall or proxy settings by clicking 
Tools > Global Options and expanding Connection and selecting Proxy Server. 
If you are not sure what the settings for the proxy should be, you will need to 
contact your network or system administrator for that information.  

 
If all of these options fail and you still have the same results, you will need to contact the 
server administrator of the site you are connecting to in order to resolve the problem. 

CHILD TRANSFER FAILED 

If you attempt to transfer a folder or directory and see this error, it simply means that an 
item or items within the folder failed to transfer. You can check your connection log to find 
a more detailed error describing why the item failed to transfer.  
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NOT ENOUGH CREDITS TO DOWNLOAD 

You may not be able to download from some FTP sites until you have uploaded something 
to them. In other words, you have to give them a file before they give you one -- a type of 
file trading. Most of these "ratio sites" have a text file that explains how to upload files to 
them and get credits. If you have any problems, contact the administrator of the site.  

PERMISSION DENIED 

If you receive this message, your server administrator has not established your permissions 
correctly. You will need to call the server administrator to reset the permissions. Every time 
an FTP account (for uploading your Web pages) is opened, your server determines all the 
things that you are allowed to do, like upload, download, write to a file, delete a file, make 
new directories, etc. If permissions have not been set up correctly, it will cause these types of 
problems.  
 
If any transaction you try with CuteFTP doesn't seem to be accomplished, refer to the log 
(the lower part of the remote pane in the CuteFTP Professional window, and the top 
window in CuteFTP Home) for any entries that are colored red or any message boxes that 
appear indicating a potential problem on your server's end. 

PORT ALREADY IN USE ERROR WITH DIAL-UP VPN 

If you are connecting to a Virtual Private Network through a modem and receive the Port 
already in use error when trying to connect, do the following: 

1. From the menu, choose Tools > Global Options. 
2. In the left pane, expand Connection.  
3. Select DUN/LAN 
4. In the right pane choose Connect to the Internet using a LAN. CuteFTP uses the 

existing connection.  
5. Select OK. 

SHELL CANNOT GET DATA FROM TE 

If you see this error, there is not enough space in your Temp folder to run CuteFTP. 

To correct the error 
• Make sure the path to the Temporary Files folder (Temp) is valid. 
• Make sure their is enough space to run the program on the drive where the 

Temporary Files (Temp) folder exists. 

Configuration notes 
• A valid path for a temp folder on a Windows 2k or XP machine would be similar to 

this:  C:\Documents and Settings\USER\Local Settings\Temp 
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• A valid path for a temp folder on a Windows NT computer would be similar to this: 
C:\Temp 

• This issue is more likely on machines with several different users with different 
accounts, each user's account needs a valid Temp folder on a hard drive with enough 
room to run CuteFTP. 

CONNECTING AFTER A 425 ERROR 

If you receive an 425 error, or an error that says "Cannot open data connection" or "Cannot 
build data connection", try connecting in PASV mode. If you still cannot connect, you can 
try connecting via HTTP and port 80. Enter all your information as you would for an FTP 
site. 

To connect via HTTP and port 80 
1. From the menu, choose File > New > HTTP Site. The Site Properties dialog 

appears showing the General tab. 
2. In Label, enter any name you would like for the site. 
3. In Host Address, enter the regular FTP address for the site. 
4. In Username, enter your user name for the site. 
5. In Password, enter your password for the site. 
6. Select Connect. 

SOCKET ERROR 2000 

This error generally occurs when port 21 is blocked on your computer. The port could be 
blocked by a firewall or a proxy server that has not been configured properly. Generally 
you'll see a log like this: 
 

STATUS:> Connecting to server xxx.xxx.x.xx (ip= 
xxx.xxx.x.xx)... 
ERROR:> Can't connect to remote server. Socket error = 
#2000. 
ERROR:> Timeout (60000ms). 
STATUS:> Waiting 30 seconds...... 

 
To avoid this error, open port 21 to inbound and outbound traffic.  Most often a firewall 
(such as those from MacAfee, Norton or the built-in Windows XP firewall) is blocking 
inbound or outbound TCP traffic on port 21. 

SOCKET ERROR = #10061 

10061 is a Connection Refused error sent to you by the server. You could not make a 
connection because the target machine actively refused it. The most common cause is an 
incorrectly configured server, full server, or incorrect Port specified by the client.  
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To change your connection Port for an FTP site 
1. Select the site in the Site Manager. 
2. From the menu, choose File > Properties. 
3. Select the Type tab. 
4. Enter the correct port number in the Port text box. 

Sometimes a 10061 error is caused by either a firewall or anti-virus software presence on the 
local computer or network connection.  Either one may be blocking the ports needed to 
make a successful FTP connection to the server.  
For a regular FTP session, please either disable the firewall or anti-virus software or 
configure it to allow CuteFTP to establish an FTP session over ports 20 and 21. Please 
consult the documentation or help file for your specific firewall or antivirus software 
product for further instructions. Usually, the manufacturer of the device or software has 
specific instructions available on their Web site. 
If you continue to receive the same error after insuring ports 20 and 21 are open, please 
contact the administrator of the site where you are trying to connect. 

SOCKET ERROR = #10060 

10060 is a Connection Time-out error that usually appears when the client does not receive a 
response from the server for a specific command. 
 
Most often this occurs when you try to connect in PASV mode to a server that prefers 
PORT for data connections. If you see an error log similar to the one following, right click 
the problem site and choose Site Properties, click the TYPE tab and change the Data 
Connection Type to Use PORT.  
 

COMMAND:> PASV 
227 Entering Passive Mode (xxx,xx,xxx,xx,x,xxx). 
COMMAND:> LIST 
STATUS:> Connecting ftp data socket xxx.xx.xxx.xx:xxxx... 
ERROR:> Can't connect to remote server. Socket error = 
#10060. 
ERROR:> Failed to establish data socket. 

 
If you still receive a 10060 error, the server may be trying to send a listing for a very large 
directory (with many thousands of files) causing the client to time-out while waiting. Try 
increasing the time-out value under Tools > Global Options > Transfer > Reconnect 
and resume in [n] seconds if nothing received, to a higher value, such as 45 or 60 
seconds. 
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FAILED TO ESTABLISH DATA SOCKET 

This error usually occurs when trying to connect in PASV mode to a site that only accepts 
PORT mode connections. Change the connection type from PASV mode to PORT mode to 
connect to the site.  

To switch from PASV to PORT mode  
1. In the Site Manager, select the problem site. 
2. From the menu, choose File > Properties.  
3. Select the Type tab.  
4. In the Data connection type list, select Use PORT. 
5. Select OK. 

SOCKET ERRORS 10060, 10061, 10064, 10065 

A socket error in the 10060 range is a Winsock error. It is generally caused by either 
outgoing connection problems or connection problems on the host end.  

Firewall and AV Software 
Outgoing connections can be affected by the presence of firewall or anti-virus software on 
the local computer or network connection.  Either one may be blocking the ports needed to 
make a successful FTP connection to the remote server.   
 For a regular FTP session, please either disable the firewall or anti-virus software or 
configure it to allow CuteFTP to establish an FTP session over ports 20 and 21.  Please 
consult the documentation or help file for your specific firewall or antivirus software 
product for further instructions.  Usually the manufacturer of the device or software will also 
have specific instructions available on their Web site. 
If you continue to receive the same error after insuring ports 20 and 21 are open, contact the 
administrator of the site you are trying to connect to. 

Technical reasons for 1006x errors 
WSAETIMEDOUT (10060) 

1. The connection fails due to an error or timeout. 
2. Verify that the destination IP address is correct.  
3. Increase the connection timeout threshold under Global Settings > Connection. 
4. Switch to the opposite data connection type (PASV or PORT) under Site Settings 

> Type tab. 
5. Verify that the problem is not local by trying to connect to an alternate server. 
6. If a server name was used, verify it resolves to the correct address. 
7. If using a local server table for server name resolution, check to see that it doesn't 

resolve to an obsolete address. 
8. Try pinging the address. 
9. If you are using a router, verify the router is up and running (check by pinging it and 

then ping an address outside of the router). 
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10. Do a traceroute to the destination to verify all routers along the connection path are 
operational. 

11. Verify that your subnet mask is setup properly. 

WSAECONNREFUSED (10061) 

1. The remote host actively refused the attempt to connect to it. 
2. Verify that the destination server name or IP address is correct  
3. Verify that the connection port number is correct (under Site Settings | Type tab). 
4. The remote server may be temporarily or permanently inaccessible (try again later). 
5. Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have 

setup all required options for that protocol.  
6. Verify that the destination IP address and port numbers are correct.  
7. The remote server may be refusing multiple connections from the same client. Try 

using only one connection thread when connecting to this particular server (Site 
Settings | Options). 

8. Try pinging the address. 
9. If you are using a router, verify the router is up and running (check by pinging it and 

then ping an address outside of the router). 
10. Do a traceroute to the destination to verify all routers along the connection path are 

operational. 
11. Verify that your subnet mask is setup properly. 

 
WSAESERVERDOWN (10064) 

• The server is temporarily or permanently unreachable. Verify that the 
destination host name or IP address is correct and try again later. 

 
WSAESERVERUNREACH (10065) 

• The server is unreachable. Verify that the destination host name or IP address 
is correct and try again later. 

SFTP ERROR #4 

This is a general SFTP connection error. See Trouble Shooting SFTP connections for help. 

ERROR 421 MESSAGES 

Common Error 421 Problems 
• Error 421 Service not available, closing control connection.  
• Error 421 User limit reached 
• Error 421 You are not authorized to make the connection 
• Error 421 Max connections reached 
• Error 421 Max connections exceeded 
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Possible Solutions 
You can receive that 421 error if the FTP server you are connected to limits the total 
number of connections available or limits the connections available to one user.  There are 
three things you can do: 

1. Limit the number of connections to any one FTP site by selecting Tools > Global 
Options > Connection and set "Per site max connections /transfers" to 1 (By 
default it will be set to 2). 

2. Remove items from the Transfer Queue.  The Transfer Queue is where you see 
items ready for transfer, in transit, or just transferred.  Sometimes the Queue Pane 
can become cluttered with unfinished transfers.  To clear the queue, right-click inside 
it and choose Remove All. 

3. Make sure only one instance of CuteFTP is running on your system.  Open the 
Windows Task Manager and see if CuteFTP is listed more than once. 

INSTALLSHIELD ERROR 1628: FAILED TO COMPLETE SCRIPT BASED INSTALL 

Problem: 
The following error message occurs at run time:  

Error 1628: Failed to complete script based install. 

More Information 
The error message occurs at run time usually when you are trying to uninstall, repair, or 
update an installation. This error message is caused by the Windows Installer Service and is 
often caused by the installation itself. 

Possible Cause 1 

This error message is often caused when the uninstallation log file becomes corrupt. This 
can happen if the installation is somehow corrupt.  
Fix:  End the process that is running IDriver.exe via the Task Manager by following these 
steps: 

1. Press Ctrl + Alt + Del and select Task Manager.  
2. Go to the Processes tab.  
3. Check the running processes for idriver.exe 
4. If found, select the process and then select End Process. 

Run the installation again to see if the error still occurs. 

Possible Cause 2 

This error can also occur if the Windows Installer Service is not properly configured on your 
computer or if the installation is created with a newer version of the Windows Installer 
Service than what exists on your computer. 
Fix:  To fix this issue, install the latest Windows Installer Service on your computer. 
 Instructions and download links for the Windows Installer can be found below.  Just click 
on the link for your operating system. 

Windows 95/ 98/ Me: 
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http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEB
BACD8-C094-4255-B702-DE3BB768148F
 
Windows NT 4.0 or 2000: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=4b6140f9-2d36-4977-
8fa1-6f8a0f5dca8f&DisplayLang=en
 
Windows XP: 

Windows XP already contains Windows Installer version 2.0. Thus, you should not 
have to install the Windows Installer Service (MSI engine) on Windows XP. 

Restart your computer and run the installation again to see if the error continues to occur. 

Possible Cause 3 

This error message may also occur if a file in the Temp directory is conflicting with the files 
being used by the installation while it is being run.  
Fix:  Delete the entire contents of the Temp directory using these steps:  

1. Double-click the My Computer icon on your desktop or select Start > Explore.  
2. Navigate to the location of the Temp directory, for example, C:\Windows\Temp.  
3. Select Edit > Select All.  
4. Select File > Delete.  
5. Click Yes or Yes to All in the dialog that appears.  

Run the installation again to see if the issue is resolved. 

Can't connect to server 
Making one or more minor configuration changes usually solves connection problems quite 
easily.  
 In the Log window there is a complete list of all communications and commands between 
CuteFTP and the FTP server you are trying to connect with. In that list there is at least one 
ERROR message in red. You probably need to scroll up to see it.  That error message 
should tell you the specific reason why you cannot connect.  
 The most common problem is that the Host Address, the User Name or the 
Password has been entered incorrectly.  Make sure all three pieces of information exactly 
match what the administrator of the Server you are connecting with provided. 
 

Cannot see files or folders 
If you cannot see your directory listing or files you can try these solutions to display files or 
folders.  
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YOUR CONNECTION LOG SHOWS A LIST-L COMMAND INSTEAD OF THE NORMAL 
LIST 

1. From the menu, choose Tools > Global Options > Navigation Settings > Links.  
2. Clear the Resolve links by sending LIST-L command check box. 
3. Select OK. 
4. Try to connect.  

CHANGE CONNECTION TYPE  

1. From the menu, choose Tools > Global Options. 
2. Select Connection.  
3. In the Connection type box, choose PASV.  
4. Select OK.  
5. Try to connect. If you cannot connect, follow the same steps, but choose PORT.  

TURN OFF ALL FILTERS  

1. Select the Site Manager tab.  
2. Seelct the problem site.  
3. Right-click the site and select Site Properties. 
4. Select the Actions tab. 
5. Select Filter.  
6. Clear the Enable filtering check box.  
7. Select Connect. 

USE THE -L FILTER ON THE SERVER  

1. Select the Site Manager tab.  
2. Select the problem site.  
3. Right-click the site and click Site Properties. 
4. Select the Actions tab. 
5. Select Filter.  
6. Select the Enable filtering check box. 
7. Select the Enable server side filtering check box. 
8. Enter -L in the Remote field.  
9. Select Connect. 

CHANGE SERVER HOST TYPE 

1. Select the Site Manager tab.  

251 



CuteFTP Professional User's Guide 

2. Select the problem site.  
3. Right-click the site and click Site Properties. 
4. Select the Type tab.  
5. Change the Host Type from Auto-Detect to the first specific server.  
6. Select Connect.  
7. If that does not work, try the next host type on the list.  

SEND AN EXTENDED LOG TO TECHNICAL SUPPORT 

If none of the solutions discussed here work, please obtain a raw directory listing and submit 
it along with details of the problem to GlobalSCAPE's technical support team. 

1. From the menu, choose Tools > Global Options > General > Logs. 
2. Select the Enable extended list in session log window (raw listing - for 

debugging) checkbox. 
3. Reconnect to the problem site. 
4. Once connected, right-click in the log pane located directly beneath the Remote 

Pane. 
5. Select Copy entire log to clipboard. 
6. Paste the selection (hold down Ctrl and press V) into an e-mail message. 
7. 

8. 

If you are having difficulty connecting to your SFTP server, refer to the following SSH2 
Connection Checklist: 

Describe the problem, what you have already tried and include information on the 
system you are using. 
Submit your support request using our support submission form. 

Can't connect to SSH2 (SFTP) sites 

SSH2 CONNECTIONS FAIL IF THE CLIENT OR SERVER IS NOT PROPERLY 
CONFIGURED.  

 
1. Verify that the server you are connecting to supports SFTP connections (see Note 

below). 
2. Verify the connection port. SFTP usually occurs over port 22. 
3. Try toggling the compression options in the SSH2 Security page 
4. Verify the authentication mechanism supported and required by the server. It may 

require password, public key (identity file), or both (see Important note below).  
5. If public key authentication is required, be sure to provide a copy of the public key 

you created to the server’s administrator, as it must be in the server’s trusted list in 
order for you to connect.  

6. If the server administrator created a public key for you, be sure to replace your 
existing one with it and select the provided key from within the SSH2 Security page. 
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7. Copy the connection log to a text file or e-mail to assist in troubleshooting when 
contacting your FTP or Web service provider or the GlobalSCAPE support team. 

Note: 
CuteFTP Professional supports SFTP, which is a secure service provided 
by the SSH2 host, in which the server both encrypts the data and handles 
the file transfer. This should not be confused with FTP over SSH2, in 
which the SSH2 uses port forwarding to forward standard FTP 
transactions over an encrypted tunnel, with the actual file transfer being 
handled by a separate (and non-secure) FTP server 

Public key authentication 
To use public key authentication, you must send your public key to the server administrator 
before making an SSH2 connection. If the server is running OpenSSH, convert the public 
key as described below: 
 

1. 

Command sequence: 

Create an identity file in the client. 
2. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.) 
3. The server administrator must convert the public key to OpenSSH, check it with 

wordcount, and add it to authorized_keys.  
 

ssh-keygen -i -f Identity.pub > sshpub 
wc sshpub 
cat sshpub > ~\.ssh\authorized_keys 
 

Note: 
Wordcount should return a "1" as the first number. OpenSSH is going to 
ask for the identity files password the first time you log in. If CuteFTP 
fails to connect, please contact our support team and provide the kernel 
version, OpenSSH build, and the CuteFTP Professional build number (to 
find that, choose Help > About from the menu.). 

Cannot create multiple connections to the same 
server 
If CuteFTP Professional does not open new connections when you try to start new sessions, 
or if it does not let you browse while transferring files, you can force CuteFTP to open new 
connections. 

TO OPEN MULTIPLE CONCURRENT CONNECTIONS 

1. Select the Site Manager tab. 
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2. Select a site in the Site Manager. 
3. From the menu, choose File > Connection > Connect. 
4. Repeat step 3 to create more connections to the same site. 

TO CONFIGURE CUTEFTP TO OPEN NEW CONNECTIONS FOR MULTIPLE TRANSFERS 

1. Go to Tools > Global Options > Transfer. 
2. Clear the Transfer files over the browse session check box. 
3. Go to Tools > Global Options > Connection. 
4. Make sure the value under Per site max connections/transfers value is greater 

than 1. 

Copy and Paste removes files from the remote folder 
FTP Servers do not support a "Copy" command. If you use "Copy" then "Paste" you 
actually move the file to the new location on the server, and the file is removed from the old 
location. You can "Cut & Paste" the file back if you need to restore the original file. This is a 
limitation of the FTP protocol.  

To copy a file or folder from one remote folder to another 
1. Download the file. 
2. Upload the file to the new location. Another option is to perform a site-to-site 

transfer. 

CONFIGURATION NOTES  

• Not all servers allow site-to-site transfers 
• You can accomplish a copy by downloading the file and then uploading again to the 

new destination folder, or by performing a site to site transfer on the same site (if the 
server allows it).  

• The copy command is in the menu, because you CAN copy files from the remote to 
the local pane, or to the queue, etc. 

Can't download files from a VMS server 

PROBLEM:  

When connected to a VMS server, downloads start, reach approximately 98% and never 
complete. They continually restart and try to complete but never do. 
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SOLUTION: 

From the menu, choose Tools > Global Options > Transfer > Smart Overwrite > 
Advanced Options. Clear the check in Use SIZE and MDTM commands to gather 
precise details. 

Site-to-site transfer limitations 
You can connect to two servers and transfer files between them using FXP (File eXchange 
Protocol). FXP lets you copy files from one FTP server to another. CuteFTP Professional 
supports this mechanism for transferring files between sites. 
When you transfer files between two remote hosts using an FXP client, the maximum 
transfer speed does not depend on your connection but only on the connection between the 
two hosts, which is usually much faster than your own connection. Because it is a direct 
connection you will not be able to see the progress or the transfer speed of the files. 

• 

• Each finished queue item takes up about 500 bytes of memory until the Transfer 
Engine is closed. 

Although FXPing is very easy, there are a few restrictions to transferring the files. Both hosts 
have to support PASV mode and must allow PORT commands to foreign hosts. The FXP 
client tells the destination FTP server to listen for a connection by sending a "PASV" 
command. The source FTP server then connects to the data port reported by the destination 
server (after a successful PASV command) All the data then goes directly from the source to 
the destination server and both servers only report fail/success messages to the FTP client. 

High memory usage 
If CuteFTP (specifically its Transfer Engine) is working for extended periods of time, it may 
begin to consume large amounts of system resources (memory and hard drive space) due to 
log and queue requirements.  
You can set CuteFTP to remove successful items from the queue to help alleviate this 
problem.   

TO REMOVE SUCCESSFUL ITEMS FROM THE QUEUE  

1. From the menu, choose Tools > Global Options > Transfer > Events. 
2. Select Navigation Settings. 
3. Select the Remove successfully finished items from the queue automatically 

check box.  
4. Select OK.  

CONFIGURATION NOTES 

Successful items are removed even if tasks were run without the user interface open. 

• Turn off logging to further improve resource management. 
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TO DISABLE LOGGING 

1. From the menu, choose Tools > Global Options > General > Logs. 
2. Select Logs. 
3. Clear the check boxes for logs you won't be needing. 
4. Select OK. 

Transferring to case sensitive servers 
Some servers are case sensitive and will treat two items with the same name typed in 
different case as two different files. For instance, if you sent a file called TEST.txt to a case 
sensitive server that already had a file called test.txt, you would not be prompted to 
overwrite the destination file, instead the server would keep both files.  If you connect to 
such a site in CuteFTP, CuteFTP will treat the files as the same, unless you change settings 
for the site. 

TO SET A SITE AS CASE SENSITIVE 

1. Select the site in the Site Manager. 
2. From the menu, choose File > Properties. 
3. Select the Type tab. 
4. In the Server type list choose Unix-compatible. 

Overwrite prompts me again and again 
If you are getting numerous overwrite prompts and want to avoid receiving them in the 
future, configure a default rule for the overwrite configuration panel. 

TO ADD A RULE  

1. From the menu, choose Tools > Global Options. 
2. Expand Transfer and select Smart Overwrite 
3. In the For matching files list, choose Use Rules. 
4. Select Ignore zero byte files . 
5. In the For matching folders list, choose Use Rules. 
6. Select Configure Rules. The Overwrite Rules dialog appears. 
7. In the If the destination file date is list select older. 
8. In the and size is list select smaller. 
9. In the during list select any transfer. 
10. In the then list select overwrite. 
11. Select Add. The new rule displays in the list. Add more rules as needed. Here are 

some recommendations: 
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• If destination file date is the same and size is the same during any transfer then 
skip 

• If destination file date is older and size is different during any transfer then 
overwrite 

• If destination file date is no matter and size is smaller during any transfer then 
resume 

• If destination file date is newer and size is larger during any transfer then skip 
12. Select OK. The Overwrite Rules dialog disappears. 
13. In the Prompt timeout action list, choose Skip. 
14. Select Timeout in, and leave the time at 30 seconds. 
15. Select Use LIST to determine overwrite status. 
16. Select Use SIZE and MDTM to determine overwrite status. 
17. Select OK. 

Using the ACCT command 
You can establish a connection and then supply the ACCT command for servers that require 
it.  

TO USE ACCT WITH OR WITHOUT AN FTP PROXY  

1. Select a site in the Site Manager. From the menu, choose File > Properties.  
2. Select the Options tab, and choose Use site-specific option under the Site-

specific configuration options drop down menu.  
3. Select Proxy. The Proxy dialog box appears. 
4. In the Proxy type list, select your proxy type. 
5. Select the Use authentication check box.  
6. Type the password (for ACCT) in the Password field.  
7. Make sure the HOST and PORT field are identical to your site's host and port as 

specified in the General and Type tabs.  
8. Select Advanced. The Advanced Proxy Settings dialog appears. 
9. Select CUSTOM.  
10. Add the following variables. Select Enter after each one: 

USER %user%  
PASS %pass%  
ACCT %fire_pass%  

11. Select OK to close the Advanced Proxy Settings dialog. 
12. Select OK again to close the Proxy dialog. 
13. Select Connect or Exit.  
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TO USE ACCT WITH AN FTP PROXY 

1. Select a site in the Site Manager. From the menu, choose File > Properties.  
2. Select the Options tab, and choose Use site-specific option under the Site-

specific configuration options drop down box.  
3. Select Proxy. The Proxy window appears. 
4. In the Proxy type list, select FTP proxy. 
5. Select the Use authentication check box.  
6. Type the password (for ACCT) in the Password field.  
7. Select Advanced. The Advanced Proxy Settings dialog appears. 
8. Select USER/PASS/ACCT.  
9. Select OK to close the Advanced Proxy Settings dialog. 
10. Select OK again to close the Proxy dialog. 
11. Select Connect or Exit.  

Using CuteFTP behind a router 
In most cases, CuteFTP does not have any problems working behind a router.  If you are 
having problems, try doing all your transfers in PASV mode. 

F CONNECTIONS OR TRANSFERS STILL FAIL

1. ake certain the Server and it's network 

2. it up for FTP, or 

3.  Global 

4. 
turn on port mapping under the Tools > Global 

Options > Connection tab. 

ONFIGURATION NOTES

• s 
ers. 

• 
ke data transfers in PORT mode using a Clear Command 

Channel SSL connection. 

I : 

Check with the FTP server administrator to m
are configured to allow FTP in PASV mode.  
Check your router documentation for information on how to set 
how to open the appropriate ports. FTP generally uses  port 21. 
You can define a port range for CuteFTP to operate with under Tools >
Options > Transfer Settings > Limit local port range from n to n. 
You can try using UPnP (if your NAT or router supports it) to establish a 
connection properly. You can 

C  

To perform transfers in PORT mode, or for secure transfers,  refer to your router'
documentation for information on how to configure the router for such transf
If you are behind a NAT firewall, and the Secure FTP server is on a different 
network, you can only ma
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Using CuteFTP with Norton Internet Security 2004 
If you have Norton Internet Security 2004 installed on the same computer as CuteFTP, you 
will need to adjust a setting in the Norton program to allow CuteFTP to make connections 
and transfers. 
Allowing CuteFTP to make connections will not compromise the other security settings in 
Norton Internet Security 2004. 

TO USE CUTEFTP WITH NORTON INTERNET SECURITY 2004 

1. Open Norton Internet Security 2004. You can open it by clicking the Norton 
Internet Security icon on your task bar.  

2. In the Norton Internet Security window, select Personal Firewall. 
3. In the lower right, select Configure. A dialog with tabs opens. 
4. Select the Programs tab. 
5. In the Manual Program Control section, scroll down to find ftpte.exe row. 
6. In the Internet Access column of the ftpte.exe row, click the down arrow next to 

Block All.  
7. In the list that appears, select Permit All. 
8. Select OK. Norton Internet Security 2004 should now allow CuteFTP to make 

connections and transfers. 

Cannot download executables 
If you use remote filters while connecting with some Unix or Linux servers, CuteFTP may 
not be able to download some of the files. You can download the files by simply turning off 
the filters. 

TO TURN OFF REMOTE FILTERS 

1. Select the Site Manager tab. 
2. Select the site with files you want to download. 
3. From the menu, choose File > Properties. The Site Properties dialog appears. 
4. Select the Actions tab. 
5. Select Filter. The Filter dialog appears. 
6. Delete any filters listed in Remote filter. You do not need to delete the -L filter. 
7. Select OK to close the Filter dialog. 
8. Select Connect to close the Site Properties dialog and connect to your site. 
9. Download your files. 
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Can't connect from Windows XP 
Some versions of Windows XP have an Internet Firewall built in, which is active by default 
and blocks FTP traffic. You can turn off this firewall. 

TO TURN OFF THE WINDOWS XP FIREWALL 

Follow the instructions Microsoft has posted at 
http://www.microsoft.com/WINDOWSXP/home/using/howto/homenet/icf.asp
 

Truncated listings 
If you connect to a server and you see 266-Options: -1 or 226 Output truncated to 2000 
matches, it means the server cannot display more than 2000 items in file listings. This is a 
limitation of the server and not CuteFTP. 

Help with scripts 
Due to the wide range of scripts that CuteFTP Professional is able to accommodate we are 
unable to offer technical support on individual scripts, other than what is available in the 
help files and online Knowledge Base.  
If you are having trouble with your script, try to perform the desired action manually, using 
the CuteFTP GUI.  If you cannot, then troubleshoot that problem first and then re-try your 
script.   
If you are able to perform the desired actions, and in the desired sequence when using the 
GUI, then the problem is not with CuteFTP or the FTP Server.  The next thing to do is to 
troubleshoot your script line by line.   
The Transfer Engine section has extensive scripting examples and help. 

Unable to connect to Titan FTP server when using SSL 
Disable Reuse cached session for data connection under Tools > Global Options > 
Security > SSL Security and try again. 

Firewall problems 
Outgoing connections can be affected by the presence of firewall or anti-virus software on 
the local computer or network connection.  Either one may be blocking the ports needed to 
make a successful FTP connection to the remote server.   
 If you are using a personal firewall software package please configure it so that ports 20 and 
21 are open.  It may also be necessary to grant specific permission for CuteFTP to access 
those ports.  If you need help configuring your personal firewall software please consult the 
documentation or the support section of their Web site. 
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Symantec (Norton) support site: 
http://www.symantec.com/techsupp/support_options.html 
 
McAfee support site: 
http://www.mcafeehelp.com 
 
Microsoft has complete instructions on how to disable the Internet Connection Firewall 
built into some versions of Windows XP.   
http://www.microsoft.com/WINDOWSXP/home/using/howto/homenet/icf.asp 

Conserve Local File Time feature doesn't work 
properly when connected to Serv-u FTP Server 
Problem 
When using CuteFTP (Home and Professional) to connect to Serv-u, the "Conserve Local 
File Time" feature doesn't work properly. 

Cause 
The MDTM command is supposed to be used for retrieving a file's time from the server. 
However, CuteFTP and various other FTP clients use the MDTM command change (set) an 
uploaded file's timestamp as well. 
The official draft documenting the MDTM command (draft-ietf-ftpext-mlst-16.txt) makes 
no provisions for using the MDTM command to set the file time stamp, so various clients 
and servers have ended up implementing the command differently. 
The typical command syntax is MDTM YYYYMMDDHHMMSS FILENAME, where the 
HHMMSS is either the client's actual local time zone, or in the case of some FTP clients, 
GMT (Greenwich Meridian Time), which mimics the retrieve behavior of MDTM as 
documented in section 2.3 of the afore mentioned IETF draft. 
A couple servers, such as Serv-u, have extended the MDTM command even further, adding 
a time zone parameter to the end of the MDTM command, as follows: MDTM 
YYYYMMDDHHMMSS[+-TZ] FILENAME. 
CuteFTP does not support this proprietary [+-TZ] parameter. Also, CuteFTP sends the 
local time for the HHMMSS portion of the MDTM command sequence, not the GMT time. 
Unfortunately, Serv-u (and potentially a couple other FTP servers) expect the time to be sent 
in GMT, and automatically adjust the time for the file, causing it to be different than what 
the client expected.  

Example 
CuteFTP retrieves a listing. File time shows 8:55 AM: 
 

-rw-rw-rw-   1 user     group       20249 May 14 08:55 
Reports.cfc 
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CuteFTP does an MDTM retrieve time to determine what the remote file's time is.  
Notice the server sends 12:55 PM, adding 4 hrs. due to the server's time difference and 
GMT: 
 

COMMAND:>       MDTM Reports.cfc 
                213 20040514125501 

 
CuteFTP uploads the replacement Reports.cfc file: 
 

STOR Reports.cfc 
 
CuteFTP issues an MDTM command to set the time according the actual date and LOCAL 
time of the file, 12:55 PM: 
 

COMMAND:>       MDTM 20040514125501 Reports.cfc 
 
Subsequently we retrieve the list from the server. Notice the time, 8:55 AM. 
 

-rw-rw-rw-   1 user     group       20249 May 14 08:55 
Reports.cfc 

 
Notice that the server didn't write the 12:55 timestamp as requested. Instead, it assumed the 
timestamp was in GMT and subtracted 4 hours.  

Workaround 
There are no known workarounds. 

Solution 
Don't turn on this feature when connecting to Serv-U or other FTP servers that modify the 
time sent as part of the MDTM set sequence. 
 

Public key authentication failing 

ATTEMPTING TO CONNECT IN CUTEFTP PROFESSIONAL TO WINSSHD USING 
PUBLIC KEY AUTHENTICATION ONLY SEEMS TO FAIL. 

After you set up an account for public key authentication you will still have to enter a 
password the first time you log in. This is because when you set up public key authentication 
for an account and set the authentication type to Pwd OR Key, WinSSHD still must cache 
the password so that you can log in with just the public key. Therefore, on your first login 
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attempt after you set up public key authentication, WinSSHD asks you for a password to 
store in the cache, even if your client already authenticated successfully using a public key. 
When this happens, just supply a valid password. When you log in after that, the password 
will be cached and you won't have to enter it again. 
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